asifhs

Synergy server configuration stuck in loop!

2 posts in this topic

Synergy
(Git cloned and compiled) Version: 1.10.0-stable-0badc0de
Build Date: Friday, July 13, 2018
Ubuntu
Release: 16.04.4 LTS
Kernel: 4.4.0-130-generic
Problem
1) Startup shows the main window with the following options pre-selected:
  
Server (share this computer's mouse and keyboard):
  
Use existing configuration:
   NOTE: The default synergy.conf does not exist.
2) Pressing the apply button causes the whole program to get stuck in a loop showing the dialog window, when the "No" button is pressed:

   Configuration filename invalid
   You have not filled in a valid configuration file for the synergy server...

3) The only way out is to press the "No" button and very quickly select the following option in the main window:
   Configure interactively:
4) Please see attached screen capture: serverConfigurationLoop.png

serverConfigurationLoop.png

Share this post


Link to post
Share on other sites
On 7/26/2018 at 10:22 AM, asifhs said:

Synergy
(Git cloned and compiled) Version: 1.10.0-stable-0badc0de
Build Date: Friday, July 13, 2018
Ubuntu
Release: 16.04.4 LTS
Kernel: 4.4.0-130-generic
Problem
1) Startup shows the main window with the following options pre-selected:
  
Server (share this computer's mouse and keyboard):
  
Use existing configuration:
   NOTE: The default synergy.conf does not exist.
2) Pressing the apply button causes the whole program to get stuck in a loop showing the dialog window, when the "No" button is pressed:

   Configuration filename invalid
   You have not filled in a valid configuration file for the synergy server...

3) The only way out is to press the "No" button and very quickly select the following option in the main window:
   Configure interactively:
4) Please see attached screen capture: serverConfigurationLoop.png

serverConfigurationLoop.png

Perhaps I'm confused, it is nearing 1 in the morning for me.

To me, based on the details you've provided in the post and the picture you've helpfully provided, this would only be unexpected behavior to me if the file does indeed exist, but it isn't detecting its existence.

To my knowledge, the recommended option is Configure Interactively as that will go through the process of creating the synergy.conf configuration file for you and provide you with in-program methods to configure it without going through the messy option of directly editing through a markup language.

Is there a specific reason that you're trying to manually point to a conf file?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now