MerF

2.0.12 requires libqt5core5a >=5.7.0

3 posts in this topic

Hello,

Been a synergy license holder for a couple of years now, and while not being really happy with Synergy 2, I've been chugging along and hoping that the next release will be the one that puts it all together finally.

I had been pretty content with 2.0.10 and had held back upgrading for a long time, then eventually got the itch to upgrade.  Went flawlessly on my Win10 desktop (which acts as my Synergy2 server, since gaming is impossible on a Synergy 2 client...sigh).  Also had little issues with my CentOS7 laptop, although it is getting a lot of disconnects now that it wasn't before I upgraded.

However, on my Mint 18 client I'm getting Qt5 dependency error that I need a version that's not available in any repo for Ubuntu 16.04/Mint 18.  My Mint desktop is my main work computer, so while I'm certainly capable of mixing/matching newer releases of Ubuntu's repositories then pinning the necessary dependencies, I would certainly rather not have to do this.

From searching, I've learned that this has happened before, where a version of Synergy was released with dependencies that broke non-cutting-edge distros (I mean...come on...Mint 18-3 is barely a year old) and "next releases" would fix the issue...but if the UX is build against this newest version of Qt5, I'm not sure how that would get fixed, short of distributing the necessary Qt5 libraries with Synergy2, or possibly creating your own repositories that support all of your dependencies, but that's a pretty enormous undertaking.

Please advise.

PS-  For now, I've been patient with the numerous disconnects and work-arounds to problems with Synergy 2.  As a software developer, I 100% supported your work with a license...actually a few licenses since I convinced a few folks from the old job to hop onboard...but it's getting really tiresome, guys and gals.  Synergy 2 really should be in a working state right now with a UX that's...you know...usable.

Share this post


Link to post
Share on other sites

I've been running 2.0.12-beta on Mint 18.3, haven't had any issues whatsoever... maybe that's worth a try? 

Share this post


Link to post
Share on other sites

I ran into a similar dependency issue for several QT5 packages on RHEL 7.5.  I did a google search for the library yum/dnf said was missing (ex: libQt5Qml.so.5), then select the result for rpmfind and download the appropriate rpm from there (in my case, the CENTOS 7.5 rpm).  Is there a similar site to rpmfind for Ubuntu/Mint for deb download... perhaps packages.ubuntu.com?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now