Jason26

Synergy 2 Issues with Fedora 28.

1 post in this topic

I have 2 Fedora 28 machines. One is my desktop which is dual display, the second is a Thinkpad with its built-in display and an external display. The desktop is using nvidia drivers and running Gnome. The laptop uses the Intel drivers and was running Gnome on Xorg.

At first I was using Synergy 1, but run into an issue where the screen lock can't kick it. It is blocked by an application, and only happens when Synergy is running, so I'm guessing that application is Synergy so I decided to try Synergy 2.

The first install of Synergy 2 works well. However, after a reboot of the laptop I get:

synergy-service[1221]: [ Router  ] [2018-07-23T06:33:15] debug: Terminating core client read loop                                                                                      
synergy-service[1221]: [ Core    ] [2018-07-23T06:33:15] NOTE: disconnected from server                                                                                                
synergy-service[1221]: [ Core    ] [2018-07-23T06:33:15] DEBUG: retry in 1 seconds                                                                                                      
synergy-service[1221]: [ Core    ] [2018-07-23T06:33:16] NOTE: connecting to '127.0.0.1': 127.0.0.1:24801                                                                              
synergy-service[1221]: [ Router  ] [2018-07-23T06:33:16] debug: Saying Hello to core client                                                                                            
synergy-service[1221]: [ Router  ] [2018-07-23T06:33:16] error: Couldn't send message to node 193132: no route to node                                                                  
synergy-service[1221]: [ Router  ] [2018-07-23T06:33:16] debug: Route table is empty                                                                                                    
synergy-service[1221]: [ Router  ] [2018-07-23T06:33:16] debug: Handler failed to process core client message: HelloBack: [[version, [1, 6]], [screen_name, this.localdomain]]          
synergy-service[1221]: [ Router  ] [2018-07-23T06:33:16] debug: Terminating core client read loop                                                                                      
synergy-service[1221]: [ Core    ] [2018-07-23T06:33:16] NOTE: disconnected from server                                                                                                
synergy-service[1221]: [ Core    ] [2018-07-23T06:33:16] DEBUG: retry in 1 seconds

However, if I just leave it alone it eventually connects, after about 5 minutes or so and works.

This is with Xorg, and the screen locking problem persists.

If I switch the laptop to Wayland I run into 2 different issues:

  1. Control appears to switch to the laptop. I do not see a mouse pointer, but I do see various UI elements get their hover.
  2. When control is on the desktop, every few moments the mouse moves to the center of the screen.

So at least with Xorg, usage seems to be on par with the older version. But I do miss the hotkey stuff. But I'm keen to see this work well.

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now