skicombinator

Failed to connect to server: Incompatible Client 1.5

3 posts in this topic

Posted (edited)

Hi. Following is my setting:

Server: Ubuntu-Gnome 16.04 64bit (Synergy 1.10.0.stable_b36+275cdc1c_debian_amd64)

Client: Windows 7 64bit (Synergy version is same as server)

 

I got the error message on the client side when I'm trying to connect.

Of course, I've searched and found this article and some comments, but in my case it didn't helpful.

Especially I've tried re-install .deb package, but it failed because of the incompatible version dependency of libqt5core5a(Ubuntu 16.04 has only 5.5.1 as its latest version, while synergy needs more than 5.7.0 version of it).

Has anyone experienced similar issues?

Thank for the help.

Edited by skicombinator

Share this post


Link to post
Share on other sites

OK, I found that even I thought I've installed the latest version on Ubuntu 16.04, v1.10.0 stable, due to the libqt5core5a dependency issue, Ubuntu Software automatically installed v1.6.2 on my server machine, while the version of client machine is still 1.10.0-stable-275cdc1c. How can I fix this?

Share this post


Link to post
Share on other sites

Not that elegant solution, but still I solved this problem by installing the older version on Ubuntu server machine.. Hope the latest version's dependency issue will be fixed soon!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now