asifhs

Synergy 1.10.0 installation on Ubuntu 16.04 fails.

10 posts in this topic

Posted (edited)

Attempt to install synergy 1.10.0 on Ubuntu fails.

dpkg --install synergy_1.10.0.stable_b36+275cdc1c_debian_amd64.deb ;
(Reading database ... 410825 files and directories currently installed.)
Preparing to unpack synergy_1.10.0.stable_b36+275cdc1c_debian_amd64.deb ...
Unpacking synergy (1.10.0.stable~b36+275cdc1c) over (1.10.0.stable~b36+275cdc1c) ...
dpkg: dependency problems prevent configuration of synergy:
 synergy depends on libqt5core5a (>= 5.7.0); however:
  Package libqt5core5a:amd64 is not configured yet.
 synergy depends on libssl1.1 (>= 1.1.0); however:
  Package libssl1.1 is not installed.

dpkg: error processing package synergy (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.22-1ubuntu5.2) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20180209-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Errors were encountered while processing:
 synergy

 

Edited by asifhs

Share this post


Link to post
Share on other sites

Looks like some missing dependencies. Have you tried apt?

Share this post


Link to post
Share on other sites
Posted (edited)

Following is my attempt at installing all the dependencies.

wget http://ftp.br.debian.org/debian/pool/main/o/openssl/libssl1.1_1.1.0f-3+deb9u1_amd64.deb ;
dpkg --install libssl1.1_1.1.0f-3+deb9u1_amd64.deb ;# Successful

wget http://ftp.br.debian.org/debian/pool/main/i/icu/libicu57_57.1-6+deb9u1_amd64.deb ;
dpkg --install libicu57_57.1-6+deb9u1_amd64.deb ;# Successful

# wget http://archive.ubuntu.com/ubuntu/pool/main/d/double-conversion/libdouble-conversion1v5_2.0.1-3ubuntu2_amd64.deb
# dpkg --install libdouble-conversion1v5_2.0.1-3ubuntu2_amd64.deb ;# Already installed.

wget http://ftp.br.debian.org/debian/pool/main/d/double-conversion/libdouble-conversion1_2.0.1-4_amd64.deb ;
dpkg --install libdouble-conversion1_2.0.1-4_amd64.deb ;# Conflict with libdouble-conversion1v5.

wget http://ftp.br.debian.org/debian/pool/main/q/qtbase-opensource-src/libqt5core5a_5.7.1+dfsg-3+b1_amd64.deb ;
dpkg --install libqt5core5a_5.7.1+dfsg-3+b1_amd64.deb ;# Dependency failure: libdouble-conversion1 (>= 2.0.0)

dpkg --install synergy_1.10.0.stable_b36+275cdc1c_debian_amd64.deb ;# Dependency failure: libqt5core5a (>= 5.7.1)

Summary
synergy_1.10.0 requires:
   libqt5core5a_5.7.1 requires:
      libdouble-conversion1 conflicts with:
         libdouble-conversion1v5 needed by:
            libqt5qml5 ... which is needed by many other packages!
Details

  1. Ubuntu 16.04 already has libdouble-conversion1, but it is named "libdouble-conversion1v5".
  2. When trying to install libqt5core5a_5.7.1, the dependency "libdouble-conversion1" needs to be met.
  3. So libqt5core5a_5.7.1 cannot be installed because libdouble-conversion1 is not installed.
  4. Trying to remove libdouble-conversion1v5 (in order to install libdouble-conversion1) fails, because libqt5qml5 depends on libdouble-conversion1v5.
Edited by asifhs

Share this post


Link to post
Share on other sites

My system might be hozed!
I cannot do a dist-upgrade!

Share this post


Link to post
Share on other sites

Ok, I force-installed:
libdouble-conversion1
which caused the removal of:
libdouble-conversion1v5
Then I could not run apt-get dist-upgrade. It complained about dependency failures.
I think I resolved this by removing libdouble-conversion1 and reinstalling libdouble-conversion1v5.
I think I cannot use synergy 1.10.0.
But I paid for it! :-(
I would love to get it installed and working!

Share this post


Link to post
Share on other sites
Posted (edited)

Ok, I decided to go the compile and install route and it works. Here's what I did:

tclsh ;
uname -a ;
# Host: Linux 4.4.0-130-generic #156-Ubuntu SMP x86_64 x86_64 x86_64 GNU/Linux
sudo apt-get install libxtst-dev qtbase5-dev libavahi-compat-libdnssd-dev ;
set p synergy-core ;
set d $env(HOME)/Software/Bin/${p} ;
exec >&@stdout git clone https://github.com/symless/${p}.git ;
cd ${p} ;
git checkout -b v1.10.0-stable v1.10.0-stable ;
mkdir build ;
cd build ;
cmake -DCMAKE_INSTALL_PREFIX=${d} .. ;
make ;
make install ;

 

Edited by asifhs
  • Like 1

Share this post


Link to post
Share on other sites

By-the-way, I compiled and installed it on Ubuntu 16.04 LTS.

Share this post


Link to post
Share on other sites

Thanks so much.

It has taken me 8 hours to get to this point and get Synergy (1) working again!

I love Synergy, but this is hard work!!

Share this post


Link to post
Share on other sites

Good to see others getting it to work!
Hope folks will experiment or push the envelop and take it further.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.