Nick Bolton

Synergy 1.10 & The Enterprise Merge

5 posts in this topic

Synergy 1.10 is here! 🎉

In an effort to breathe some much-needed life back into Synergy 1, we’re working on some improvements.

We’re back in action after the recent company restructuring, and we’ve started by combining the Enterprise edition with the Pro and Basic editions.

This major release gives both business and personal users extra bug fixes and features, marking the first step in returning to Synergy 1 development. We’ll get back to developing Synergy 2 soon (now in beta), once we’ve shown Synergy 1 some love.

Oh, and Raspberry Pi support has been added to Synergy 1! 🥧

Here’s what’s new in Synergy 1.10.0:

  • Merged Enterprise edition fixes into Pro and Basic
  • Fixed a dependency issue on Ubuntu 18.04 (libcurl3)
  • Added support for Raspbian (Raspberry Pi)
  • Disabled Bonjour auto-config by default
  • And other minor fixes and enhancements

Check the release notes for more details.

Download Synergy v1.10.0

p.s. If you want to try out Synergy 2 Beta, you can buy early access (if you haven’t already done so).

Share this post


Link to post
Share on other sites

Installed on Mac 10.10.13 and Windows 10. Just a note, the Windows install appeared to get "stuck" on verifying install, probably almost 2 minutes. I just let it sit and after it got past that it was quick. Just wanted to put that out there in case anyone else has that issue and is wondering about it.

Share this post


Link to post
Share on other sites

Thanks for this. I ran Synergy 2 for a while to get the latest Pi support and it ran OK but I didn't like not being able to lock the server and it sometimes would lose the background service. It was only a little irritating sometimes, though, and overall I think it will get smoothed out and come up to speed and get new features. So I'm watching it. Everything worked except the clipboard on the Pi with the old version (1.4, I think, was the only thing available until 1.10.0) but now that works, too. Keep going and good luck.

  • Like 1

Share this post


Link to post
Share on other sites
25 minutes ago, Joel Gray said:

Windows install appeared to get "stuck"

Aha, yes we fixed that in Synergy 2, but we still need to back-port the bug fix. It's on our list!

Share this post


Link to post
Share on other sites

I'm encountering this too... but in my case, it's been stuck at "Validating install" for perhaps 30 mins so far.

Wondering whether I'll find I have a working Synergy install or not when I get in to work tomorrow!

(Ubuntu install ran smoothly though)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now