Jayson Garrett

macOS 10.14 Mojave Issues

43 posts in this topic

Posted (edited)

I didn't particularly expect it to work, but then, hope springs eternal.

Upon startup, I get the following error sequence:

ERROR: failed to create quartz event tap
ERROR: process exited with error code: 11
INFO: detected process not running, auto restarting
 

Edited by Kelvin Tran

Share this post


Link to post
Share on other sites

Also, for what it's worth, the beta of 2.0.11 shows the same error in its logs, too.

Share this post


Link to post
Share on other sites

got the same error on the public beta

Share this post


Link to post
Share on other sites

+1

Same  / not working on Mojave Beta 

Share this post


Link to post
Share on other sites
Posted (edited)

Unfortunately, new 1.10.0 does not work either

Edited by Section 8

Share this post


Link to post
Share on other sites

Hey guys.

Not a very good fix but wanted to let you know that I have managed to get things working on my particular setup.  

I use a Mac (running 10.14 Mojave) as the server and a Linux box (Cinnamon) as a client.  I have managed to get things working by installing the old (1.8.8-stable-c30301e) https://sourceforge.net/projects/synergy-stable-builds/ on the Mac.  I then installed the new Beta 2 of Synergy on the linux machine (using the ubuntu build).

It's not perfect and has dropped a couple of times but it seems to work.

I thought I would share in case anyone wants to run Synergy on the new Apple Beta 10.14 Mojave.

 

Share this post


Link to post
Share on other sites

Interesting that an older version still works. So hopefully it won’t be too big a stretch to get the more modern versions working again at some point relatively soon.

Share this post


Link to post
Share on other sites

Yes.  If you are trying to replicate.  I also forgot to mention to watch that the computer names are correct.  The older version defaults to [name].gateway.  But the new version (which runs on the client for me) expects [name].local.  Such a simple thing but it had be going for a while before I noticed it.

Share this post


Link to post
Share on other sites
1 hour ago, Andre DiCioccio said:

Hey guys.

Not a very good fix but wanted to let you know that I have managed to get things working on my particular setup.  

I use a Mac (running 10.14 Mojave) as the server and a Linux box (Cinnamon) as a client.  I have managed to get things working by installing the old (1.8.8-stable-c30301e) https://sourceforge.net/projects/synergy-stable-builds/ on the Mac.  I then installed the new Beta 2 of Synergy on the linux machine (using the ubuntu build).

It's not perfect and has dropped a couple of times but it seems to work.

I thought I would share in case anyone wants to run Synergy on the new Apple Beta 10.14 Mojave.

 

This, unfortunately, does not work for me... I'm running windows 10 as a server and mac as a client. Still no-go ;-\

Share this post


Link to post
Share on other sites

In my setup, I use a Mac as the server and a Windows 10 machine as the client. I still have the 1.8.8 installers lying around (I never get rid of Synergy distributions LOL) so I'm about to give a dual 1.8.8 setup a try.

Share this post


Link to post
Share on other sites

Unfortunately, I'm getting the same error using 1.8.8 on macOS Mojave Developer Beta 3.

 

Share this post


Link to post
Share on other sites

Can confirm that I've had no luck with Synergy 2, Synergy 1 (latest or 1.8.8) on Mojave Beta 3 as server. 

ERROR: failed to create quartz event tap
 

Share this post


Link to post
Share on other sites

Might try this with the new Mojave beta 4. Synergy2 is now working for me.

Share this post


Link to post
Share on other sites

Unfortunately still not working for me. 1.10 os x as a client and 1.10 win 10 as a server. Might give synergy 2 a try (have they brought back the preferences yet?)

Share this post


Link to post
Share on other sites

I can confirm that Synergy 1.10 still doesn't work on Mojave Developer Beta 5.

Share this post


Link to post
Share on other sites

Hi guys,

Just further.  I have been able to get a connection by running the latest Synergy 2 beta on a linux (CLIENT) and on my Mac running the old Synergy (1.8.8) (SERVER).

The connection has actually been pretty stable.

To get it to work I firstly loaded up the client (Synergy 2).  Then I run Synergy 2 on the Mac (SERVER).  This doesn't work of course.  But I then quit that Synergy 2 and run Synergy 1.8.8 and that works.  Not sure if it has anything to do with running Synergy 2 firstly?

Share this post


Link to post
Share on other sites

I gave Public Beta 6 (18A353d) a chance today on a test machine.   I'm still running 1.8.8 stable on both my Win10(server) and Mac 10.13.6(client). 

I tried to install 1.10.0 on the 10.14 Mojave Mac and that didn't work.  (Note: Did NOT try to upgrade my PC to 1.10)

I then tried to install the 1.8.8 version of Synergy (without SSL) on MacOS 10.14 Mojave and it does work but it's pretty slow and choppy.   Not 100% if that's a factor of having two Macs connected to my PC or more than likely the new OS causing performance problems. Anyway, just wanted to share my experience.  Would love to see an update to 1.10 for Mojave support soon!

Share this post


Link to post
Share on other sites

Hmm, interestingly I just tested the Mojave Mac again and it seems to be performing well so that might be more of a network issue?   With that said,  I might take the plunge and update my primary Mac to 10.14.   Surely, everything will go smoothly. 

Share this post


Link to post
Share on other sites

Surely :) 

I couldn't get any version of Synergy to work with previous Mojave beta releases. I did get Synergy 2 working with the latest beta, but did not test Synergy 1 at all. I'm running the server on the Mac, and client on Ubuntu 18.04.

Share this post


Link to post
Share on other sites
Posted (edited)

I am trying this using Mojave beta 7 and this is an excerpt from my log:

[ Service ] [2018-08-16T21:00:24] debug: starting core process with command: /Applications/Synergy.app/Contents/Resources/synergy-core --client -f --debug DEBUG --name Doug-MacMini --enable-drag-drop --profile-dir /Users/dougb/Library/Synergy --log /Users/dougb/Library/Synergy/synergy-core.log 127.0.0.1:24801
[ Service ] [2018-08-16T21:00:24] debug: core process started, id=5520
[ Core    ] [2018-08-16T21:00:24] INFO: drag and drop enabled
[ Core    ] [2018-08-16T21:00:24] DEBUG: screen shape: center=-1920,0 size=4480x1440 on 2 displays
[ Core    ] [2018-08-16T21:00:24] DEBUG: starting watchSystemPowerThread
[ Core    ] [2018-08-16T21:00:24] DEBUG: adopting new buffer
[ Core    ] [2018-08-16T21:00:24] DEBUG: creating quartz event tap
[ Core    ] [2018-08-16T21:00:24] DEBUG: started watchSystemPowerThread
[ Core    ] [2018-08-16T21:00:24] DEBUG: waiting for event loop
[ Core    ] [2018-08-16T21:00:24] ERROR: failed to create quartz event tap
[ Service ] [2018-08-16T21:00:25] debug: core process exited: exit code=0 expected=false error=Undefined error: 0
[ Service ] [2018-08-16T21:00:25] error: can't wait() on core process: waitpid(2) failed: No child processes
[ Service ] [2018-08-16T21:00:25] debug: core process I/O cancelled unexpectedly

This section basically repeats over and over.

I want to run the server on macOS Mojave, and client is Win 10, but due to this error the Synergy window shows the Win 10 box as the server.

Edited by DougB

Share this post


Link to post
Share on other sites

Wonder if we can get any feedback from someone on the Synergy team? I wrote in a while ago and they said they were working on it (among other things), but that was back in public beta 1. Just wondering whats happening!

Share this post


Link to post
Share on other sites

bump...

New public beta release build 18A384a still doesn't work :(

Share this post


Link to post
Share on other sites

I installed the Mojave beta before checking the forum and had to restore back to High Sierra. I use my personal MBP for work and use Synergy to connect to my Win10 work pc. Hoping now that the full version is out, they will update the app to work.  Still haven’t seen anything from the Synergy team.  I’m sure they are busy, but it would be nice to see a mention that they are working on making a compatible version. 

Share this post


Link to post
Share on other sites

Server: MacOS Mojave 

Client: MacOS Mojave

Synergy 1.10.1-stable-8941241e

ERROR: failed to create quartz event tap

Any update on getting a fix released for this?

Share this post


Link to post
Share on other sites

Same issue here, my workstations are essentially non-functional at this time.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now