Matthias Wegner

Not working on ubuntu 17.04

3 posts in this topic

Posted (edited)

I like to use Synergy on Ubuntu 17.04, but after installation i always get the information

 

FATAL: failed to start server: cannot bind address: Permission denied.

ERROR: process exited with error code: 1

 

I did not get it. I installed with sudo and i am root, so what permission should be enabled.

Regards,

Matthias

Edited by Kelvin Tran

Share this post


Link to post
Share on other sites

The issue that is occurring now, as can be seen by the error message, is that Synergy is failing to bind itself to a specific network interface or port number because a process higher than root is using it (i.e. a system process). 

1.) Try rebooting. I've seen that some processes like to be stubborn and hang around as a system process but will not start up again after a reboot and leave the network interface/port free for other applications to bind to.

2.) Note if the application is running with the same privileges as your user account. 

3.) Mess around with Synergy's preferences (NOT "Configure Server") and see if you can modify a specific port number, modify which specific network interface it is trying to bind to (if possible), etc.

4.) If this is possible (haven't been in front of a Linux terminal for a while), use a command that will allow you to check the PID/name of the process that is bound to specific port numbers/network interfaces.

Let me know if you have any other questions.

Share this post


Link to post
Share on other sites

I don't use Ubuntu primarily and am not extremely familiar with Linux distributions, but when I was using ubuntu with Synergy I ran into problems. I ended up having to start the service in terminal every time I booted up and if I disabled synergy it wouldn't work again after re-enabling. I'm running Linux Mint now and installed Synergy 2 and from a first time install, test, reboot and re-test it seems to be much more dependable. Again, my inexperience with Ubuntu could of affected my experience but I thought I'd share.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now