olaf3DE

Centos 6.7 installation problem

9 posts in this topic

Hi All. My name is Olaf.
Yesterday I bought one license of Synergy. Just one license because I need to test your product.
And here is a problem that can be a serious problem for me. I download Synergy v1.9.1, because
I need stable version for some production pipeline workflow.

On standard PC laptops like Dell E6520 with Windows 7 Pro 64bit installation was running fine.
One of them required the installation of Visual Studio 2017 for the installation to be successful.
But I need to install Synergy on two PC workstations with Windows 7 PRO 64bit and linux Centos 6.7 64 bit.
I downloaded the version for RedHut and for Fedora synergy-1.9.1-322.stable.2a0225c1.el7.centos.x86_64.rpm.
And here came the problem. During the installation, a message about missing libraries appeared.
Mainly everything that connects to QT5??? And here I have a request and a question...
Are you able to compile Synergy for Centos 6.7 so that it will works right out of a box?
If not, can you write exactly what the Synergy version for Centos might require (as for RedHut?).
QT5, some newer, newer GCC than default in 6.7, which version?
I really need Synergy and I'm counting on launching in our company.
I plan to buy a more licenses, but I must be sure that we will be able to run in our configuration.
I am also in a hurry with the decision to buy.
Cheers
Olaf Przybyszewski
www.3de.com.pl

Share this post


Link to post
Share on other sites

Hi guys. Can I have some update in this matter please? Synergy this is very urgent for me.

Cheers, Olaf

Share this post


Link to post
Share on other sites
Posted (edited)

Hi

From what i can understand, you are trying to run a CentOS 7 rpm (synergy-1.9.1-322.stable.2a0225c1.el7.centos.x86_64.rpm) in a CentOS 6 environment... This will most likely fail.

You can compile synergy on el6 i'm pretty sure altho not certain how much work it is -- i mean not certain the required dependencies are available thru yum and you might have to build/install some or even most of dependencies. I have really no idea, really... But i will have a look soon.

In the meantime, you could try installing v1.8.8 ... here's a code that should work

# Install dependencies needed (if not already installed...)
yum -y install qt qt-x11 libXrandr libXtst avahi-compat-libdns_sd libXinerama libICE libSM libX11

# Download v1.8.8 rpm to /tmp
wget -4O /tmp/synergy-v1.8.8-stable-Linux-x86_64.rpm http://rpmfind.net/linux/sourceforge/s/sy/synergy-stable-builds/v1.8.8-stable/synergy-v1.8.8-stable-Linux-x86_64.rpm

# Install using rpm
rpm -Uvh /tmp/synergy-v1.8.8-stable-Linux-x86_64.rpm

 

You can checkout an asciicast of this at Synergy v1.8.8 installed on CentOS 6

 

Hope this helps a little

Edited by Mathieu Aubin

Share this post


Link to post
Share on other sites
Posted (edited)

Hi Mathieu.
Yes, I did not notice ( was very sure? ) that this file is for the RedHut 7.xx version. I was not in possession of links to some archive
where I was able to find some earlier versions compatible with Centos 6.xx. I am also not so proficient to make compilations myself,
and our SoftwareDev people in our studio are always very busy with other stuff.

However, thanks to Sarah's quick reaction from Synergy support I got a specific link to the synergy-v1.8.8-stable-25a8cb2-Linux-x86_64.rpm
version, which works very well on Centos 6.7.

Of course, Synergy software on pure Centos 6.7 still requires to install avahi-compat-libdns_sd-0.6.25-17.el6.i686.rpm and at front of this
you need to install some additional packages like:

avahi-libs-0.6.25-17.el6.i686.rpm
avahi-libs-0.6.25-17.el6.x86_64.rpm
dbus-libs-1.2.24-8.el6_6.x86_64.rpm

...but it succeeded and works fine. :)

Anyway, Thank you for helping Mathieu and for Sarah from Synergy Support. Now I will buy some more licenses :)

(STATUS SOLVED)

Edited by olaf3DE

Share this post


Link to post
Share on other sites

I don't know if you noticed but i wrote (and showed) the exact steps to make it work..

Have you even checked the asciicast (text-video link i created for you)? It shows that trying to install v1.8.8 will break without installing other libraries. Then it shows the command line installing the libraries from package manager then synergy installs fine... i even commented the lines to explain a little what each does.

This command installs everything needed without the need to download rpms -- YUM is centos package manager and takes care of everything in a safe way. It also takes care of updating and maintaining a clean system.

yum -y install qt qt-x11 libXrandr libXtst avahi-compat-libdns_sd libXinerama libICE libSM libX11

You also must understand what you install -- You seem to install 32bit stuff mixed in with 64bit stuff (look at the rpms names... x86_64 = 64 bit, i686 = 32 bits). Installing stuff at random and/or incompatible libraries WILL BREAK your system at one point or another, guaranteed.

Its also a very bad habbit to install stuff directly from downloaded rpms without using the package manager (when the packages are available that is). Dependencies problems can quickly escalate to a real nightmare, specially for unexperienced users

Anyways, i am glad you got it working, one way or another. -- (oh, i have achieved compiling v2.0.0 on centos6 with success... using v1.8.8 GUI with v2.0.0 core - it is a 'hack' yes, but provides best of both worlds)

Bottom line is... if you are truly installing in a company setup where you have multi installations, do it the right way. If you need help, you can write me - i am full-time linux server administrator

Share this post


Link to post
Share on other sites
Posted (edited)

Mathieu, thank you very much for clarifying a few things. I'm not really an IT guy :)
Here, I was wrong and in fact my Centos 6.7 did not install avahi-libs-0.6.25-17.el6.i686.rpm for 32bit.
(I can not edit my previous post to correct the information.)
Sorry... I was in a hurry and an error crept in when I was download different things to test.

In my case it is quite difficult to install and compile anything.
I only did a quick test myself if Synergy software "works" in the configuration I need it, i.e. Windows 7 Pro 64 bit with Centos 6.7 64bit.

We have a lot of restrictions in the production environment and we can not install on workstations using the Internet and YUM as a normal user.
Everything is installed using local repos, which are specially prepared by Adnim and automated by special software and some other stuff.
It's good to know that there is someone here who understands well Centos and installations by "the right way".
I think I may be interested in your help soon enough.

Cheers
Olaf

Edited by olaf3DE

Share this post


Link to post
Share on other sites
Posted (edited)

Hi,

No need to be sorry friend. All is well.

But just so you know, there is absolutely no compilation requiered in the technique i have given you, only simple and basic centos terminal commands to be executed as super-user (root/admin). As i mentionned, installing libraries with downloaded rpms when they are available via the package manager (this means created and compiled specifically for your centos version) is exposing the system to potential library clashes/problems/corruption.

If you can install rpm files directly, which such operation requires administrative privileges (root/admin), then you most likely are able to run YUM package manager and/or RPM program. RPM is more than a file format, its also the true name of RedHat's Package Manager, and YUM is in turn a user-friendly software layer built over top of RPM in order to help simplify libraries and programs management under RedHat and derivatives (redhat, centos, fedora and flavors built with a redhat core)

The asciicast/text-video i have created only contains the terminal part of the process since the server used is a virtual server and therefore has no graphical interface and/or monitor/keyboard/mouse or commonly available desktop user input devices. Yes, Synergy is useless on such server but thats not the point. It just goes to prove how quick and easy it is to install Synergy on even the most minimalistic CentOS 6 installation.

 

6 hours ago, olaf3DE said:

Everything is installed using local repos, which are specially prepared by Adnim and automated by special software and some other stuff.

I believe your interpretation of 'special software' and 'local repos' is exactly what i am and have been talking about this whole time. Super-user rights (your 'admin' has them) are requiered, as mentionned earlier. I do not believe he is preparing any 'special repositories or softwares' (other than typical compilations) and if he maintains he is and gets paid extra for such, i would suggest you investigate into the matter and have him/her proves the value of the extra expenses (as i said, if any).

Having a system administrator is mandatory, don't get me wrong. I just felt the need to express my opinion regarding an increasing and very misleading pest-problem that exists amongst many companies -- systems administrators lacking transparency and fairness/squareness.

Wish you well and don't hesitate to give my post a 'like' to help others using the forum

Edited by Mathieu Aubin
  • Like 1

Share this post


Link to post
Share on other sites
On 6/10/2018 at 1:42 PM, Mathieu Aubin said:

OMG, this is new to me. And it's amazing.

Share this post


Link to post
Share on other sites
8 hours ago, Nick Bolton said:

OMG, this is new to me. And it's amazing.

Yes, its some great stuff

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now