David

Sysinternal Desktops v2.0

1 post in this topic

Hi, I'm using Sysinternals Desktops v2.0 on Windows 8.1 with dual screens. With the newest release (1.7.1) I'm starting to have problems when not in the main desktop and switching between clients. Client: MAC 10.10 1) The actual behavior is when switching to second desktop cursor at first doesn't move to client. then after a couple of seconds it moves to the client but when switching back from the client back to the server. the curser moves back to the center of my first screen. 2) not sure how to explain this but when on second desktop when typing into a autocomplete dropdown it seems to selecting the first option after first character. almost if the one of the arrow keys are being press or tab key. is anyone else having this issue? Thanks!, David Debug log: [quote]DEBUG: started process, session=2, command="C:/Program Files/Synergy/synergys.exe" -f --no-tray --debug DEBUG --name Work --ipc --stop-on-desk-switch --enable-drag-drop --enable-crypto --profile-dir "C:\Users\xxxx\AppData\Local" -c "C:/Users/xxxx~1/AppData/Local/Temp/qt_temp.i13056" --address :24800 DEBUG: desk Sysinternals Desktop 1 window is 0x00110e20 DEBUG: shutting down because of desk switch to "Sysinternals Desktop 1" NOTE: disconnecting client "MAC" DEBUG: active sides: 4 DEBUG: event queue is ready NOTE: client "MAC" has disconnected DEBUG: unregistered hotkey id=1 DEBUG: adopting new buffer DEBUG: discarding 1 event(s) DEBUG: closed display NOTE: stopped server DEBUG: ipc disconnect, closing stream DEBUG: ipc disconnect, closing stream DEBUG: ipc client disconnected DEBUG: ipc client proxy removed, connected=1 WARNING: detected application not running, pid=10428 INFO: backing off, wait=2s, failures=1 DEBUG: getting elevated token, elevation required DEBUG: processes in session 2: csrss.exe, winlogon.exe, dwm.exe, explorer.exe, igfxEM.exe, igfxHK.exe, igfxTray.exe, itype.exe, ipoint.exe, taskhostex.exe, TSVNCache.exe, schedhlp.exe, googledrivesync.exe, TrueImageMonitor.exe, TibMounterMonitor.exe, PSUAMain.exe, googledrivesync.exe, IAStorIcon.exe, SettingSyncHost.exe, Desktops.exe, explorer.exe, ctfmon.exe, SkyDrive.exe, explorer.exe, ctfmon.exe, explorer.exe, ctfmon.exe, HelpLibAgent.exe, devenv.exe, Ssms.exe, notepad++.exe, mstsc.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, devenv.exe, WebDev.WebServer40.EXE, chrome.exe, synergy.exe, cmd.exe, conhost.exe, runas.exe, chrome.exe, chrome.exe, livecomm.exe, RuntimeBroker.exe, notepad++.exe, DEBUG: found winlogon.exe in session 2 DEBUG: got token 1192, duplicating DEBUG: duplicated, new token: 1188 INFO: starting new process DEBUG: launched syntool to check active desktop activeDesktop:Sysinternals Desktop 1 DEBUG: getting elevated token, at login screen ERROR: could not get session id for process id 4580 DEBUG: processes in session 2: csrss.exe, winlogon.exe, dwm.exe, explorer.exe, igfxEM.exe, igfxHK.exe, igfxTray.exe, itype.exe, ipoint.exe, taskhostex.exe, TSVNCache.exe, schedhlp.exe, googledrivesync.exe, TrueImageMonitor.exe, TibMounterMonitor.exe, PSUAMain.exe, googledrivesync.exe, IAStorIcon.exe, SettingSyncHost.exe, Desktops.exe, explorer.exe, ctfmon.exe, SkyDrive.exe, explorer.exe, ctfmon.exe, explorer.exe, ctfmon.exe, HelpLibAgent.exe, devenv.exe, Ssms.exe, notepad++.exe, mstsc.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, devenv.exe, WebDev.WebServer40.EXE, chrome.exe, synergy.exe, cmd.exe, conhost.exe, runas.exe, chrome.exe, chrome.exe, livecomm.exe, RuntimeBroker.exe, notepad++.exe, syntool.exe, DEBUG: found winlogon.exe in session 2 DEBUG: got token 1228, duplicating DEBUG: duplicated, new token: 1232 INFO: starting new process INFO: drag and drop enabled DEBUG: opening configuration "XXXXXXXXXXXXX" DEBUG: configuration read successfully DEBUG: plugins dir: C:\Users\XXXXX\AppData\Local\Synergy\Plugins DEBUG: plugins dir is empty: C:\Users\XXXXX\AppData\Local\Synergy\Plugins\*.dll DEBUG: screen shape: 0,0 3840x1080 (multi-monitor) DEBUG: window is 0x00100d30 ERROR: failed to get desktop path, no drop target available, error=2 DEBUG: adopting new buffer DEBUG: opened display NOTE: crypto disabled because of ns plugin not available DEBUG: active sides: 4 DEBUG: active sides: 4 DEBUG: desk Sysinternals Desktop 1 window is 0x00120e20 DEBUG: switched to desk "Sysinternals Desktop 1" DEBUG: desktop is now accessible DEBUG: registered hotkey ScrollLock (id=ef14 mask=0000) as id=1 NOTE: started server, waiting for clients DEBUG: event queue is ready DEBUG: add pending events to buffer DEBUG: accepted ipc client connection DEBUG: screen "Work" shape changed DEBUG: start ipc handle data DEBUG: ipc read: IHEL DEBUG: finished ipc handle data DEBUG: ipc hello, type=node INFO: watchdog status: ok DEBUG: started process, session=2, command="C:/Program Files/Synergy/synergys.exe" -f --no-tray --debug DEBUG --name Work --ipc --stop-on-desk-switch --enable-drag-drop --enable-crypto --profile-dir "C:\Users\xxxx\AppData\Local" -c "C:/Users/xxxx~1/AppData/Local/Temp/qt_temp.i13056" --address :24800 NOTE: accepted client connection DEBUG: received client "MAC" info shape=0,0 1440x900 at 720,450 DEBUG: active sides: 4 NOTE: client "MAC" has connected INFO: switch from "Work" to "MAC" at 0,704 INFO: leaving screen DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: open clipboard DEBUG: close clipboard INFO: screen "Work" updated clipboard 0 DEBUG: open clipboard DEBUG: close clipboard INFO: screen "Work" updated clipboard 1 DEBUG: send clipboard 0 to "MAC" size=12 DEBUG: send clipboard 1 to "MAC" size=12 DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead DEBUG: SetCursorPos did not work; using fakeMouseMove instead INFO: switch from "MAC" to "Work" at 3835,730 DEBUG: SetCursorPos did not work; using fakeMouseMove instead INFO: entering screen DEBUG: desk Default window is 0x00140f16 DEBUG: shutting down because of desk switch to "Default" NOTE: disconnecting client "MAC" DEBUG: active sides: 4 DEBUG: event queue is ready NOTE: client "MAC" has disconnected DEBUG: unregistered hotkey id=1 DEBUG: adopting new buffer DEBUG: discarding 1 event(s) DEBUG: closed display NOTE: stopped server DEBUG: ipc disconnect, closing stream DEBUG: ipc disconnect, closing stream DEBUG: ipc client disconnected DEBUG: ipc client proxy removed, connected=1 WARNING: detected application not running, pid=4644 INFO: backing off, wait=2s, failures=1 DEBUG: getting elevated token, elevation required DEBUG: processes in session 2: csrss.exe, winlogon.exe, dwm.exe, explorer.exe, igfxEM.exe, igfxHK.exe, igfxTray.exe, itype.exe, ipoint.exe, taskhostex.exe, TSVNCache.exe, schedhlp.exe, googledrivesync.exe, TrueImageMonitor.exe, TibMounterMonitor.exe, PSUAMain.exe, googledrivesync.exe, IAStorIcon.exe, SettingSyncHost.exe, Desktops.exe, explorer.exe, ctfmon.exe, SkyDrive.exe, explorer.exe, ctfmon.exe, explorer.exe, ctfmon.exe, HelpLibAgent.exe, devenv.exe, Ssms.exe, notepad++.exe, mstsc.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, devenv.exe, WebDev.WebServer40.EXE, chrome.exe, synergy.exe, cmd.exe, conhost.exe, runas.exe, chrome.exe, chrome.exe, livecomm.exe, RuntimeBroker.exe, notepad++.exe, DEBUG: found winlogon.exe in session 2 DEBUG: got token 1188, duplicating DEBUG: duplicated, new token: 1224 INFO: starting new process DEBUG: launched syntool to check active desktop activeDesktop:Default DEBUG: processes in session 2: csrss.exe, winlogon.exe, dwm.exe, explorer.exe, igfxEM.exe, igfxHK.exe, igfxTray.exe, itype.exe, ipoint.exe, taskhostex.exe, TSVNCache.exe, schedhlp.exe, googledrivesync.exe, TrueImageMonitor.exe, TibMounterMonitor.exe, PSUAMain.exe, googledrivesync.exe, IAStorIcon.exe, SettingSyncHost.exe, Desktops.exe, explorer.exe, ctfmon.exe, SkyDrive.exe, explorer.exe, ctfmon.exe, explorer.exe, ctfmon.exe, HelpLibAgent.exe, devenv.exe, Ssms.exe, notepad++.exe, mstsc.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, chrome.exe, devenv.exe, WebDev.WebServer40.EXE, chrome.exe, synergy.exe, cmd.exe, conhost.exe, runas.exe, chrome.exe, chrome.exe, livecomm.exe, RuntimeBroker.exe, notepad++.exe, syntool.exe, conhost.exe, DEBUG: did not find logonui.exe in session 2 DEBUG: getting non-elevated token DEBUG: duplicated, new token: 1240 INFO: starting new process INFO: drag and drop enabled DEBUG: opening configuration "C:/Users/XXXX~1/AppData/Local/Temp/qt_temp.i13056" DEBUG: configuration read successfully DEBUG: plugins dir: C:\Users\xxxx\AppData\Local\Synergy\Plugins DEBUG: plugins dir is empty: C:\Users\xxxx\AppData\Local\Synergy\Plugins\*.dll DEBUG: screen shape: 0,0 3840x1080 (multi-monitor) DEBUG: window is 0x00c70ea8 DEBUG: using desktop for drop target: C:\Users\xxxx\Desktop DEBUG: adopting new buffer DEBUG: opened display NOTE: crypto disabled because of ns plugin not available DEBUG: active sides: 4 DEBUG: active sides: 4 DEBUG: desk Default window is 0x00150e9e DEBUG: switched to desk "Default" DEBUG: desktop is now accessible DEBUG: registered hotkey ScrollLock (id=ef14 mask=0000) as id=1 NOTE: started server, waiting for clients DEBUG: event queue is ready DEBUG: add pending events to buffer DEBUG: accepted ipc client connection DEBUG: screen "Work" shape changed DEBUG: start ipc handle data DEBUG: ipc read: IHEL DEBUG: finished ipc handle data DEBUG: ipc hello, type=node INFO: watchdog status: ok DEBUG: started process, session=2, command="C:/Program Files/Synergy/synergys.exe" -f --no-tray --debug DEBUG --name Work --ipc --stop-on-desk-switch --enable-drag-drop --enable-crypto --profile-dir "C:\Users\xxxx\AppData\Local" -c "C:/Users/xxxx~1/AppData/Local/Temp/qt_temp.i13056" --address :24800 NOTE: accepted client connection DEBUG: received client "MAC" info shape=0,0 1440x900 at 55,631 DEBUG: active sides: 4 NOTE: client "MAC" has connected[/quote]

Share this post


Link to post
Share on other sites
I can only guess that probably this Desktops app is causing confusion for Synergy. Have you tried testing the same operations without having Desktops 2.0 running?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now