cacophony

Synergy working with Ubuntu 12.04 and 18.04

10 posts in this topic

Posted (edited)

I have Synergy 1.6.2 running on an old PC that is using Ubuntu 12.04. I'm about to setup a new PC with Ubuntu 18.04 and would like to be able to get Synergy working between these two computers to help with the multi-week setup process. What the easiest way to do this? 

I have licences for both Synergy 1 Pro and Synergy 2 Pro but I've read that Synergy 2 doesn't work on Ubuntu 12.04 and if I installed Synergy 2 on my new PC it wouldn't be compatible with Synergy 1. So do I need to get Synergy 1.6.2 running on my new PC as well? If I need that exact version where is the recommended place to get it?

Thanks!

Edited by cacophony

Share this post


Link to post
Share on other sites

Synergy 2.x.x is not compatible with Synergy 1.x.x

I upgraded to Ubuntu 18.04 last week. Synergy 2.0.10 works great on that Linux box.

As to whether the 12.04 installation will support Synergy 2.x.x, I wouldn't hazard a guess.

On recent updates of 2.0.x, I've noticed that newer versions are backward compatible, at least with the immediate previous version.

Either way, your system is going to have to have all Version 1 or all Version 2.

I expect some of our guru forum users will chime in with whether your 12.04 will support 2.x.x.

Share this post


Link to post
Share on other sites
29 minutes ago, GranPaSmurf said:

Synergy 2.x.x is not compatible with Synergy 1.x.x

I upgraded to Ubuntu 18.04 last week. Synergy 2.0.10 works great on that Linux box.

As to whether the 12.04 installation will support Synergy 2.x.x, I wouldn't hazard a guess.

On recent updates of 2.0.x, I've noticed that newer versions are backward compatible, at least with the immediate previous version.

Either way, your system is going to have to have all Version 1 or all Version 2.

I expect some of our guru forum users will chime in with whether your 12.04 will support 2.x.x.

When you keep in mind that 16.04 is the "LTS" (long-term support) release that is out and that even that is about to be a deprecated OS in place of another LTS release, it is important to keep in mind that 12.04 will be multiple generations old (I don't remember the exact year count), so it is important to note that v2 will most likely NOT support the 12.04 release of Ubuntu Linux.

  • Thanks 1

Share this post


Link to post
Share on other sites
4 hours ago, Kelvin Tran said:

When you keep in mind that 16.04 is the "LTS" (long-term support) release that is out and that even that is about to be a deprecated OS in place of another LTS release, it is important to keep in mind that 12.04 will be multiple generations old (I don't remember the exact year count), so it is important to note that v2 will most likely NOT support the 12.04 release of Ubuntu Linux.

THAT would be short-sighted since a lot of people who need Synergy need it because they have an older PC or OS that they need to support, but also want a more up to date main machine.

Share this post


Link to post
Share on other sites
8 hours ago, Davewill said:

THAT would be short-sighted since a lot of people who need Synergy need it because they have an older PC or OS that they need to support, but also want a more up to date main machine.

It's a temporary lack of support. XP and (I'm pretty sure) Vista are unsupported as well. I see your concern, and Nick has expressed a desire to add support for those deprecated operating systems in a later version (pretty sure 2.1). For now though, it's unsupported. Sorry.

Share this post


Link to post
Share on other sites

So I was able to get it kind of working but it won't let me activate the Synergy on my Ubuntu 12.04 setup, which I believe is preventing me from enabling encryption.

More detail:

I was able to upgrade to version 1.7.6 on my Ubuntu 12.04 PC by doing this;

wget -q -O - http://archive.getdeb.net/getdeb-archive.key | sudo apt-key add -
sudo sh -c 'echo "deb http://archive.getdeb.net/ubuntu trusty-getdeb apps" >> /etc/apt/sources.list.d/getdeb.list'
sudo apt-get update
sudo apt-get install synergy

But when I try to activate I get a server response with html code and a title of "301 Moved Permanently". It sounds like the activation service was changed/moved in a way that is not backwards compatible with earlier versions of Synergy.

I would like to get encryption enabled, so is there some alternative way to activate? 

Share this post


Link to post
Share on other sites

Synergy 2.0 will not work with Ubuntu versions prior to 16.04

Share this post


Link to post
Share on other sites
4 hours ago, Andrew Nelless said:

Synergy 2.0 will not work with Ubuntu versions prior to 16.04

That's fine, but how come I can't activate version 1.7.6?

Share this post


Link to post
Share on other sites
On 5/8/2018 at 11:22 AM, cacophony said:

That's fine, but how come I can't activate version 1.7.6?

I notice that your reply never got noticed.

What do you mean "activate version 1.7.6"? Did you have a key for the software?

Share this post


Link to post
Share on other sites
17 minutes ago, Kelvin Tran said:

I notice that your reply never got noticed.

What do you mean "activate version 1.7.6"? Did you have a key for the software?

To quote myself above: "But when I try to activate I get a server response with html code and a title of "301 Moved Permanently". It sounds like the activation service was changed/moved in a way that is not backwards compatible with earlier versions of Synergy."

So yes I have a purchased key for the software but when I tried to activate using the key I got an activation error. I've since upgraded the PC to a new OS so this issue is technically moot for me, but it's still disappointing that certain earlier version of the software fail to activate with valid keys.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now