Martin Fürholz

All kind of weird issues after Windows 10 April upgrade

18 posts in this topic

Hello,

today after I made the Windows 10 April upgrade to Windows 10 Version 1803 on my Synergy host PC, I am facing all kind of weird issues with Synergy (2.0.10-stable).

The mouse doesn't jump to the other Windows 10 client (a laptop) at all most of the time. And when it does, the mouse cursor becomes invisible, and doesn't go back to the other PC anymore.

On the other hand, for my other MacOS client the jump is by far too sensitive - the mouse jumps already to the other client when it is more than 200 pixels away from the border of the screen. But then I have the same issues on the MacOS client as on the other Windows client: the mouse becomes invisible, and I can't get it back to the host PC anymore. I have to stop the service.

I cannot continue using Synergy in this current state!

 

I didn't have *any* issues (apart from the issue that the mouse jumps back to the host when I type an '@' or other special character) before the Windows 10 April upgrade.

 

I already re-installed Synergy on all machines. I removed all PCs from the Synergy UI and added them again. But nothing helped. It just doesn't work anymore.

Please tell me that you tested Synergy with the Windows insider builds in the past couple of months/weeks so that you could get a hold of issues that might arise with this next Windows upgrade?

Share this post


Link to post
Share on other sites

And you're sure that this is directly caused by the 1803 update?

I'll look at the change-log of the 1803 update, but it's not implausible that there might have been a change to the input-control APIs that were used, as I know that the 1803 update was a fairly major update to the logistics of input control.

@Steve Williams, this is a fairly major issue as this is an update that is rapidly being pushed out. If we get any further reports, can we prioritize it on your development list?

Share this post


Link to post
Share on other sites

I updated 3 computers to Win 10 1803 yesterday and this morning, after a restart, they all seem solid.  I can't reproduce your issue since I don't have a MAC in my system.

Share this post


Link to post
Share on other sites
Posted (edited)
14 hours ago, Kelvin Tran said:

And you're sure that this is directly caused by the 1803 update?

I'll look at the change-log of the 1803 update, but it's not implausible that there might have been a change to the input-control APIs that were used, as I know that the 1803 update was a fairly major update to the logistics of input control.

@Steve Williams, this is a fairly major issue as this is an update that is rapidly being pushed out. If we get any further reports, can we prioritize it on your development list?

I read in another thread in this forum that after the upgrade to Win 10 version 1803 the text scaling is causing issues similar to mine.

I have different text scaling on the 4 monitors of my host PC, and one of them is standing upright/vertically.

But I'm 100% certain that the issue started with the Windows 10 April update/upgrade, because I have been using the very same version of Synergy for a couple of days already before that upgrade. And had no issues.

 

I sent my logs to support.


Computer 1 (Laptop)
Operating System: Windows 10
Synergy Version: Synergy 2.0.10
Log: https://synergy-logs.symless.com/b8aec058cfeadace7bc424a0cf3a0d5e/logs/144-2018-05-01T23-58-25.log

Computer 2 (MARTINPC)
Operating System: Windows 10
Synergy Version: Synergy 2.0.10
Log: https://synergy-logs.symless.com/b8aec058cfeadace7bc424a0cf3a0d5e/logs/144-2018-05-01T23-57-38.log

Computer 3 (Martins-MBP.fritz.box)
Operating System: Osx 10.13
Synergy Version: Synergy 2.0.10
Log: https://synergy-logs.symless.com/b8aec058cfeadace7bc424a0cf3a0d5e/logs/144-2018-05-01T23-58-16.log

Edited by Martin Fürholz

Share this post


Link to post
Share on other sites

Someone suggested that going back to version 2.0.9 would fix the issue with text scaling. I will give that a shot soon.

Share this post


Link to post
Share on other sites

It works fine with Synergy 2.0.9.

So there is some issue with the combination of Windows 10 version 1803 and Synergy version 2.0.10.

 

This is my setup (the PCs have individual UI scaling (Windows settings) on each monitor):

Screenshot_20180505-185413.jpg

Share this post


Link to post
Share on other sites

Thank you Martin,

I was having the same issue where the cursor would become invisible after trying to jump screens.  I changed my Windows scaling option from 125% to 100% and it works again.

Now I just can't see anything because it's all too small!

  • Thanks 1

Share this post


Link to post
Share on other sites

I am having the same issue as well. Especially when I turn off a monitor or swap the display configurations.

Share this post


Link to post
Share on other sites

Interesting, we've not changes anything between 2.0.9 and 2.0.10 that should affect this. We'll take a look.

Share this post


Link to post
Share on other sites
18 minutes ago, Steve Williams said:

Interesting, we've not changes anything between 2.0.9 and 2.0.10 that should affect this. We'll take a look.

I don't think it's your fault. I believe it's a change in Windows that caused the issue. All of us have moved to 1803 which has been directly correlated to this issue.

  • Thanks 1

Share this post


Link to post
Share on other sites

This sounds like an issue with DPI awareness compatibility. Could someone running 1803 please confirm the status of the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

There should be a REG_SZ entry there for synergy-core.exe (full program files path) with the value "~ HIGHDPIAWARE WIN7RTM"

In the meantime we'll upgrade our boxes internally and start looking in to this.

Share this post


Link to post
Share on other sites
15 minutes ago, Andrew Nelless said:

This sounds like an issue with DPI awareness compatibility. Could someone running 1803 please confirm the status of the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

There should be a REG_SZ entry there for synergy-core.exe (full program files path) with the value "~ HIGHDPIAWARE WIN7RTM"

In the meantime we'll upgrade our boxes internally and start looking in to this.

image.thumb.png.de4c0b2f9b0c226b892b1d72a49e7a8a.png

  • Thanks 1

Share this post


Link to post
Share on other sites

@Martin Fürholz

Cheers, it sounds like this has stopped working in 1803. We will investigate. This however will not make it in to 2.0.11, which has already been tagged.

Share this post


Link to post
Share on other sites

This issue appears to be fixed for me in Synergy 2.0.11, but there's another new issue:

Every time the mouse cursor switches from server to client or from client to server, it jumps to the center of the screen for a brief moment.

Share this post


Link to post
Share on other sites

The issue of the mouse cursor jumping briefly to the center of the screen gets somewhat annoying when I have a control there with OnHover code, that code gets executed every time I switch to the client.

Share this post


Link to post
Share on other sites

I can add another data point: literally updated windows 10 to 1803 Just Now, and immediately lost ability to share with mac running high sierra. (Synergy 2.0.11)

I have four monitors on Windows, some with scaling, some without. 

Changed all monitors to 100%, and BAM- instantly can control the mac again!

Nothing else helped, restarting, rebooting, etc.

Oh, Windows, you so silly...

Share this post


Link to post
Share on other sites
On 5/8/2018 at 4:42 AM, Martin Fürholz said:

image.thumb.png.de4c0b2f9b0c226b892b1d72a49e7a8a.png

image.png.5bc814867ecac8c531a8bb802e38bda0.png

Same here.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now