Hypersphere

Reverting to Synergy 1.xx

10 posts in this topic

After much frustration with Synergy 2.xx, I have finally given up and reverted to Synergy 1.xx.

Unfortunately, Synergy 2.xx never did work well for me, even on a single-desk setup with a Windows 10 machine and two Linux machines, using the Windows 10 machine as the primary one from which I shared the keyboard and mouse with the two Linux boxes.

The situation became much worse when I installed Synergy 2 on a similar setup at work, where I had a primary Windows 10 machine sharing with a second Windows 10 machine and a Linux box. The problem here was that my home and work setups were generating conflicts through the Synergy central server. I had intende to add a third desk to the mix, but I discovered after contacing Synergy Help that I would have to purchase 2 additional licenses and set up 2 additional email accounts to make this work.

After thoroughly purging Synergy from my work computers, I installed Synergy 1.91 and set up my system without SSL encryption. Thus far, everything is working well.

I much prefer Synergy 1 over Synergy 2. I like the fact that I can configure things to some degree in Synergy 1, and I can disable SSL encryption. Synergy 2 is just too much of a black box, and I don't like the fact that I have to login to a remote server, which also gives rise to conflicts when there is more than one setup, as I have.

Does anyone know if Synergy maintains a user-accessible archive of prevoius Synergy versions? It turns out that the current Synergy 1 version, 1.91, is working for me, but it would be nice to know if other versions were available in case a given version does not work for some reason.

 

 

 

Share this post


Link to post
Share on other sites

I've never seen a download list like you describe, but existing users might be able to make arrangements to get older install files.

https://symless.com/contact

Share this post


Link to post
Share on other sites

I too have had to revert to version 1 after an frustrating couple of weeks with version 2.

Pretty basic setup: PC win10 server, Mac client.

v1 is flawless at reconnecting after server restart or client waking up after sleep.

v2 is nowhere near as robust - often having to restart both machines :( Given how awkward it is interacting with the client when synergy is not running - just couldn't continue with it.

The lack of a user defined configuration I suspect is at root cause - the auto connecting mechanism is far from perfect - think the devs should allow us users to define the config if we want to!

Share this post


Link to post
Share on other sites

@GranPaSmurf: Thanks for the suggestion. I have written to Synergy support asking if there is a Synergy archive of previous versions of synergy 1.xx. I am using 1.9.1 now and it seems to be working okay thus far, but if Synergy upgrades to a newer version that does not work for me, I would like to be able to drop back to an earlier version. As a safeguard, I will make my own backup of Windows and Linux editions of version 1.9.1.

@SpoddyCoder: I had thought that deleting version 2 from my work setup might still enable me to run version 2 at home, but my home setup is still giving me the same problems as before and like you describe as well. So, I am in the process of completely purging Synergy 2 from my home Linux and Windows machines and installing Synergy 1.9.1.

Even if Synergy 2 had worked, I still would prefer to have more control over configuration, especially encryption. I also don't like the idea of having to connect to the Synergy server to enable Synergy to work.

 

 

 

Share this post


Link to post
Share on other sites
3 hours ago, Hypersphere said:

I also don't like the idea of having to connect to the Synergy server to enable Synergy to work.

Oh wow - didn't know this about v2!

Pretty sure this may have been at the root of some of my frustration tonight - which was the straw that broke the camel's back & prompted me to roll back. The UK's primary telephone/internet backbone, BT, had a massive country-wide outage tonight - lasting several hours.

So we cannot use Synergy under those circumstances? Even tho our local network is fully up and running?... :(

Share this post


Link to post
Share on other sites
27 minutes ago, SpoddyCoder said:

Oh wow - didn't know this about v2!

Pretty sure this may have been at the root of some of my frustration tonight - which was the straw that broke the camel's back & prompted me to roll back. The UK's primary telephone/internet backbone, BT, had a massive country-wide outage tonight - lasting several hours.

So we cannot use Synergy under those circumstances? Even tho our local network is fully up and running?... :(

It is my understanding that with Synergy 2, it has to connect to the Synergy central server in order to work. One reason that I believe this is the case is that I have 2 benches at work with 3 computers on each bench, and I have another bench in my home office that also has 3 computers. I had installed Synergy 2 on all 9 computers. Each bench has 2 Linux boxes and a Windows machine. I noticed when running Synergy on any of the 3 benches that I was seeing computer names from the other 2 benches, and I was getting frequent labs and disconnects. 

I contacted Synergy tech support and was told I would have to get 2 more licenses and a total of 3 accounts (with 3 email addresses) to prevent interference among my 3 computer benches. Thus, even though each of my 3 computer benches were on separate local networks, they were talking to each other, presumably via the Synergy central server.

So, after a complete purge of Synergy from all 9 computers, I have installed Synergy 1.9.1 on all of them. No more cross-talk among the 3 separate LANs, and Synergy is thus far working just fine on each computer bench.

 

  • Like 1

Share this post


Link to post
Share on other sites
19 hours ago, mourngrym1969 said:

Synergy 1.8.8 is available here and gets rid of all the cloud black box spyware nonsense - https://sourceforge.net/projects/synergy-stable-builds/

Thanks for the tip. It is good to know that older versions are available in case newer ones introduce some sort of regression. So far, version 1.9.1 from the Synergy site is working well for me.

 

Share this post


Link to post
Share on other sites
Posted (edited)

I was about ready to revert this morning and my yet do so. I traveled to a remote office and woke my laptops up. Mind you that the network environment couldn't be simpler as I use a NAT router on my desk because I'm constantly working with embedded HW and it's just easier if I have an environment where I can control IPs. So the laptops are both on a local network segment. No matter how many times I restarted the synergy services on both machines, connection would not happen. In particular, the Windows box would only show itself in the config screen. I finally had to give in and reboot the Windows laptop to get things working again. 

I like a couple of things about version 2, the automatic shifting of the server role, and more gracefully handing login and UAC on Windows being the most important, but version 1 never forced me to reboot anything and works even if there's no connectivity.

Edited by Davewill

Share this post


Link to post
Share on other sites

I've also gone back to Synergy 1.9 on my Ubuntu (DELL workstation) - Windows (Microsoft Surface Laptop) configuration at work.

My post about what isn't working is over here (looks like the new boost library doesn't like something that Synergy 2.x us using) --

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now