lineber

Fedora 27 downgrades 2.0.9 to 1.8.8

5 posts in this topic

FYI,

While updating my Fedora system, I noticed that Fedora recognizes I manually installed synergy2, and is trying to update the package to synergy1. I tested this update and confirmed it overwrites the version 2.0.9 version with the 1.8.8 version. Which for me was bad, because If someone did the update and didn't notice, they would not understand why the system is not working.

So immediately I ran:   sudo dnf upgrade --exclude=synergy  // This only allowed me to update all other software with the exception of synergy.

Later I added the following line to /etc/dnf/dnf.conf  (as root):

excludepkgs=synergy

This prevents dnf from updating synergy.

I would much rather that Symless provided a repo for Fedora. This would solve all problems and is not as difficult as it sounds. If symless already does have a dnf repo with synergy2, or is available in a public one, please let me know!

-Jerry

Either way, below are some captures of the dnf software trying to update my system. Also, I showed the version I have and the available that is in the updates repository.

====

Last metadata expiration check: 0:07:09 ago on Sat 21 Apr 2018 09:41:27 PM EDT.
Dependencies resolved.
============================================================================================================================================
 Package                        Arch                          Version                                  Repository                      Size
============================================================================================================================================
Upgrading:
 synergy                        x86_64                        1:1.8.8-3.fc27                           updates                        876 k

Transaction Summary
============================================================================================================================================
Upgrade  1 Package

Total download size: 876 k
Is this ok [y/N]: n
Operation aborted.

[[email protected] ~] $ sudo dnf info synergy
Last metadata expiration check: 0:08:05 ago on Sat 21 Apr 2018 09:41:27 PM EDT.
Installed Packages
Name         : synergy
Version      : 2.0.9
Release      : 1601.stable.4a1bbebe.el7.centos
Arch         : x86_64
Size         : 14 M
Source       : synergy-2.0.9-1601.stable.4a1bbebe.el7.centos.src.rpm
Repo         : @System
From repo    : @commandline
Summary      : Keyboard and mouse sharing solution
URL          : https://symless.com/synergy
License      : GPLv2
Description  : Synergy allows you to share one mouse and keyboard between multiple computers.
             : Work seamlessly across Windows, macOS and Linux.

Available Packages
Name         : synergy
Epoch        : 1
Version      : 1.8.8
Release      : 3.fc27
Arch         : x86_64
Size         : 876 k
Source       : synergy-1.8.8-3.fc27.src.rpm
Repo         : updates
Summary      : Share mouse and keyboard between multiple computers over the network
URL          : https://symless.com/synergy
License      : GPLv2
Description  : Synergy lets you easily share your mouse and keyboard between multiple
             : computers, where each computer has its own display. No special hardware is
             : required, all you need is a local area network. Synergy is supported on
             : Windows, Mac OS X and Linux. Redirecting the mouse and keyboard is as simple
             : as moving the mouse off the edge of your screen.

 

  • Like 1

Share this post


Link to post
Share on other sites

Nice troubleshooting / fix -- although we really should look into our own repo, as you state!

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Same problem, and went a bit further by excluding the package from the two fedora repos, that tries to downgrade it.

This will stop both dnf and PackageKit which Gnome-Software uses, from ever trying to downgrade using the official fedora repositories again.

Edit the following two files:

  • /etc/yum.repos.d/fedora.repo 
  • /etc/yum.repos.d/fedora-updates.repo

If you use the updates-testing repo, remember to do it for that one as-well.

Add the following to both: 

exclude=synergy

Example on how it looks in /etc/yum.repos.d/fedora-updates.repo for me:

[updates]
name=Fedora $releasever - $basearch - Updates
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/$basearch/
metalink=https://mirrors.fedoraproject.org/metalink?repo=updates-released-f$releasever&arch=$basearch
enabled=1
repo_gpgcheck=0
type=rpm
gpgcheck=1
metadata_expire=6h
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False
exclude=synergy

[updates-debuginfo]
....

That will make sure neither dnf or PackageKit will try for those repositories again. But to stop Gnome-Software, clearing PackageKit cache seemed to also be necesary as well as a reboot.

Check PackageKit cache size:

sudo du -sch /var/cache/PackageKit/27/metadata/

Clean it for all old and no longer used packages:

sudo pkcon refresh force

You can check PackageKit size again if you want, to see how much old stuff have been removed.

And now reboot!

 

All that stuff fixed it for me. :)

This is the related Bugzilla for why this happens: https://bugzilla.redhat.com/show_bug.cgi?id=1542286

Edited by JacobPed
Added Bugzilla link
  • Thanks 1

Share this post


Link to post
Share on other sites

Again, great troubleshooting! I know this'll help out our RH and Fedora folks... thanks!

Share this post


Link to post
Share on other sites

JacobPed, Thanks. I rarely do updates from the Gnome Software tool, but yes it tries to downgrade it too. I added the lines to the yum repo files and it worked.

Thanks again.

-Jerry

  • Haha 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now