ichigeki

Synergy 2 Multiple monitors mouse stuck

5 posts in this topic

I'm facing an issue when i'm switching from 2 monitors to 1 monitors in order to use my second one form my second PC.  

My computer using 2 monitors is under Ubuntu 16. I go to settings and turn off the second monitor.  When I move my mouse over to the Windows PC, my mouse gets stuck on the far left side of the screen and I can't go back to my primary computer.  I need to shutdown my second computer for the mouse to return to normal, kill Synergy on Ubuntu, boot the windows PC again an then it will work.

Anyone having the same issue ? 

I haven't tried to turn off my second monitor in ubuntu before I power on the Windows PC. I'll give it a go and  let you guys know.

Share this post


Link to post
Share on other sites

I'm having the same issue with Ubuntu + Windows 10.  I can't go left (or at least not very fast).  If i SLOWLY move the mouse northwest, I can eventually go back.  If I use synergy from the windows machine, it's all fine.  I just don't want to as the keyboard and mouse setup is better on the linux system. 

The previous version of synergy worked fine, starting to regret the purchase.

Share this post


Link to post
Share on other sites
19 minutes ago, Davewill said:

Yeas, I run into that kind of thing often when adding or subtracting a monitor from Ubuntu. Synergy doesn't seem to realize that it's happened and uses the old desktop dimensions. I don't use Ubuntu as my server, so I haven't gotten that badly stuck.

 

The way I fix it is to open the synergy app and right click to "share from" again. It doesn't seem to matter which machine you do it on. That usually causes a reconnect and fixes the issue. Alternately, drag one of the computers away from the rest, then back. You could also try using the tray app on Windows to disable then enable Synergy.

Thanks for the tip Davewill ! I'll try this next time and let you know.
I just hope I dont forget to do it before I switch from Ubuntu to Windows.

Share this post


Link to post
Share on other sites

Davewill,

Your solution works great, thanks ! 

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now