PJM

Synergy v2.0.9 (single/double quote problem)

8 posts in this topic

Posted (edited)

I'm using Synergy v2.0.9 on a Windows 10 (Host OS) and a macOS Sierra (Guest OS), using English layout (the United States international) on both of them.

With this version and the old one (Synergy v1.8) I can't use the single and double quote (' and " character) on the guest operating system.

This is something that will be fixed or have a solution? 

My fix, for now, is using ShareMouse software, but I really like the way that Synergy works (older version) and I'm very enthusiastic to use the Synergy v2.1, but this bug makes this software useless for my use case.

Thanks

Edited by PJM

Share this post


Link to post
Share on other sites

Hello, have you checked if synergy doesn't affect layout on "guest" ?

This is an issue I have on a win10 (server) + Debian (linux, client) I need to manually set the keymap on first interraction (as long as the linux is not rebooted it is OK).
I had the same issue in V1, I am using french keyboard layout.

Maybe try to force the keymap on the Mac and see if it's OK

Share this post


Link to post
Share on other sites

Hi sholan,

Thank you very much for your quick reply.

I don't know what's happening, but you give me a quick fix. Basically, if I use Win 10 (Server) with English layout and macOS (Client) with Portuguese layout, the keyboard works as expected (all keys seems to be using English layout).

Otherwise, if I stick to use the English keyboard in both (Server and Client), the single/double quote stops working.

So for anyone who has the same problem, try to apply the suggestion made by sholan, by changing the keyboard layout of client.

Share this post


Link to post
Share on other sites

I'm happy to know this workaround helped you.

If you're really annoyed, you should consider contacting the symless support : https://symless.com/contact/customer-support
They may help you troubleshoot the issue or get enough information to solve it in future release.

  • Like 1

Share this post


Link to post
Share on other sites

I already contacted and asked if Synergy v2.1 would have this fixed (because the problem was also on Synergy v1.8.8 too).

They didn't reply to it, but since this quick workaround fixes the problem, it's fine for me to use it this way.

With this, Synergy team could focus on bringing the Synergy v2.1 with PRO features, after that, I will insist on this bug report.

It's great to use Synergy once again.

Share this post


Link to post
Share on other sites
9 hours ago, PJM said:

They didn't reply to it

Sorry about that. I checked your tickets and couldn't find one for this issue (your last ticket was Feb 18). Perhaps your message failed to send, or there was a problem at our end?

9 hours ago, PJM said:

With this, Synergy team could focus on bringing the Synergy v2.1 with PRO features, after that, I will insist on this bug report.

 

We'll absolutely be doing this, though 2.1 will be more focused on advanced settings. 2.2 will start to introduce new features, but this could be pushed back to next year due to us having staffing issues (Jerry is leaving the company and we're looking for a new Software Engineer).

Share this post


Link to post
Share on other sites
On 4/18/2018 at 8:33 AM, Nick Bolton said:

Sorry about that. I checked your tickets and couldn't find one for this issue (your last ticket was Feb 18). Perhaps your message failed to send, or there was a problem at our end?

 

Thank you for the reply.

No problem at all, but you can check my request #63101.

For some reason, the ticket was merged with another one that I ask for Synergy v1.X. If you think it's important, you could reopen it, but for now, this fix doesn't bother me too much, since I can use the software.

On 4/18/2018 at 8:33 AM, Nick Bolton said:

We'll absolutely be doing this, though 2.1 will be more focused on advanced settings. 2.2 will start to introduce new features, but this could be pushed back to next year due to us having staffing issues (Jerry is leaving the company and we're looking for a new Software Engineer).

 

That's fine, I like Synergy v1.X because it's advanced settings and for not using the cloud, it seems that's more reliable because of it. Either case, the last Synergy version seems to be better. 

Sorry to hear that, from what I read was a great and first employee of Symless. Keep the good work.

Share this post


Link to post
Share on other sites

Hi PJM,

Thanks for the quickfix. I have Sierra as the server and windows 10 as the client, and when I change the keyboard layout in windows 10 to Portuguese it works as well.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now