asargent

User instructions for 2.0.9

17 posts in this topic

I just upgraded my Synergy 2 to 2.0.9 and I can not see how to configure it?  I feel like an idiot, but it is not clear how to use it.  I have Synergy open on both computers.  In each case, all it shows is a little block with the computer's name.  I can move the block around and if I right click it shows me the option to share from <name of computer>.  I can see no menus or options to start the server or client or to configure anything.  What am I doing wrong?

Share this post


Link to post
Share on other sites

That's pretty much what is expected.

SYNERGY
The goal of Synergy 2 is that a user installs it and it auto-configures and works without the user having to intervene. Even to select a server.

Synergy 2.1 is being developed, targeting IT and Power Users. There will be access to a console for administrative control of specific cases, but most users won't ever see it. Offline configuration is planned to be included.

But Synergy 2.1 is still a few months away.

Share this post


Link to post
Share on other sites

OK, so that leaves me with the problem that I can not share my keyboard and mouse across the two computers.  They share a LAN and WAN and I can map drives between them.  Is it supposed to find the other machine and connect automagically?

Share this post


Link to post
Share on other sites

Yes.

Moderaters put together an UNOFFICIAL documentation back during the beta trial.

Maybe it can help orientation to the vision of version 2.0

Could be that version 2.1 will fit your setup better. But it's still a few months away.

Share this post


Link to post
Share on other sites

I was just reading the UNOFFICIAL documentation, but it looks like it assumes that the computers recognize each other?  Maybe I need to revert?  What would cause the two instances of Synergy to not recognize each other?

Share this post


Link to post
Share on other sites

Not making the cloud configuration trip.

I'd try a CLEAN reinstall next.

 

Share this post


Link to post
Share on other sites

I was just reading the UNOFFICIAL documentation, but it looks like it assumes that the computers recognize each other?  Maybe I need to revert?  What would cause the two instances of Synergy to not recognize each other?

Tried uninstall/reboot/install with no joy.

 

Share this post


Link to post
Share on other sites

[ Service ] [2018-04-11T13:09:51] debug: service log file path: C:\ProgramData\Symless\Synergy\synergy-service.log
[ Service ] [2018-04-11T13:09:51] debug: install dir: C:\Program Files\Synergy
[ Service ] [2018-04-11T13:09:51] info: starting service...
[ Router  ] [2018-04-11T13:09:52] debug: binding to 0.0.0.0:24802
[ Router  ] [2018-04-11T13:09:52] debug: Initialized
[ Service ] [2018-04-11T13:09:52] debug: creating rpc endpoints
[ Service ] [2018-04-11T13:09:52] debug: rpc endpoints created
[ Config  ] [2018-04-11T13:09:55] debug: connected to background service
[ Config  ] [2018-04-11T13:09:55] debug: saying hello to background service
[ Service ] [2018-04-11T13:09:55] debug: saying hello to config ui
[ Service ] [2018-04-11T13:09:55] info: Tray process connected
[ Config  ] [2018-04-11T13:09:56] debug: new added screen pos: 257 161
[ Service ] [2018-04-11T13:09:56] error: can't send profile snapshot, not yet received from cloud
[ Config  ] [2018-04-11T13:09:58] debug: current version is update to date

Share this post


Link to post
Share on other sites

All fixed.  Tech support sent me this procedure.

First, uninstall Synergy using Add or remove programs (or Apps & features).

Next, run regedit and delete these registry keys:

HKEY_CURRENT_USER\Software\Symless
HKEY_CURRENT_USER\Software\Synergy

Now, delete these directories (if they exist):

C:\ProgramData\Symless
C:\ProgramData\Synergy v2
%USERPROFILE%\AppData\Local\Synergy
%USERPROFILE%\AppData\Local\Symless

Finally, reboot Windows to ensure that the hook DLL is completely unloaded.

Once you've done that, you can reinstall Synergy 2.

Share this post


Link to post
Share on other sites

Good work, thanks for pointing Support reply.😊

Share this post


Link to post
Share on other sites

Did the above, but it still doesn't work for me.

Staring at two little boxes with a green line crawling across one.

Share this post


Link to post
Share on other sites

Referring to my comment above.

The software now appears to work.

Lost my mouse pointer and found it on the monitor of the other computer

A bit unsettling.. :)

Share this post


Link to post
Share on other sites
Posted (edited)

Yeah, I wasn't sold on that auto-swap server feature at first since my dedicated keyboards are 'sorta' within reach, I've noticed that the auto-swap server saved me from actually having to think about what was happening. Since it is back and forth seamlessly and immediately, it's become hardly noticeable to me.

Edited by GranPaSmurf
grammar

Share this post


Link to post
Share on other sites
22 hours ago, GranPaSmurf said:

I've noticed that the [insert feature/product here] saved me from actually having to think about what was happening

This statement perfectly embodies our mission statement. :)

 

  • Thanks 1

Share this post


Link to post
Share on other sites

That seemed to work for my windows client, now if I could have a similar procedure for my linux box, that would be super (mint 18.1)

Share this post


Link to post
Share on other sites

update on linux mint 18.1

I did a "apt-get remove synergy# then I did a  "locate synergy" and found some synergy files under ~/.configure I deleted all those files and folders and tried to re-install, now it worked better!

so, I guess the cleanup-script for the package did not clean up as good as it should.

  • Like 1

Share this post


Link to post
Share on other sites

Great!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now