Guest Nick Graham-Brown

2.0.9 has landed!

23 posts in this topic

Hi everyone,

Version 2.0.9 of Synergy is now available to download

Release Notes

  • Added Raspberry Pi support 
  • Fixed issue with reconnection after sleep
  • Fixed issue where redundant connections were being created between machines
  • Resolved issue with Windows installer getting stuck at validation step (fixed for 2.0.8+)

For details on previous releases, check out the full release notes for Synergy

We encourage all users to update to the latest version of Synergy to ensure as many users as possible are getting the best experience.

Not seeing something you're looking for? Vote for a feature you'd like to see in Synergy.

Enjoy!

 

Share this post


Link to post
Share on other sites

Awesome! Here's hoping this will fix my connectivity issues.

Share this post


Link to post
Share on other sites
51 minutes ago, Nick Graham-Brown said:
  •  
  • Fixed issue with reconnection after sleep
  • Fixed issue where redundant connections were being created between machines

I'm excited to see if these will fix my issues! :)

Share this post


Link to post
Share on other sites

It looks like this takes care of the two main remaining issues that I've had with Synergy 2 -- I've sometimes have to smack it around a bit after I bring my laptop up after sleep, and the Windows installer hang thing.

It's been plenty usable since ... oh, 2.0.4 or so, I think I recall.

 

Share this post


Link to post
Share on other sites

can we expect arm64 version soon ?

Share this post


Link to post
Share on other sites
Posted (edited)

Still no proxy support I see.

Heck, the word proxy doesn't even appear in either the "roadmap" or the "bugs" page. 

Edited by JeffDG
  • Thanks 1

Share this post


Link to post
Share on other sites
2 hours ago, Alvaro Matiz Rodriguez said:

Unfortunately, close but no cigar. I´ve tried several times since ver. 2.0 was launched and my two Mac computers, both on the same wired network, same configuration, seeing each other with ping, working flawlessly with Synergy 1.9.1, refuse to connect. I´ve installed the "server" and it remains stuck at the "second step: install synergy on another computer". I do so, but the other computer just shows a dark screen icon and nothing happens. And to add insult to injury, the "minimalist" design does not allow you to see what´s going on, aside of the sending logs feature. For the time being, I will stick with the old version...

I've been using Synergy 1.X for a very long time. I tried to use 2.0.9 today and no dice. Same error you have. Slave machine seems to be fine, but the Master system does nothing, and the GUI shows my local host as Greyed out. No config options to be found anywhere. Opened a ticket with support, but it looks like this has been an ongoing issue.

Back to 1.9 it is..

Share this post


Link to post
Share on other sites

UPDATE 2: As per Arnie´s suggestions, I followed the detailed uninstall instructions for Mac, reinstalled the latest version and now it´s working. You can see the instructions here:

Hope this helps!

 

  • Like 1

Share this post


Link to post
Share on other sites
Just now, Alvaro Matiz Rodriguez said:

UPDATE 2: As per Arnie´s suggestions, I followed the detailed uninstall instructions for Mac, reinstalled the latest version and now it´s working. You can see the instructions here:

Hope this helps!

 

Awesome! While in-place upgrades are great, it might be beneficial to recommend the aforementioned to users who are looking to go to 2.X.

Another thing I noticed: There are no direct links to these forums from the main symless.com page. Found these forums after Googling one of the initial errors from the logs.

Is this by design?

  • Like 1

Share this post


Link to post
Share on other sites
13 hours ago, JeffDG said:

Heck, the word proxy doesn't even appear in either the "roadmap" or the "bugs" page. 

Fixed! https://symless.com/synergy/roadmap

14 hours ago, m00 said:

take back the strings and put synergy 1.9.x back on github

Synergy 1.9 is on GitHub... https://github.com/symless/synergy-core/commits/v1.9

12 hours ago, Arnie C said:

Another thing I noticed: There are no direct links to these forums from the main symless.com page. Found these forums after Googling one of the initial errors from the logs.

Is this by design?

It's been on our todo list for a while. Sorry for the delay, thanks for your patience.

  • Like 1

Share this post


Link to post
Share on other sites

I am guessing there are quite a few back-end changes since I last tried Synergy 2, especially with the new Raspberry support.  It still looks pretty similar to the last time I tested it.

A couple of improvements I notice and appreciate.  You can now delete the phantom computers that showed up prior, it is interesting that they came back right away, there must have been an old config that never got deleted.

Also, the delay when the software detects the slave computers input devices are active and switches it to the new master has been increased which helps with false positives that I was getting before; it might actually be triggered off of a mouse click or key press rather than just mouse movement.  That is a big improvement.

A couple of things which have not been fixed.  The flutter at the edge of the screen when switching between screens still occurs.  Unfortunately I have not been able to find a consistent pattern to this bug, it seems to occur about 50 percent of the time though at the moment.  This bug is bad enough that it alone relegates this software to beta status at best just in terms of usability because it is so intrusive and annoying.  It seems to be triggered more often when I try and move the mouse  very quickly between screens, rather than at a slower steady pace.

There also still seems some sort of GUI bug where one of the computers will get "hung" in updating status when it is becoming the master.  This bug does not seem to affect the usability of the app, the computer icon in the app just never stabilizes to solid green.  It will stabilize if you flip the slave computer to be master and flip back again.

All in all, this is a huge improvement over the first alpha release.  Here is my log file for the flutter affect:

https://synergy-logs.symless.com/19683741d0f04e0129fa30fe3e1ec25b/logs/29939-2018-04-11T07-39-55.log

Share this post


Link to post
Share on other sites
9 hours ago, Nick Bolton said:

Fixed! https://symless.com/synergy/roadmap

Synergy 1.9 is on GitHub... https://github.com/symless/synergy-core/commits/v1.9

It's been on our todo list for a while. Sorry for the delay, thanks for your patience.

Synergy-core != Synergy (but hey i'm sure you're aware of that)

and synergy-core wont compile on arm64, the old branch (1.8.x) did just well. including SSL and GUI.

ever since this software became closed source it became crappy honestly.

the community should have the latest version available with SSL and GUI as long as u compile it yourself, and for now - that is not the case.

 

Share this post


Link to post
Share on other sites
On 4/11/2018 at 3:43 PM, Jereme Guenther said:

The flutter at the edge of the screen when switching between screens still occurs.

This drives me nuts too. Actually, I was talking to @Andrew Nelless about this today. He thinks that the S1 "Take foreground windows" and/or "Relative mouse moves" settings may have fixed this or changed the behavior. Anyway, we'll get it fixed (I hope sooner rather than later).

Share this post


Link to post
Share on other sites
On 4/11/2018 at 6:58 PM, m00 said:

Synergy-core != Synergy (but hey i'm sure you're aware of that)

In Synergy 1, there is nothing except for Synergy Core, so they're basically the same thing.

Share this post


Link to post
Share on other sites

UPDATE 3: I guess I spoke too soon. Synergy 2.0.9 installed flawlessley and after cleaning everything up, connected to my second computer. So far, so good. Problems started when one of the machines went to sleep and after waking up, there´s no way to reconnect to the sharing computer. The only method I found useful was to kill Synergy´s process and restart it, and this is difficult because of the minimalistic interface. So, after two frustrating days, I´m back to 1.9.x, that simply works. Hopefully guys you can come out with a stable solution for the 2.x branch some day...

Share this post


Link to post
Share on other sites
On 4/13/2018 at 7:40 PM, Alvaro Matiz Rodriguez said:

Problems started when one of the machines went to sleep and after waking up

We're aware of the sleep/resume bug and are working on it urgently. @Jerry Hou and @Andrew Nelless are making progress on this, so hopefully, we'll have a fix in 2.0.10 or 2.0.11 if all goes well.

Share this post


Link to post
Share on other sites

Thank you all a lot for all the hard work and updates, I only need one feature so badly which is using the windows commands like Ctrl+C, Ctrl+S etc...  on Mac, I knew it was mentioned to be in the upcoming 2.1, but is there any news if it may come to 2.0.10 or 2.0.11 ?

Share this post


Link to post
Share on other sites
11 hours ago, Remy said:

I only need one feature so badly which is using the windows commands like Ctrl+C, Ctrl+S etc...  on Mac

Are you wanting to swap the Alt/Cmd/Ctrl keys around on the Mac client? This is a high priority on the roadmap: https://symless.com/synergy/roadmap

  • Like 1

Share this post


Link to post
Share on other sites

And...2.0.10 is out with no release notes.

Share this post


Link to post
Share on other sites

I am more concern about when will that be fixed : "Modifier keys (Shift/Ctrl/Alt/Win) not working in Parallels"

I am not using parallels but ms remote desktop on MacOS client. And I am having the exact same issue for months.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now