Enrico Self

Synergy 1.9 and high Sierra 10.13.4

14 posts in this topic

I'm using Synergy (1.9 and still happy with it ... it does what i need) and I have a linux machine as server and a macbook as a client; since upgrading the macbook to 10.13.4 i'm seeing the following error each time a keyboard key is pressed:

synergyc[17428:1597384] pid(17428)/euid(501) is calling TIS/TSM in non-main thread environment, ERROR : This is NOT allowed. Please call TIS/TSM in main thread!!!

 

Synergy does indeed work as expected, the only glitch I see is that the service is in "starting" mode forever and there is no green check in the toolbar icon. 

 

any idea how to fix that ? is that a serious problem ?

 

thanks

 

Share this post


Link to post
Share on other sites

glad you're getting good use of Synergy.

The display sometimes does that. It shows a machine as not quite connected. I call it 'searching' mode. But the app is working fine.

Sometimes a reboot resets it, but mostly I ignore it. The developers are aware of that glitch but been focusing on improving connectivity on specific combinations. 

BTW, Synergy 2.09 should drop in the next few days. Updating to the most recent version couldn't hurt.

Share this post


Link to post
Share on other sites

I am having the exact same issue.  Reboot does not fix the issue.  I can't connect to my other computers running Windows.  Same version of Mac as well.

 

DJ

Share this post


Link to post
Share on other sites

I also have exactly the same issue.
Mac 10.13.4 which dont connect to windows laptop. 

2018-05-11 18:27:39.686 synergys[1118:15342] pid(1118)/euid(501) is calling TIS/TSM in non-main thread environment, ERROR : This is NOT allowed. Please call TIS/TSM in main thread!!! 2018-05-11 18:27:39.686

Share this post


Link to post
Share on other sites

This error just started happening randomly on one of my macbooks. 

2018-05-14 08:35:58.616 synergyc[7492:28042] pid(7492)/euid(501) is calling TIS/TSM in non-main thread environment, ERROR : This is NOT allowed. Please call TIS/TSM in main thread!!!

 

Share this post


Link to post
Share on other sites

same problem with 2.0.11.  MacBook Pro server and win10 client.  Mouse works but keyboard doesn't.  new user as of yesterday and spent all day on it trying to figure out what was wrong.  the lack of being able to configure anything was a little frustrating when things aren't working but understand why they did it.  rebooted a bunch and uninstalled and reinstalled.  same issue.  I opened up a support ticket but after seeing all the problems with 2.0.11 I am thinking that support won't get to me for a while.  wondering if i should drop down to an older version or just get my money back. 

Share this post


Link to post
Share on other sites

More than once since 2.0 was introduced I've had to take a step back. I never considered a refund because I didn't want to lose the financial consideration. Usually, for me, when the next version arrived, my issue has been fixed. 

It's good that you have a support ticket open. That gets your issue in front of a developer much quicker than posts in this forum. Trouble tickets drive development.

Share this post


Link to post
Share on other sites
Posted (edited)

This error doesn't seem to stop 1.9 from working on High Sierra. Its just alerting, I'm going from Mac to Mac both on 10.13.4 and one windows machine.  

Screen Shot 2018-05-15 at 4.54.25 PM.png

Edited by DaRkBaN
uploaded picture

Share this post


Link to post
Share on other sites
1 hour ago, jcarlstrom said:

same problem with 2.0.11.  MacBook Pro server and win10 client.  Mouse works but keyboard doesn't.  new user as of yesterday and spent all day on it trying to figure out what was wrong.  the lack of being able to configure anything was a little frustrating when things aren't working but understand why they did it.  rebooted a bunch and uninstalled and reinstalled.  same issue.  I opened up a support ticket but after seeing all the problems with 2.0.11 I am thinking that support won't get to me for a while.  wondering if i should drop down to an older version or just get my money back. 

Do gestures work?

Share this post


Link to post
Share on other sites

gestures work on MBP but not on Win10 PC but to tell you the truth I didn't even think about trying them on Windows machine.  I was thinking that they were on a mac thing.  thanks for asking.

Share this post


Link to post
Share on other sites

I have a dell usb keyboard and on a whim I connected it up along with my apple wireless keyboard to see if it was maybe it was my keyboard.  plugged usb keyboard in and everything worked.  both keyboards could type on both my mac and Win10, opened and typed in word and chrome on both, did copy and paste from on to the other, and some of the gestures worked on my wireless apple mouse on Win10.  Thought it was the wireless keyboard causing problems so i removed it with just the usb keyboard and rebooted both to see if i could get a reproducible config.  Unfortunately, I could never get it to work again.  tried every permutation of keyboard (wireless only, usb only, wireless and usb) and different booting sequences (mac and win10 same time, mac first, win10 first, only mac, only Win10, etc.) to no avail.  BUT i saw it work once so I know that it is possible.

Share this post


Link to post
Share on other sites

So are you saying that you can do more than 2 finger scroll on v2?  This is what has been missing in v1.9, the lack of being able to say three finger swipe a client mac, or even two finger swipe to go back/forward. I contacted the Symless team to get a definite answer about this, they for the lack of the better term ignored the question.

 

 

 

Share this post


Link to post
Share on other sites

scroll and double tap worked.  2 and 3 finger did not

Share this post


Link to post
Share on other sites
Posted (edited)

edit: wrong thread

Edited by M-ke
irrelevant to post

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now