adunker

Service Restart Button / Option

18 posts in this topic

Often when I take my laptop with me on the go and then return to my normal workflow at home, it fails to have Synergy start working again. I have to open the Services page, find Synergy, andrestart the Synergy service. Then it will work. If this could be a simple button press in the Synergy app it would be so much easier.

Share this post


Link to post
Share on other sites

Then I think you will like version 2.0.7 released yesterday. 

See if it works for you.

Share this post


Link to post
Share on other sites
Posted (edited)
11 minutes ago, GranPaSmurf said:

Then I think you will like version 2.0.7 released yesterday. 

See if it works for you.

I actually updated my machines yesterday. Still had to manually restart the service today. Gave it a couple minutes to see if it would connect, and it didn't until I did the manually restart. Is there something I'm missing because I didn't see any options or ways to have it do that for me.

Also don't see anything in this regard in the patch notes: https://symless.com/blog/synergy-207 Does clicking disable / re-enable functionally do the same thing?

Edited by adunker

Share this post


Link to post
Share on other sites
Posted (edited)

Synergy should autostart when Windows starts up.Maybe the installation got corrupted.

I only tried the disable/enable once: it worked fine then.

Synergy has always left behind files that sometimes mess up a new installation. I always use and recommend a clean install.

If you just did an update in place, I'd say your next step is to start over. Windows Un-Install then search the drive for any left over traces of "Synergy", delete them, then re-download the msi and try again

Also, having to restart after Windows reboot is an issue. Start a ticket with support, https://symless.com/contact/customer-support

 

Edited by GranPaSmurf

Share this post


Link to post
Share on other sites
26 minutes ago, GranPaSmurf said:

Synergy should autostart when Windows starts up.Maybe the installation got corrupted.

I only tried the disable/enable once: it worked fine then.

Synergy has always left behind files that sometimes mess up a new installation. I always use and recommend a clean install.

If you just did an update in place, I'd say your next step is to start over. Windows Un-Install then search the drive for any left over traces of "Synergy", delete them, then re-download the msi and try again

Also, having to restart after Windows reboot is an issue. Start a ticket with support, https://symless.com/contact/customer-support

 

When you say windows starts up as in booting? Or during a lock/unlock scenario? My use case is I'm out using my laptop somewhere else, come back, and dock it at home and connect it to the home network. Synergy runs fine after a full reboot, but it's 10x easier to restart the service. What is the process that should be auto restarting the service?

Share this post


Link to post
Share on other sites

I’m never a fan of creating a button to fix a bug. There are a few issues with the synergy service and I think they should use their time in sorting those out.

That being said it is quite a pain having to start/stop/restart services that are buggy. 

If it is a huge problem in your life you could always write a script or app to do this for you.

Stuart

Share this post


Link to post
Share on other sites

Elsewhere on the forum Linux users posted how to write a brief script for Linux computers. Check here:  https://symless.com/forums/topic/5371-synergy-2-unofficial-edition-2-documentation/ scroll to 'manually restarting services'

stuart, I have machine that gives me trouble with every update. It's an old Win 7(32 bit) with limited resources. In Windows I created a shortcut in the taskbar to 'component services' so I could quickly restart the Synergy service. After a couple of days it seems I don't have to use it anymore but I leave the shortcut there, ready for the next update hassles. 

Also, a 'quick and dirty' trick is to open the Synergy UI of a different machine. Mouse over and grab one of the screens displayed and move it away. No longer touching. Then move it back. That should restart the Synergy core on both machines.

Share this post


Link to post
Share on other sites
14 hours ago, adunker said:

When you say windows starts up as in booting? Or during a lock/unlock scenario? My use case is I'm out using my laptop somewhere else, come back, and dock it at home and connect it to the home network. Synergy runs fine after a full reboot, but it's 10x easier to restart the service. What is the process that should be auto restarting the service?

I don't have any experience with the scenario you describe. But thinking about it, that's no different than starting up a client in your network that's already set up in Synergy, right? I would think that when the laptop is turned on, while in router range, Synergy would detect it and you should be 'good-to-go.'

But you're saying that doesn't happen, right? So, does the Synergy UI show the laptop at all? Gray? Gray and 'searching?' 

Share this post


Link to post
Share on other sites
Posted (edited)
8 hours ago, stuart macmillan said:

I’m never a fan of creating a button to fix a bug. There are a few issues with the synergy service and I think they should use their time in sorting those out.

That being said it is quite a pain having to start/stop/restart services that are buggy. 

If it is a huge problem in your life you could always write a script or app to do this for you.

Stuart

Stuart, I totally agree if it's not an issue, but since the functionality isn't there, it's annoying to have to go out of the way to support the software. Like a menu option, or an option in the taskbar to restart the service would be great.

4 hours ago, GranPaSmurf said:

I don't have any experience with the scenario you describe. But thinking about it, that's no different than starting up a client in your network that's already set up in Synergy, right? I would think that when the laptop is turned on, while in router range, Synergy would detect it and you should be 'good-to-go.'

But you're saying that doesn't happen, right? So, does the Synergy UI show the laptop at all? Gray? Gray and 'searching?' 

I plug mine in over ethernet, but yes, same scenario. And it's generally not good to go. The Synergy UI does show the laptop, and I think it's generally gray and searching, but I don't understand the meaning of the Synergy UI because half the time when everything is working they're showing different things.

Edited by adunker

Share this post


Link to post
Share on other sites

Yeah, it's a bug. They're working on it. Ignore that part.

If it is showing in the UI, then you can move them around and make them touch and such. Another quick trick is to separate the images for a few seconds, then replace them touching. That should restart Synergy core on both machines.

Share this post


Link to post
Share on other sites
39 minutes ago, GranPaSmurf said:

Yeah, it's a bug. They're working on it. Ignore that part.

If it is showing in the UI, then you can move them around and make them touch and such. Another quick trick is to separate the images for a few seconds, then replace them touching. That should restart Synergy core on both machines.

Browsing on the forums I picked up on this and that definitely seems to fix the issue. Just wish this might have been a bit more intuitive of a way to accomplish this.

Share this post


Link to post
Share on other sites

still getting a re-connection problem when my laptop (win10) is woken up due to inactivity > 10 mins and goes to sleep. I wake up my laptop and click on the enter key to wake up my imac (sierra).  Client on the laptop tries to re-connect but doesn't. I have to go to services to restart synergy.

This problem with waking up and re-connecting to imac has been happening for awhile with version 2.

Share this post


Link to post
Share on other sites
49 minutes ago, Cheryl Lomedico said:

still getting a re-connection problem when my laptop (win10) is woken up due to inactivity > 10 mins and goes to sleep. I wake up my laptop and click on the enter key to wake up my imac (sierra).  Client on the laptop tries to re-connect but doesn't. I have to go to services to restart synergy.

This problem with waking up and re-connecting to imac has been happening for awhile with version 2.

The UI adjustment trick works great for me if you can try that. I would love if the devs added an option in the tray icon to effectively do the same thing.

Share this post


Link to post
Share on other sites

explain what you mean by "UI adjustment trick"...

Share this post


Link to post
Share on other sites
1 hour ago, Cheryl Lomedico said:

explain what you mean by "UI adjustment trick"...

If you click and drag the 'screens' to a different position and back again, it essentially does the equivalent of restarting the services apparently. Works for me.

Share this post


Link to post
Share on other sites

That is what I thought you meant. I did try that actually and it still didn't re-connect.

Share this post


Link to post
Share on other sites

Could you try disable and then re-enable from the tray icon? You'll need 2.0.7 to do this.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now