Shawn243

"Validating install" takes forever

14 posts in this topic

Can anyone explain why the installer takes forever to validate the install before it will actually install the software? Synergy 2.0.5 took at least 15 minutes to validate. 2.0.6 has already taken nearly 30, and it still hasn't validated. This happens with the Windows 64-bit installer on Windows 10. No such problem when installing on Mac OS X 10.11.6.

Share this post


Link to post
Share on other sites

This bug is driving me crazy! I'm pushing for the fix for this to be prioritized.

Share this post


Link to post
Share on other sites

I've been seeing a long lag, then (I forget the exact wording) something about can't complete due to some process still running.  I click "try again", and it eventually works on the second try.

I haven't timed how long it takes.

I saws this on 2.0.6 and 2.0.5.  I'm not sure about earlier versions.

Share this post


Link to post
Share on other sites

Cheers o/

As seen in another post, installation can become stuck, manually stopping the synergy service worked for me.
Please note I first canceled the allready started installation process, stopped the service, restarted the installer and ... tada !

  • Like 1

Share this post


Link to post
Share on other sites

If the service has to be stopped, why doesn't the installer either stop the service or tell you that upfront? But you're right. As soon as I stopped the service and then ran the installer, it completed in about 10 seconds.

  • Like 1

Share this post


Link to post
Share on other sites

I made sure the service was stopped but it still took almost 15 minutes to get past "Validating install" on upgrading from 2.0.4 to 2.0.7 on Windows 10

Share this post


Link to post
Share on other sites

Synergy 2.0.8-Stable, upgraded from Synergy 1, problem still persists on Windows 10; validating install is basically stuck (didn't wait 15 minutes :)

Manually stopping the service worked for me, installs in a second.

One of my favourite software, thanks.

Share this post


Link to post
Share on other sites

You should see a difference going from 2.0.8 to future versions.

Share this post


Link to post
Share on other sites
On 06/04/2018 at 12:13 PM, Steve Williams said:

You should see a difference going from 2.0.8 to future versions.

Indeed, 2.0.9 went smoothly and effortless.
Congrats !

  • Like 1

Share this post


Link to post
Share on other sites

I also had no problems when upgrading to 2.0.9.

  • Like 1

Share this post


Link to post
Share on other sites

I'm seeing this issue with 2.0.10. 64-bit, upgrading from Synergy 1.8.8. Cancel doesn't close the installer, either.

Share this post


Link to post
Share on other sites
On 4/25/2018 at 4:29 PM, Ben R. said:

I'm seeing this issue with 2.0.10. 64-bit, upgrading from Synergy 1.8.8. Cancel doesn't close the installer, either.

Ditto, Annoying little bug, works flawless on Linux though lol 

Share this post


Link to post
Share on other sites

Version 2.0.11 - had same problem on one machine, the other installed perfectly. 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now