IT Troll

Windows service blocks in-place upgrade

12 posts in this topic

For the past two releases (2.0.5 & 2.0.6) I found that the Windows installer would stall part way through the setup when upgrading an existing installation. I had to manually stop the Synergy service for the installation to continue.

With 2.0.6 it stalled at "Validating installation" with no real clue as to what it was doing.

On the other hand, the Mac in-place upgrade worked fine.

Share this post


Link to post
Share on other sites

interesting observation.  Here is another data-point

I installed 2.06 Monday afternoon. I did this:

  1. Win 10 laptop, in-place upgrade,
  2. Win 10 desktop, squeaky-clean (I'm lazy - I use a free version of Revo Uninstaller) 
  3. re-install Win 7 (32 bit) squeaky-clean re-install 
  4. Kubuntu 17.10 in-place upgrade

All 4 were perfectly smooth, usual pop-ups with no glitches on all 4. I restarted a couple of times as verification. Perfect operation. This morning, after overnight shut-down. all 4 started Synergy with no intervention needed. I haven't opened the UI on any of the 4 with about an hour of use today.

Share this post


Link to post
Share on other sites

Hmmm, that's interesting. I wonder what is different about my Windows 10 system. Previously, it upgraded fine, it is just the last two that needed manual intervention.

Share this post


Link to post
Share on other sites

when you do a clean install, are you totally purging all Synergy from the computer? registry too?

Share this post


Link to post
Share on other sites

I don't do a clean install - clues in the title. ;)

I'm just doing an in-place upgrade as you would expect any average user to do.

Edited by IT Troll

Share this post


Link to post
Share on other sites

Ahh So...

good troubleshooting.

2 of my installs were an in-place upgrade, flawless

Share this post


Link to post
Share on other sites

Had the same problem on my upgrade to 205 and 206. Had to kill the installer, reboot, then stop the Synergy service to get the install to run successfully.

Share this post


Link to post
Share on other sites

Just had the same again with 2.07. Stalled on validating install.

Close installer, stop service, launch installer, success.

Share this post


Link to post
Share on other sites

Ahh! So if I understand the workaround:

  1. in-place install
  2. get blocked part-way
  3. stop the installation 
  4. stop the Synergy service,
  5. install successfully.

So, since it's an in-place installation, Synergy service is already there from the previous Synergy. I like to do clean installs when we update, but now I'm wondering if one could just stop Synergy service first, then install the update. The fresh installation would probably restart the service, but if not, it's easy to restart.

Hmmm.

Share this post


Link to post
Share on other sites

Yeah, I am sure that stopping the service first would do the trick. However, the installer should handle that automagically. I didn't have this problem prior to v2.05.

Auto update is planned feature so it will need to handle the service better for that to work reliably.

Share this post


Link to post
Share on other sites

:)

Share this post


Link to post
Share on other sites

Fixed in 2.0.9

Included in this update:

  • Resolved issue with Windows installer getting stuck at validation step (fixed for 2.0.8+)
  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now