adab3ta

Synergy-core process restarts when switching screens (Arch & Windows)

9 posts in this topic

Windows host, Arch Linux guest,  synergy 2.0.5-stable 

When using the Windows machine as a host, passing the cursor over to the Arch machine works maybe once or twice, but usually triggers what looks like a restart loop in the synergy-core process.

 

Windows logs https://gist.github.com/adamancini/6a6a5b5792c42b4118a02618f66b8057

Arch logs https://gist.github.com/adamancini/cdf29d47f886341c38d99057ad729a4b

 

Note that in addition, when started from the systemd unit file with `systemctl start synergy.service`, the arch client fails to connect to the Windows host.  If I start the service as root with `sudo synergy-service` then my arch client will connect to the Windows host, but results in the above condition.

 

It also looks like the router? is trying to connect on all my interfaces, several of which are internal (virtual interfaces for vms, docker).  Is there some way to exclude them, or specify which ip interface/IP address to bind to?

Share this post


Link to post
Share on other sites

does slowing down your pointer movement during the screen transition seem to work more smoothly?

Share this post


Link to post
Share on other sites

Not at all, it seems to trigger the moment I encounter the screen boundary

Share this post


Link to post
Share on other sites

It appeared to help on my end, but it still glitches when I'm on the Arch (client) side of the screen. It never messes up when I'm on the Windows (server) side. Sometimes it seems it happens when I abruptly change directions of the pointer.

I've got a 4k display on the Windows side, and a 2k resolution on the Arch side. DE is cinnamon. Dunno if any of that matters.

I wonder if it doesn't have something to do with a polling rate mismatch between the two computers. Changing other conditions (pointer size, acceleration, etc)  doesn't make a difference, but I can 100% attest that slowing my transition down from server to client helped out.

Share this post


Link to post
Share on other sites

I have not measure the "speed" of my cursor in any way, I wonder how you would do that (pixels/second perhaps) but it does not seem DPI/resolution dependent or "speed of cursor" dependent.  No matter how slowly I try to change displays, the moment the cursor touches the screen boundary, synergy-core restarts.

Share this post


Link to post
Share on other sites

It may just have something to do with not being able to run it in systemd. I'm tinkering with it on my end, when I have more time I'll try to run it with elevated priority on arch to see if that changes anything. I'll reply here if I find anything useful, if you don't hear back from me in a few weeks, send beer.

Share this post


Link to post
Share on other sites

I have the same problem when I'm trying to use windows 10 for host to my Ubuntu 16.04 computer. Works for 1 to 10 times and after that it seems like the process will restart itself and i need to wait for a little while before I can use it again. Its very annoying and my km switch works 10 times better and makes this program unusable.

Using Ubuntu has host seems to work to 100% and with a lot less lag going from computer to computer.

I do need my windows 10 computer has host because the mouse sensitivity will change and small lags will happen and that is not a possibility when im gaming.

Share this post


Link to post
Share on other sites

Adding more details, it does seem that when I use Arch as my host machine, windows is able to connect as a client without issues and the problem with the boundary detection is not reproducible. 

I'd like to keep using Windows as my server, however, since that machine sits at my desk with mouse & keyboard attached

Share this post


Link to post
Share on other sites

I changed my mouse.  (I had planned on doing this before getting Synergy in place)

  • I had a wired ECA-1 mouse. 
  • I now have a Logitech MX Master 2S

The Logitech was glitching (a known bug with windows 10 on some devices). One of the recommended steps to address this glitch was to disable the option that allows the computer to turn off the device to save power.

The steps

  1. Open up Device Manager
  2. Expand Human Interface Device
  3. USB Input Device (you just have to figure out the relevant one for your device)
  4. Right Click and select Properties
  5. Select the Power Management tab
  6. Un-check the option. 'Allow the computer to turn off this device to save power'
  7. Reboot (just to be sure, probably not necessary though)

 

For the past 4 hours now, the synergy service has not restarted or frozen once.  I plugged in the ECA-1 and the issues were immediately reproduced. I re-traced my steps above for this device and the errors stopped for the ECA-1.

(Note the disabled logitech download assistant was the culprit for the logitech problem.)

hid.jpg

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now