AusArcher

Do Back and Forward Mouse buttons work for people?

7 posts in this topic

Hi All,
I've been lurking in these forums following progress for a while. I've been using Synergy 2.0.x since it's release and have been one of the lucky one where for the most part it has worked pretty well. I have certainly seen improvements in the stability with each new version in my environment (Admittedly, my environment is pretty simple). I've just upgraded to 2.0.5 this morning and everything seems to be working well, even seamlessly copied images across systems - made life really easy.

The one thing that I have never been able to get working reliably, even in 1.x is the Back and Forward Mouse buttons. In 1.x they would sometimes work and then mysteriously not work. It was frustrating but was a minor inconvenience that I never had time to follow up. Now with with 2.0.x I've not had the Back and forward mouse buttons work at all, ever, and given that there's no configuration options yet, there doesn't seem to be anything I could potentially do about it. Other Mouse functions, standard left & right click and scroll wheel work fine.

So my question, am I the only one this isn't working for? Do Back and Forward mouse clicks work for anyone else & if so, did you have to do anything special to get them to work?

My Setup:

Synergy 2.0.5, Windows 7 Professional, Windows 10 1703 (Build15063)

 

Thanks

AusArcher

Share this post


Link to post
Share on other sites

It's the same here.

Forward and back buttons have never worked for me.

Setup: Ubuntu 17.10 synergy client. Win10 (virtualized with usb and therefore mouse passed through) as the synergy server.

Share this post


Link to post
Share on other sites

I've had the same issue, but I was able to workaround it with the help of third party apps such as xbindkeys for Linux, Better Touch Tool for Mac and X-Mouse for Windows

The idea is to remap the mouse buttons on the server to a keyboard shortcut.  For example, on my server, my forward mouse button is mapped to "alt-right" and my back mouse button is mapped to "alt-left".

I believe there's some issue with Synergy & how the extra mouse buttons are translated to the other clients which have no mouse.

 

Share this post


Link to post
Share on other sites

No. Using Ubuntu as host for my Windows 10 computer. Left, Right and scroll button works but not back and forward.

Edited by Mike Danielsson

Share this post


Link to post
Share on other sites

Thanks for the input guys, I'm glad it's not just me.
Chamsfiend, thanks for the info on X-Mouse, unfortunately I'm reluctant to run yet another third party app, particularly to resolve an issue that really should be core functionality for Synergy. I'm already running Acoustic Bridge to provide the audio link between systems, something I'd very much like to see become a core part of Synergy, it works but can be flaky at times.

I would really like to see this issue resolved as I'm sure using back and forward mouse buttons is a daily activity for most people. I know there is a feature request forum, but is the are way for us to log Bugs, or to see if this is already listed as a bug that's being worked on?

Share this post


Link to post
Share on other sites

Mac host, Windows client, Microsoft wireless mouse, version 206. Back and forward works fine.

Share this post


Link to post
Share on other sites

Linux Arch host, Windows client. Both running 2.0.10.
Logitech MX Ergo mouse.

All buttons except back & forward work.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now