Karthage

getting there was a problem connecting to the background service...

6 posts in this topic

I've fully removed synergy 2 using the instructions from nick, reinstalled it, same thing. I've removed it and reinstalled 2.0.4, same thing. When I tell it to upload logs and view them I get:

[ Service ] [2018-02-13T22:25:37] debug: install dir: C:\Program Files\Synergy
[ Service ] [2018-02-13T22:25:37] info: starting service...
[ Service ] [2018-02-13T22:25:37] error: service failed: Value must follow after a '=' at line 1
[ Service ] [2018-02-13T22:25:40] debug: service log path: C:\ProgramData\Symless\Synergy\synergy-service.log
[ Service ] [2018-02-13T22:25:40] debug: install dir: C:\Program Files\Synergy

 

Anyone have suggestions?

Share this post


Link to post
Share on other sites

Current version of Synergy is 2.05. 

I'd first update to that version. If the issue persists post to Synergy support. Then come back here and let's kick it around. 

What OS's are you using? 

Share this post


Link to post
Share on other sites

My surface pro 4 also have the same issue.

I already tried un-install, remove the regedit and install the latest version. (Synergy_v2.0.6-stable_b1587-1ef57bb6-x64.msi)

But the Synergy service status still keep running  in 'Running' / 'Stopped'.

The log: 

[ Service ] [2018-02-28T09:54:39] info: starting service...
[ Service ] [2018-02-28T09:54:39] error: service failed: Value must follow after a '=' at line 1
[ Service ] [2018-02-28T09:54:42] debug: service log path: C:\ProgramData\Symless\Synergy\synergy-service.log
[ Service ] [2018-02-28T09:54:42] debug: install dir: C:\Program Files\Synergy
[ Service ] [2018-02-28T09:54:42] info: starting service...
[ Service ] [2018-02-28T09:54:42] error: service failed: Value must follow after a '=' at line 1

 

Edited by GarryChoi

Share this post


Link to post
Share on other sites

The regedit is helpful, but the c:\programdata\symless folder is much more important. it's hidden, you won't see c:\programdata\ but you will need to delete c:\programdata\symless to resolve this. 

  • Haha 1

Share this post


Link to post
Share on other sites
4 minutes ago, Karthage said:

The regedit is helpful, but the c:\programdata\symless folder is much more important. it's hidden, you won't see c:\programdata\ but you will need to delete c:\programdata\symless to resolve this. 

The problem is solved!  Thanks a lot!

Share this post


Link to post
Share on other sites

Hey there - 

Many thanks for this helpful solution, Karthage.  I just ran into this issue on Windows 10 Professional (Surface Pro 4) using Synergy 2.0.12 beta.  I'm unsure what caused the problem - that version had been installed and working well for a while now.  For me, the steps to fixing it were:

1 - Stop Synergy service and set it to DISABLED for automatic startup - since otherwise those files will remain stubbornly 'in use'
2 - Restart computer
3 - Delete C:\programdata\symless folder
4 - Set Synergy service back up to start on reboot (I personally use delayed automatic start)
5 - Start Synergy service

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now