Balding

Synergy wakes computer

6 posts in this topic

Windows 7 and 10

I put one the "client" computer to sleep after about 10 minutes the computer wakes again.  powercfg -requests says synergy is the issue.  I've found all sorts of ways to disable wake on devices, and disabling wake timers.  But I can't find anything about stopping a program from waking a computer.  Why is the service even still running when the computer is asleep?

Share this post


Link to post
Share on other sites

Services run when the computer's asleep. That's normal. If the background service receives a request, it'll act on that request. This is more of a feature request -- we probably need a "Sleep until <this key> is pressed" configuration option. Good idea - moving to Feature requests forum.

Share this post


Link to post
Share on other sites

I think I may have figured out a solution.  I went into the BIOS and disabled “remote wake” seems that makes it so that network services can’t wake the computer.  This obviously disabled other features as well, so it doesn’t work for everyone.

Share this post


Link to post
Share on other sites

powerfcg -requestsoverride SERVICE <name_of_service> <type_of_request>

You can get a usage message with "powercfg /?".  You can extract the name of the caller and the type of request from "powercfg -requests"

I had to do this to keep synergy from preventing my displays from sleeping.

 

Share this post


Link to post
Share on other sites

if I put both computers to sleep they seem to be staying asleep now, I haven't made any additional changes.  if I wake computer A it will wake computer B, but if I wake computer B it doesn't seem to wake computer A. This isn't a problem for me, but just something I noticed.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now