Ghostbroker

Synergy 2 won't sign in on Ubuntu 17.10

28 posts in this topic

I've installed synergy 2 on Linux, but when I click the 'sign in with symless' button, it takes me to the website and asks me to sign in. Once I sign in there, it just goes to the account page. I tried ticking 'remember login' and signing in again on the client, but it just loads a new browser window and forces me to login again.

 

This worked previously on the same linux machine. I just recently reinstalled and now it's not working.

Share this post


Link to post
Share on other sites

For me behavior is the same, but on Fedora 27. I sucessfuly used synergy on ubuntu 16.04 on the same PC just a few days before. After reinstall from Ubuntu 16.04 to Fedora 27 and installation of Synergy, I can't sign in. Always opens a new Chrome tab and I sign in into my account, but Synergy client somehow does not recognize it.

Share this post


Link to post
Share on other sites

Same. Fedora 24, run Synergy2, "sign in" link opens firefox, sign in ... just goes to account page, not to the page saying "go back to synergy"

My Ubuntu 16.04 won't talk to my windows10 machine, so  I've got three machines and none of it is working.

Wish I hadn't bothered with Synergy2, thought it would be at least functional by now.

Share this post


Link to post
Share on other sites

Same here. Fedora 27 (client) Windows 10 (server). Just downloaded the synergy-2.0.6-1430.stable.

Was able to register the windows 10 install without issue.

However on linux, clicking on the button takes me to the website where I log in and it goes to the accounts page and apparently doesn't communicate back to the synergy gui.

Had to downgrade back to 1.8.8

Share this post


Link to post
Share on other sites

I've followed this thread but my Kubuntu 17.10 has never had this issue.

I think I would do a clean re-install and see what happens. I'd make it a 'purge' un-install. 

   type this in the terminal

          sudo apt-get purge <packagename>

the packagename is probably "synergy"

I'm interested to see if this affects the issue you are having

 

Share this post


Link to post
Share on other sites

Sorry. I've tried again with no success.

Fedora use 'dnf' for package management instead of apt, so 'dnf remove synergy'. I also removed the config files in ~

Installed 2.0.6, run the synergy-config (as the user I assume). It opens the gui, where I click on the sign in. That launches Firefox to the symless.com/login page, after login it redirects me to the symless.com/account page. Nothing returns back to the config gui.

I also tried dropping the firewall, in case something was trying to communicate through a blocked port.

Combined log file attached if that helps.

synergy-combined.log

Share this post


Link to post
Share on other sites

good troubleshooting. Thaks for the logs link. It's important that you touch base with support. That quickly puts your issue in front of the developers 

Share this post


Link to post
Share on other sites

I am also having the same issue on kbuntu 17.04. I do not have enough time to try and debug and just wanted to let you know.

Share this post


Link to post
Share on other sites

Come back to check out the next update. It should drop as soon as next week

Share this post


Link to post
Share on other sites

I just purchased synergy today to use on my windows 7 machine and lubuntu machine. I am having this same issue. Has there been a fix found?

Share this post


Link to post
Share on other sites

buckey9251,

Let's look at your situation. Have you tried the troubleshooting steps? Maybe we can get you up and running.

First, try stop/start Synergy service on both computers.

Next, try reboot each.

Let us know what happens.

Share this post


Link to post
Share on other sites
Posted (edited)

There appears to be a problem when using KDE as the desktop. when you click Sign in with Symless, KDE redirects it to the browser you've chosen, but it seems Synergy 2 doesn't detect the signin.

This isn't a problem that can be fixed with troubleshooting; It's a blatant code bug where the login was untested with 17.10 and KDE. Please fix (will probably require a different sign in method, perhaps manual)!

Edit: Workaround for those using KDE: If you have gnome installed, log out and switch to gnome as your desktop environment. Login to synergy from there, then when it's working log out and back in using Plasma as your environment. Synergy should remain logged in. It's a terrible workaround considering you need an entire gnome install, but it worked for me.

Edited by Nacsiar

Share this post


Link to post
Share on other sites

Thanks for the workaround Nacsiar. I'll be trying it shortly on my Arch (KDE) install. Though as you say, it pains me to install an entire DE just to sign into Synergy.

As a side-note, how the hell can Synergy justify releasing and selling a product with so many issues? I dropped synergy 2 months ago back when it was on version 2.0.1 because of all of the issues and now I come back to find this stupid issue and that things aren't much better.

Come on guys, get your stuff together.

Share this post


Link to post
Share on other sites

I've solved this by change the default browser from chrome to firefox for the duration of the activation. After activation, I've switched back. This gave a temporary solution for me. Still incredibly frustrating to work through and I wouldn't have even tried that had it not been for this thread, but it was better than installing a new DE.

Share this post


Link to post
Share on other sites

SynUser2,

I'm not clear. Could you expand on your setup, the issue and then your workaround? It sounds like a slick way to handle...something. Installation?

Share this post


Link to post
Share on other sites

Good spot that - yep, my fedora issue - I'm using KDE. From a testing perspective, that are a lot of permutations to have to run through with this sort of app; sure isn't easy.

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

Just an update, installing MATE allowed me to get my account linked.

Now it won't connect to my other workstation, something about secondary screen unavailable. But I'll find/make a different thread for that issue.
Edit: seems to be explained in granpa's unofficial docs.

Thanks all

Edited by colwellkr

Share this post


Link to post
Share on other sites
On 3/21/2018 at 1:47 AM, GranPaSmurf said:

SynUser2,

I'm not clear. Could you expand on your setup, the issue and then your workaround? It sounds like a slick way to handle...something. Installation?

Background: Upgraded from 1.x to 2.x because of lost key and it no longer available on account page

Setup: Kubuntu 17.10

Issue: Unable to activate 2.x. Clicking sign in would open Chrome to the login page. Upon loging in the browser would take me to the Account page and not the Oauth sequence.

Workaround: Changed default browser from Chrome to Firefox and re-attempted. Sequence completed. Restored default browser to Chrome.

 

I've since uncovered other issues, but they are for another thread. Short answer don't change your DE, just momentarily switch away from Chrome. Solution for the devs to test: validate why Chrome and Firefox behave differently and either warn of the problem or code around it? I image it could save a few refunds.

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks for the workaround. 

My Kubuntu 17.10 KDE has always installed with no problem. I use Chromium, Firefox, and Opera. The default is Chromium. 

BTW, are you actually running Chrome, rather than Chromium?

 

Share this post


Link to post
Share on other sites

I have Kubuntu 18.04 installed, changing to Chromium from Firefox worked for me!

Share this post


Link to post
Share on other sites

18.04!?

I haven't noticed it's out. I may just jump on that

 

Share this post


Link to post
Share on other sites
On 3/27/2018 at 11:51 PM, RichUCT said:

Hi All

Just ran into this exact same problem under the new Bionic Bever Beta 18.04. (Running KDE as well.) I struggled for a little while as Firefox was the default application that the sign in web page was appearing in.

What I discovered is that I had to go into default applications and manually set me web browser to be firefox. It was grayed out with the default option of letting the type of URL define the application. Once I switched to manually setting everything to open in firefox it was all good!!. Hopefully someone is writing instructions on how to install in the different environments :)

 

This worked in my Fedora 27 (KDE) as well. Was able to set firefox as the default browser and synergy was able to log in.

It's strange that before it was set as default, synergy was able to launch the page, but just not get to the login page.

Thanks for the tip.

Share this post


Link to post
Share on other sites

Just another data point: If I understand, Bionic Beaver is still in beta. I haven't updated to it yet. I think I'll wait until the official release date sometime in late April. Though ordinarily, I jump on beta versions. Where's the fun of waiting until you guys have already enjoyed the glitches? 

I understand your experiences and appreciate the heads-up, but I'm kinda taking the thread with a grain of salt. There is a chance this is part of the 'beta' experience. 

Share this post


Link to post
Share on other sites

I was able to complete the sign-in process simply by setting XDG_CURRENT_DESKTOP to GNOME:

XDG_CURRENT_DESKTOP=GNOME synergy-config

 

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now