Sign in to follow this  
Ramon Gonzalez

Cannot get Windows to work as synergy server

3 posts in this topic

What version of Synergy? 1.7.3 Basic What OS is the Server? Windows 8.1 Pro What OS is the Client? Mac OS X 10.10.3 Any debugging messages? Sometime when the mouse in enter the Mac screen it will throw an error that the clipboard data is corrupted, "expected size=4 actual size=0" and then jump the mouse back to the windows screen. I used to use synergy a while ago when it was completely free. Now I paid for it and it isn't working :( . I tried setting the Mac as the server and that seems to work fine. Any suggestions?

Share this post


Link to post
Share on other sites
Version 1.7.3 still has some SSL bugs laying around. The good news is that they are being addressed for the 1.7.4 release. Disabling SSL encryption often solves these errors for the currrent release. For cases where you absolutely need encryption the 1.7.4 nightly build is stable as far as testing builds go. If disabling SSL doesn't solve this go for the latest and greatest!

Share this post


Link to post
Share on other sites
I am so sorry forgot you mentioned the Basic version! So embarassing. You might want to try resetting you clipboard somehow. Try copying something simple before you move over to the Mac. The log said "size=4" which is kind of odd.

Share this post


Link to post
Share on other sites
Ramon, I hope you are willing to post some info about the clipboard issue. There are many factors which can cause copy-paste issues. It would be very interesting to find out the content of your clipboard when this happens. Are you able to paste the clipboard content into a plain-text file (on both the PC and Mac), and then post that here for us? More things to find out: - exact behavior when something crashes/doesn't work - does Synergy continue working otherwise? - minimum steps to make Synergy work again if it closes/crashes/stops - Synbergy log content for each system involved, with logging level set to at least Debug - SSL enabled? - Synergy in "elevated" mode? - size of content copied (exact size in bytes, if possible) - where copied (application, OS, is it a Synergy server or client)? - where pasted? - problem occurs one-way, or both-ways? - if successful in copy-pasting opposite way, does copy-paste the original way then work? - intermittent? - copying plain-text? - are any non-English characters involved? - are any clipboard managers such as Glipper, Glippy, or Klipper running?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this