R.W

Raspberry PI - ARM support

10 posts in this topic

On 1/31/2018 at 12:10 PM, Nick Bolton said:

We plan on adding support in 2.1 which is due in about 6 months.

Will that support include basic universal armhf binaries for all arm-based systems? Besides the Raspberry PI there also exist the fairly popular Odroid lineup which run on armhf as well. The last version to exist for any Odroid ported distros is 1.8 or 1.6 in the case of Ubuntu 16.

Share this post


Link to post
Share on other sites
On 3/16/2018 at 3:33 PM, Tampa said:

universal armhf binaries

Sure, I don't see why not.

  • Thanks 1

Share this post


Link to post
Share on other sites
On 3/18/2018 at 6:38 PM, Nick Bolton said:

Sure, I don't see why not.

The release of today does not work on Ubuntu Mate on odroid, dependency issue libqt5core5a is version 5.5.1 with 5.7.0 needed.

Share this post


Link to post
Share on other sites
dpkg: dependency problems prevent configuration of synergy:
 synergy depends on libqt5core5a (>= 5.7.0); however:
  Version of libqt5core5a:armhf on system is 5.5.1+dfsg-16ubuntu7.5.
 synergy depends on libqt5svg5 (>= 5.6.0~beta); however:
  Version of libqt5svg5:armhf on system is 5.5.1-2build1.
 synergy depends on libssl1.1 (>= 1.1.0); however:
  Package libssl1.1 is not installed.
 synergy depends on libstdc++6 (>= 6); however:
  Version of libstdc++6:armhf on system is 5.4.0-6ubuntu1~16.04.9.
 synergy depends on qml-module-qtquick-controls (>= 5.5.0); however:
  Package qml-module-qtquick-controls is not installed.
 synergy depends on qml-module-qtquick-layouts (>= 5.5.0); however:
  Package qml-module-qtquick-layouts is not installed.
 synergy depends on qml-module-qtquick-dialogs (>= 5.5.0); however:
  Package qml-module-qtquick-dialogs is not installed.
 synergy depends on qml-module-qtquick2 (>= 5.5.0); however:
  Package qml-module-qtquick2 is not installed.

 

Share this post


Link to post
Share on other sites

Looks like we need some more builds!

Share this post


Link to post
Share on other sites
15 minutes ago, Nick Bolton said:

Looks like we need some more builds!

If you build it, I'll test it!

  • Like 1

Share this post


Link to post
Share on other sites
On 4/11/2018 at 10:51 AM, Nick Bolton said:

Looks like we need some more builds!

2.0.10 build I get this:

 

dpkg: dependency problems prevent configuration of synergy:
 synergy depends on libqt5core5a (>= 5.7.0); however:
  Version of libqt5core5a:armhf on system is 5.5.1+dfsg-16ubuntu7.5.
 synergy depends on libqt5svg5 (>= 5.6.0~beta); however:
  Version of libqt5svg5:armhf on system is 5.5.1-2build1.
 synergy depends on libssl1.1 (>= 1.1.0); however:
  Package libssl1.1 is not installed.
 synergy depends on libstdc++6 (>= 6); however:
  Version of libstdc++6:armhf on system is 5.4.0-6ubuntu1~16.04.9.

 

This is because either depending specifically to odroids builds or generally ARMHF is always behind on libs so using the latest from x86 equivalent will result in issues. Two ways, either port these libs yourself and provide them along with the builds or write them out/older versions.

Share this post


Link to post
Share on other sites

Will the support include the older armv6h architecture or should the current release (2.0.10) work on it?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now