Afo

Did someone succed in installing Synergy 2 on Debian 8 Jessie?

8 posts in this topic

I RUN: sudo dpkg -i ./synergy_2.0.4.stable_b1205+fcb59be4_amd64.deb 
(Reading database ... 172151 files and directories currently installed.)
Preparing to unpack .../synergy_2.0.4.stable_b1205+fcb59be4_amd64.deb ...
Unpacking synergy (2.0.4.stable~b1205+fcb59be4) over (2.0.4.stable~b1205+fcb59be4) ...
dpkg: dependency problems prevent configuration of synergy:
 synergy depends on libqt5core5a (>= 5.5.0); however:
  Version of libqt5core5a:amd64 on system is 5.3.2+dfsg-4+deb8u2.
 synergy depends on libstdc++6 (>= 5.2); however:
  Version of libstdc++6:amd64 on system is 4.9.2-10.
 synergy depends on qml-module-qtquick-controls (>= 5.5.0); however:
  Version of qml-module-qtquick-controls:amd64 on system is 5.3.2-2.
 synergy depends on qml-module-qtquick-layouts (>= 5.5.0); however:
  Version of qml-module-qtquick-layouts:amd64 on system is 5.3.2-2.
 synergy depends on qml-module-qtquick-dialogs (>= 5.5.0); however:
  Version of qml-module-qtquick-dialogs:amd64 on system is 5.3.2-2.
 synergy depends on qml-module-qtquick2 (>= 5.5.0); however:
  Version of qml-module-qtquick2:amd64 on system is 5.3.2-4.

dpkg: error processing package synergy (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for gnome-menus (3.13.3-6) ...
Processing triggers for mime-support (3.58) ...
Errors were encountered while processing:
 synergy


AND THEN: sudo apt-get -f install 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libasound2:i386 libdbus-1-3:i386 libdouble-conversion1 libexpat1:i386 libfontconfig1:i386
  libfreetype6:i386 libice6:i386 libjpeg62-turbo:i386 libpng12-0:i386 libsm6:i386 libx11-6:i386
  libxau6:i386 libxcb1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxi6:i386
  libxinerama1:i386 libxrandr2:i386 libxrender1:i386 libxtst6:i386
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  synergy
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 18.6 MB disk space will be freed.
Do you want to continue? [Y/n]

Any idea how to install it?

Share this post


Link to post
Share on other sites

I can't get mine going on rasbian. 

Share this post


Link to post
Share on other sites

This has been an issue with Synergy's packaging for Linux since almost day one. Easy fix. After you hit that error, run the following:
 

sudo apt-get -f install

That should manually pull in all the dependencies and complete the synergy installation.

Share this post


Link to post
Share on other sites

This really should be included with the install docs that don't exist. It's been an issue since the first .deb package released.
It's also an easy problem to just fix in the first place.

Share this post


Link to post
Share on other sites

on Debian 8 Jessie, apt-get -f install (apt --fix-broken install) just removes the broken install, i.e. Synergy. 

 

Share this post


Link to post
Share on other sites

Debian 8 is currently not a target, primarily due to the old version of Qt 5 available in the default repos. This is something we can probably work on if demand is high, but it's low priority right now.

Currently we build on Ubuntu LTS 16.04 (slightly newer than Jessie) and test on Debian 9 (Stretch), Ubuntu 16.04 and 17.10

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now