Rex Chan

Synergy 2.0 on Ubuntu listening on 127.0.0.1

2 posts in this topic

I installed Synergy 2.0 on an Ubuntu machine. The synergy-service started but synergy-core listens on 127.0.0.1:24801. Since it's listening on 127.0.0.1:24801, I couldn't connect to it from my another machine. I then execute the same synergy-core command with the process listening on 0.0.0.0:24801 instead of 127.0.0.1:24801 and it works. I then try to see how do I modify the start-up script so that it will listen on 0.0.0.0 instead of 127.0.0.1, but I couldn't find a solution. Does any know how do I do this?

This is the command started by /usr/bin/synergy-service

/usr/bin/synergy-core --client -f --run-as-uid 1000 --debug DEBUG --name my-hostname --enable-drag-drop --profile-dir /var/lib/synergy --log /var/log/synergy/synergy-core.log 127.0.0.1:24801

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now