Mapes

Synergy 2.04 Stable and Ubuntu

16 posts in this topic

The new stable release works fine for my two windows 10 devices.  The ubuntu 16.0.4 server i am running is not able to connect at all to the configuration servers.  Has anyone been able to get this working on ubuntu?  I have a support case open but they have not gotten back to be after submitting logs.  Any insight into what might be my issue would be great.

Share this post


Link to post
Share on other sites

Same problem here with Ubuntu 17.10. 

[ Config  ] [2018-01-12T11:40:37] debug: service cloud connection error
[ Service ] [2018-01-12T11:41:02] debug: retrying websocket connection now
[ Service ] [2018-01-12T11:41:02] debug: connecting websocket: pubsub1.cloud.symless.com:443
[ Service ] [2018-01-12T11:41:02] error: websocket handshake error 3: WebSocket upgrade handshake failed
[ Service ] [2018-01-12T11:41:02] error: websocket handshake response 400: Bad Request
[ Service ] [2018-01-12T11:41:02] debug: clearing last profile snapshot

Share this post


Link to post
Share on other sites

Did anyone find a resolution to this?  I uploaded logs to the support and they just want me reinstall and adjust arguments.  From my logs it looks like connection was refused.  I have since reverted back to 1.8 since i know that works and doesn't have a cloud component to it.

Share this post


Link to post
Share on other sites

So, it's not just me. I'm having that problem, plus another where Qt components can't be found:

"[ Config  ] " "[2018-02-05T10:17:44] debug: install dir: /usr/bin" 

"[ Config  ] " "[2018-02-05T10:17:44] info: log filename: /var/log/synergy/synergy-combined.log" 

"[ Config  ] " "[2018-02-05T10:17:44] warning: version check disabled, skipping" 

"[ Config  ] " "[2018-02-05T10:17:44] debug: connecting to background service" 

QQmlApplicationEngine failed to load component
qrc:/main.qml:1 module "QtQuick" is not installed
qrc:/main.qml:2 module "QtQuick.Controls" is not installed
qrc:/main.qml:1 module "QtQuick" is not installed
qrc:/main.qml:2 module "QtQuick.Controls" is not installed

"[ Config  ] " "[2018-02-05T10:17:44] debug: connected to background service" 

"[ Config  ] " "[2018-02-05T10:17:44] debug: sending uid to service: 1000" 

"[ Config  ] " "[2018-02-05T10:17:44] debug: saying hello to background service" 

"" "[ Service ] [2018-02-05T10:17:44] debug: setting core uid from rpc: 1000" 

"" "[ Service ] [2018-02-05T10:17:44] debug: saying hello to config ui" 

"[ Config  ] " "[2018-02-05T10:17:45] debug: service cloud connection error" 

"" "[ Service ] [2018-02-05T10:17:44] debug: retrying websocket connection now" 

"" "[ Service ] [2018-02-05T10:17:44] debug: connecting websocket: pubsub1.cloud.symless.com:443" 

"" "[ Service ] [2018-02-05T10:17:45] error: websocket handshake error 3: WebSocket upgrade handshake failed" 

"" "[ Service ] [2018-02-05T10:17:45] error: websocket handshake response 400: Bad Request" 

"" "[ Service ] [2018-02-05T10:17:45] debug: clearing last profile snapshot" 

"[ Config  ] " "[2018-02-05T10:17:45] debug: service cloud connection error" 

"" "[ Service ] [2018-02-05T10:17:45] debug: retrying websocket connection in 10s" 

"[ Config  ] " "[2018-02-05T10:17:45] debug: current version is update to date" 
 

Just to drive me still more crazy, I have another Ubuntu 16.04 system where it works perfectly. The system that isn't working was upgraded from 15.10. I've analyzed them and cannot see what the difference must be. If anyone has any ideas for troubleshooting, I'm all ears. I've been through double checking that all the proper qt5 packages are installed. I don't really want to migrate everything back to Synergy 1, but that's the next step if I can't get it going in the next few days.

Share this post


Link to post
Share on other sites

Another data point here.

My system has 2 Windows 10 machines, a Win 7(32) and Kubuntu 17.10. The systems work flawlessly together.

HOWEVER, I had to re-install 2.04 twice on the Kubuntu. How does a file get corrupted between download and solid install? I have no idea.

The Win 7(32) needed repeated restarts of the service before it settled down. So many that I dragged a shortcut to my taskbar for component services. After about 3 days of gnashing of teeth and muttered comments, it settled down and I could remove the shortcut.  Starts and works perfectly now.

Something I'm beginning to be aware of and starting to watch for on the forums. Something there is about Synergy 2.04 that doesn't like 4 or more computers at a time. In my setup, when I start an adjacent laptop, (Win 10) my 3rd machine (Win7) starts to go goofy. If I shut down the Win 7, then the Win 10 laptop works perfectly. Kill it and the Win7 gets happy again. I haven't seen this reported so it could be a quirk in my systems. 

I'm going to start asking how many computers are in the Synergy network. An ongoing area of curiosity. 

Share this post


Link to post
Share on other sites

Well, I tried redownloading and reinstalling just in case, but it made no difference.

Share this post


Link to post
Share on other sites

We are being told that the next 2.xxx is going to drop this week. 

If you need to drop back to Ver. 1 to get stability, hold on to your purchase instead of refund. Down the road, you will get some consideration for early adopting anyway.

Share this post


Link to post
Share on other sites

2.05 didn't help. It seem obvious to me that there is some issue with detection of the Qt libraries. Since I've got a second Ubuntu system that works, I should be able to compare them and figure out what the difference is, but so far...

Share this post


Link to post
Share on other sites

Ok, a little progress.

Versions 205 and 206 fix the connection errors, however I still get the QtQuick errors. I added the variable QML2_IMPORT_PATH which solved that error but fails a little farther on:

[email protected]:~$ QML2_IMPORT_PATH=/usr/lib/x86_64-linux-gnu/qt5/qml synergy-config
"[ Config  ] " "[2018-02-28T10:23:00] debug: install dir: /usr/bin" 

"[ Config  ] " "[2018-02-28T10:23:00] info: log filename: /var/log/synergy/synergy-combined.log" 

"[ Config  ] " "[2018-02-28T10:23:00] warning: version check disabled, skipping" 

"[ Config  ] " "[2018-02-28T10:23:00] debug: connecting to background service" 

"[ Config  ] " "[2018-02-28T10:23:00] debug: connected to background service" 

"[ Config  ] " "[2018-02-28T10:23:00] debug: sending uid to service: 1000" 

"[ Config  ] " "[2018-02-28T10:23:00] debug: saying hello to background service" 

qrc:/ActivationPage.qml:65:21: QML Image: Binding loop detected for property "sourceSize.height"
qrc:/ActivationPage.qml:65:21: QML Image: Invalid image data: qrc:/res/image/symless-signin-button.svg
"[ Config  ] " "[2018-02-28T10:23:00] warning: version check disabled, skipping" 

"" "[ Service ] [2018-02-28T10:23:00] debug: setting core uid from rpc: 1000" 

"" "[ Service ] [2018-02-28T10:23:00] debug: saying hello to config ui" 

QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior 2, swapInterval 1, profile  0) 
Aborted (core dumped)
 

Share this post


Link to post
Share on other sites

I've had to give up and go back to 1.8. It's frustrating because I'm sure it's some Qt weirdness, but I couldn't spend any more time trying to debug it. If anyone ever gets a clue, I'd love to get back to Synergy 2.

Share this post


Link to post
Share on other sites

just to clarify, you tried 2.0.7, right?

Share this post


Link to post
Share on other sites

No, I had to give up before it came out. I'm fairly confident it won't make a difference, but when I get a chance I may try it.

Share this post


Link to post
Share on other sites

Just another data point. I use Kubuntu 17.10 (Ubuntu). My issue with Synergy 2.0.4-5-6 was whenever the Synergy server, Win10, went off for some reason, Kubuntu wouldn't reconnect. I had to reboot to reconnect. Oh, and Kubuntu would sporadically grab Synergy control as the server. Not a big problem, it just had to be reset in the GUI.

Synergy 2.07 seems to be much improved for compatibility with Linux devices and works great on my machine. I think I'm noticing fewer posts about Linux on the forum.

Share this post


Link to post
Share on other sites
Posted (edited)

Just to follow up. I tried installing the Nvidia driver instead of Nouveau to try and fix this problem. In the course of this, I got into a bad place where the Nvidia driver couldn't drive an external monitor, and Nouveau wouldn't load at all. Apparently I'm not the only one to get screwed up by either the Ubuntu upgrade process or Nvidia's driver install process. This finally led me to reinstalling Ubuntu 16.04 LTS. This fixed everything. It was a little frustrating that I couldn't fix this without such a drastic measure, but I can now use either Synergy version. I occasionally get the problem where the Linux machine grabs the server role unexpectedly, but it seems to settle down after it happens a couple of times...at least until the next time I restart the Linux machine.

Edited by Davewill

Share this post


Link to post
Share on other sites

Great!

What version of Synergy are you using now? Version 2.07 is working well for me.

Version 2.08 is due to be available within a couple of days. I'm wondering if it will work better for you.

Share this post


Link to post
Share on other sites

I'm using 2.0.7. I'll upgrade when the next version comes out. It would be great if it behaves a little better.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now