BenS

Make "Share From" option in the config tool not change

16 posts in this topic

+1 for this feature.  I only ever want to share my keyboard/mouse from one computer and expect that the keyboard/mouse from every other computer stays dedicated only to those machines.

Share this post


Link to post
Share on other sites

+1

I want to share from my host's keyboard and trackpad, whilst also using my client's mouse without losing my host's sharing connection.

Edited by therug
clarification

Share this post


Link to post
Share on other sites

+1

I only have one mouse and keyboard connected to my computers. I've had to drag out additional mice because of the flippy floppy "share from" to correct the share from computer from time to time. (As long as the CTRL key is not locked on)

Share this post


Link to post
Share on other sites

I'm not even sure why it is switching. Literally the only config option is to manually check the 'Share From' location -- and it does not appear to be honored.  It would be different if switching the active server was seamless, but its not. It literally took me a week of working with support to figure out that the reason my main workstation could never control my secondary one was because the secondary machine keep switching to  'server' -- despite my manually setting the 'share from'....

  • Like 1

Share this post


Link to post
Share on other sites

Yes!  The default for Synergy 2 should be like Synergy 1 -- one server that doesn't change unless the user makes the change.  This has been driving me nuts!  Often I use the touchpad on my Windows laptop while Synergy is enabled on the OSX server -- now with Synergy 2, when it decides to make my Windows laptop the server, it changes the range of my touchpad to let it overscroll into OSX, and this happens while I'm moving the cursor so I end up clicking the entire wrong item.

I also was tailing the logs for a while on my Linux client, and if Synergy can't connect to the last server as a client a few times, it will then give up and start the core as a server instead??  This was so hard to debug until I watched the logs.  This seems to have been reduced since I updated to 2.0.5.  I hope my clients won't restart themselves in server mode ever again.  (This is usually a good habit in all sorts of programming and control systems, predictable one-way control flow.)  Thanks!!

Share this post


Link to post
Share on other sites

+1

Some way to force always use selected computer keyboard and ignore the others

Share this post


Link to post
Share on other sites

I have already created a post for this in the feature request section and it has been slated for 2.1 in a few months.

Share this post


Link to post
Share on other sites

But its not a new feature, it's a bug fix.

Share this post


Link to post
Share on other sites

Technically, it'd be reverting a new feature.

Share this post


Link to post
Share on other sites

If the feature doesn't work, it's fixing a bug. There is a 'serve from this computer' setting that doesn't work. Either the fact it exists is a bug, or the fact that it doesn't work is a bug. Making the *ONLY* configuration option work is not a new feature, nor is it reverting a new feature.

  • Like 1

Share this post


Link to post
Share on other sites

Can't disagree with that reasoning; it's literally the only option available currently.

Share this post


Link to post
Share on other sites

I have not seen my win7 take over as server, and it refuses to do it when I try to tell it to.  I frequently use both mice and keyboards without experiencing a server swap.  It stays where I put it, just the way I like it. in the Fedora box.
There has to be a two-way hand-shake protocol where the server gives up control followed by the client accepting control, like a change of the guard.

 

Share this post


Link to post
Share on other sites

According to a symless employee, this 'feature' is working as intended. It simply forces the hosts to switch which one is the server, but does NOTHING to prevent it from immediately switching back. He claims that the fact that this feature doesnt work is not a bug.

Share this post


Link to post
Share on other sites

I would accept this being a "Feature" if my linux box would take over as the server when i start using it again. But for right now the only way to make my linux box the server again is to manually change it in the configuration

Share this post


Link to post
Share on other sites

I have the exact opposite problem. Despite telling my Windows box to be the server, I cannot consistently move the mouse to the Linux box, as the Linux box randomly decides it's the server (even though that was not up for discussion -- I MANUALLY SPECIFIED THE SERVER).

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now