ntq

Secondary Screen unavailable: unable to open screen

14 posts in this topic

Posted (edited)

Hi.

Just tried Synergy 2.0.4 stable for the first time and it's already annoying. After realizing it has opened 20 tabs in my browser in the background because of clicking like an idiot on "Connect with Symless" I was able to register my Ubuntu Gnome 16.04 and my Windows 7 machine to Symless. Now the Windows machine is green, but the Ubuntu machine remains gray. Because I started synergy-config from the terminal I can see the following Errors:

"" "[Core    ] [2018-01-09T17:58:36] DEBUG: XOpenDisplay(\":0.0\")"
"" "[Core    ] No protocol specified"
"" "[Core    ] [2018-01-09T17:58:36] WARNING: secondary screen unavailable: unable to open screen"
"" "[Core    ] [2018-01-09T17:58:36] DEBUG: retry in 60 seconds"

Now my question: Why is it looking for a second screen? I did not have attached one to my thinkpad. Where can I configure which display to open? There is nothing to configure. I also want to deactivate this cloud s**t. I want to be able to use Synergy without internet access.

Also after closing synergy I immediately get an invalid pointer on free() and a Backtrace. I can not copy paste it at the moment because Synergy is not working and the Backtrace is on my other PC.

Edited by jml
Declining profanity and approving.

Share this post


Link to post
Share on other sites

You may want to try version 1.x. Despite the  labeling with "stable," it is far from it, and at this point working like beta. Congrats, you paid to be a beta tester.

Share this post


Link to post
Share on other sites

That's ridiculous.So there is a stable now release which works exactly as shitty as the beta 4 I tested months before? Nice. What are they doing with my money? Sending it to Linux Tech Tips so he can make ads in every second video with him?

  • Like 1

Share this post


Link to post
Share on other sites

Yes, that works, and I can connect 2 arch linux systems together now. This is however, a dumb way to resolve this and it's not how I expect this to work. Why does synergy-service needs to run as root? Shouldn't this run by a systemd-user thing?

On 1/11/2018 at 12:20 PM, DangPTran said:

Then start the binary  synergy-service *with sudo synergy-service.

 

  • Like 1

Share this post


Link to post
Share on other sites

I had to do the same thing in Fedora.

 

  • Like 1

Share this post


Link to post
Share on other sites

@TrentC Please read the forum rules: 

 

Share this post


Link to post
Share on other sites
On 1/10/2018 at 11:20 PM, DangPTran said:

I made mine work by killing the service (not sure about ubuntu but on arch is systemctl stop synergy, then  systemctl disable synergy So it does not autostart)

Then start the binary  synergy-service *with sudo synergy-service.

Thanks! After wasting too many hours fiddling with Synergy 2, this finally resolved the issue for me on Ubuntu 17.10. Much appreciated! 

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Seamless said:

Thanks! After wasting too many hours fiddling with Synergy 2, this finally resolved the issue for me on Ubuntu 17.10. Much appreciated! 

Yeah, too bad there was not any documentation so people would know about this.

 

 

Share this post


Link to post
Share on other sites
On 1/30/2018 at 1:10 PM, Seamless said:

Thanks! After wasting too many hours fiddling with Synergy 2, this finally resolved the issue for me on Ubuntu 17.10. Much appreciated! 

Also worked great for me to fix a new install of Ubuntu 17.10.  Please document this!

Share this post


Link to post
Share on other sites

Yes it's work for me on Ubuntu 17.10 !!!

But when I reboot computer,  I have to repeat the same operation ...

does anyone know how to fix this ?

Thanks

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now