profnova

Stop synergy from disabling DPMS

4 posts in this topic

Posted (edited)

Is there anyway to get synergy to not disable DPMS as I would like my monitors to go to sleep when they are not in use but when I enable DPMS synergy turns it off again as soon as the monitor has gone to sleep. This occurs on more than 1 pc running Linux

 

I also cant seam to find where synergy stores it's config file on Linux.

 

OS: Ubuntu Linux 17.10 with budgie desktop

Screen resolution: 3840x2160

Screen connection type: HDMI 2.0

GPU: GTX 1050ti

Gpudriver: 387.34

Synergy Version 2.0.4

Edited by profnova

Share this post


Link to post
Share on other sites

Yep - me too.  I just finally converted over from Synergy 1 this week and am seeing the same thing.  Long ago I had somehow sorted out the DPMS settings interacting with synergy1 so my monitors on all systems would all sleep - seems like there used to be a checkbox in one of the startup screens which either helped or hurt, I remember it being counterintuitive, but it finally settled down and "just worked." 

 

After switching to synergy 2, when I come back upstairs in the AM, my linux monitors are all blazing, windows ones are all off, and dmps has been disabled on linux as per the last lines of the xset -q:

DPMS (Energy Star):
  Standby: 10    Suspend: 10    Off: 10
  DPMS is Disabled
 

I can enable it manually using a very short timeout, but it only works that once and then goes disabled again.  That's like having to manually shut your monitors off when you leave.  Anybody have a fix?

Share this post


Link to post
Share on other sites

Yep, I have at least - although it's one support request which has been open since my initial installation of synergy2 (replacing years of syn1) which didn't seem to work at all at first then I updated it when it started to work, and now has this DPMS issue as #1 and a periodic disconnect where synergy just stops working for a few seconds to a few minutes as #2.  Both Sarah and Joe have both replied (mostly just saying it would take awhile to look at and apologizing) but I did finally collect and send log URLs from both sides.  Hopefully it can be figured out!  Thanks for the reply...

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now