Stoh

Synergy switch control randomly

22 posts in this topic

Hello,

I use synergy to share my mouse/keyboard from a linux computer to a windows laptop.

It works well for something like an hour, and then w/o any reason, synergy starts sharing from the laptop (there's the little dot below the windows computer in synergy windows). If I use "share from <linux computer>" option, it works again for an hour our so, and then it happens again.

The laptop is next to me, doesn't have a mouse (only a pad) so I'm sure there was no accidental input from it that might confuse synergy.

This happen consistently, even after restarting both the computer and the laptop. I have noticed it is often tied to the use of a meta key (shift, alt etc.)

Any idea what could be causing this ?

logs from the laptop computer right after the problem happened (while i was typing "{" + space -> "{" was received by the windows laptop, space was received by the linux computer) : https://synergy-logs.symless.com/d353aaff1a93ac9a67de1a40abba139d/logs/8607-2018-01-05T13-54-47.log

 

Share this post


Link to post
Share on other sites
21 minutes ago, Stoh said:

It works well for something like an hour, and then w/o any reason, synergy starts sharing from the laptop (there's the little dot below the windows computer in synergy windows). If I use "share from <linux computer>" option, it works again for an hour our so, and then it happens again.

And that's why automatic server switching surely looked awesome on paper, but in practice it's a dumb idea IMHO. The way Synergy 1.x worked was great: you have one server; that's your primary machine. If for some reason you need to input something using the client's mouse or keyboard, it works locally to that computer. Then you go back to your main machine and keep working as usual.

Seriously, does anyone go around constantly switching from one keyboard and mouse to the other? Doesn't that make Synergy kind of pointless?

Share this post


Link to post
Share on other sites

I am experiencing the same issue. I am running Linux Mint 18 on an older Macbook Pro and Windows 10 on my PC. After a short while when I want to switch from PC to Macbook the cursor reorientates to the middle of my Monitor and the control is temporarily switched to the Macbook. Any way to disable this automatic switching?

Share this post


Link to post
Share on other sites

The most annoying thing with this bug is that it doesn't switch back to sharing from the computer with the actual mouse/keyboard automatically, I have to manually change it every time. I wouldn't mind as much if that wasn't the case.

I didn't find any workaround yet.

Share this post


Link to post
Share on other sites

Yep - I'm experiencing same problem. 

I believe this is a known bug and they are working on it.  According to my logs, it appears the "server" crashes and takes a bit of time to restart & reconnect.

[ Router  ] [2018-01-21T14:21:14] debug: ClientProxy: Received client connection for **** from screen 76632
[ Router  ] [2018-01-21T14:21:14] debug: Error reading from core server: The I/O operation has been aborted because of either a thread exit or an application request
[ Router  ] [2018-01-21T14:21:14] debug: Terminating core server read loop
[ Core    ] [2018-01-21T14:21:14] NOTE: client "****" has disconnected

 

I seem to have a workaround that works about 90% of the time for me:

1) Always have Synergy app loaded un-minimized but out of focus.

2) After failing to switch to another screen, bring the Synergy app to focus. 

3) Wait until all screens are green and you should be good.

 

 

  • Like 1

Share this post


Link to post
Share on other sites
On 21.1.2018 at 9:30 PM, chasmfiend said:

I seem to have a workaround that works about 90% of the time for me:

1) Always have Synergy app loaded un-minimized but out of focus.

2) After failing to switch to another screen, bring the Synergy app to focus. 

3) Wait until all screens are green and you should be good

I have found the same "workaround", but am increasingly frustrated by the number of random control-switches the App is performing. It takes about 5-10 seconds every time it happends (which is every 1-2 minutes depending on how often I switch devices) to make my primary device the one whos peripherals are used.

Rather inconvenient to say the least...

 

Share this post


Link to post
Share on other sites

+1  This annoys the hell out of me.

If you want to make the interface "simple", fine... but give us an advanced panel option where we could change settings like forcing one computer to be the master.

Share this post


Link to post
Share on other sites

+1
Super annoying, I agree it needs a setting to force a master server

Share this post


Link to post
Share on other sites

Hi Nick

Thanks for replying to this - when can we expect  2.1 to come out?

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites

+1

auto-switching happen to me when I am forced to use the client keyboard because meta-keys are not working in RDP (server Linux, client mac). The forced master configuration will be really appreciated (although it wouldn't be a problem for me if the meta-keys problem gets also fixed)

Share this post


Link to post
Share on other sites

Also experiencing this issue.

Share this post


Link to post
Share on other sites

Also experiencing this issue. I would rather there be an option to choose a server and clients, and not have automatic switching.

Share this post


Link to post
Share on other sites

this issues is frustrating, because is necessary check if you are working in the right machine or not

Share this post


Link to post
Share on other sites

Unfortunately have the same issue.

The workaround for me is to disable AutoHotkey temporarily, but it is annoying and I can forget to turn it back on.

Waiting for 2.1 update.

Share this post


Link to post
Share on other sites

+1 I have this issue too.

How do you disable AutoHotKey

Share this post


Link to post
Share on other sites

Is there a release date for 2.1?

Share this post


Link to post
Share on other sites

Still experiencing this problem, I guess we're still waiting for 2.1?

Share this post


Link to post
Share on other sites

This is still an issue. 

On 26/1/2018 at 7:43 AM, Nick Bolton said:

2.1 will have this setting.

Cool, but this is now almost 5 months ago that that was announced :( This is making synergy useless for me, as it usually happens within 1 minute of use.

Share this post


Link to post
Share on other sites

This is happening to me as well. Just within a few minutes of running the software on two windows 10 machines. Almost unusable. 

From what I can see, the client and server keeps switching between the two pcs and when this happens, the seamless movement of the mouse is interrupted. Any idea on when the fix will come out as what was mentioned by Nick Bolton? 

 

Share this post


Link to post
Share on other sites

I'll jump in with the "Me too!"  

I'm so glad I found this thread.  I've been thinking that it was something with my setup.

Agreed that some info as to the status of 2.1 would be great given the post.  Also, it would be great if we could just create a config file that denotes a dedicated server, or exclude a machine from becoming the server.  ~/.synsergy/notaserver.cfg or something. 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now