James Hessin

Severe lag between Mac and PC

26 posts in this topic

I have used synergy 1 for a while to great effect. I rarely have a problem setting it up (occasionally I would need to restart the service or something). The mouse and keyboard work great across from my Mac to PC and vise versa.

That being said when I updated to Synergy 2 I expected a bit of a hiccup - however what I have found is that the lag that it introduces makes it impractical at best and unusable at worst. Sometimes the mouse cursor will make it halfway across the screen smoothly before freezing - but usually it will only make it a quarter of the distance before coming to a grinding halt. I'm not sure what the cause of this lag is, but it is not even close to as prevalent when using synergy 1 - which I have returned to until these bugs can be worked out of synergy 2.

Share this post


Link to post
Share on other sites

I have the same issue on one computer (windows 10 x64).  The other one (Windows 10 also) has no lag, and my osx high sierra has no lag either.

Have no clue on what is making this happen. The lagging comp is the one with the best specs but has also the most processes running. Haven't tried synergy 1 on that comp at the moment.

Share this post


Link to post
Share on other sites

I have this same issue, which I mentioned in another thread that apparently got deleted.  I can't understand why other than the fact that it didn't paint Synergy 2 in a favorable light.  I use Synergy on a daily basis for work.  I gladly purchased version 1 and 2, however I cannot use version 2 at all because of the performance issues.  My hope was that the problems would get discussed and addressed in the thread I started, but hopefully they will be here.

Share this post


Link to post
Share on other sites

Yes indeed.

This is a great product but maybe tested a little too less to be usable at the beginning of version 2.

I love the features. I tried to remove not daily used programs that could maybe use some processes (remote desktop, virtualbox, vnc). I don't have any technical skill to understand what the problems can be, can just try... it lagged much on one comp and not the other but they have same version off legit windows 10 with latest updates. 

The support just told me they have not enough people to give this kind off support and redirected me to this forum. Commercial thing, they offered me to refund my order if I wanted. I think this company has great ideas, great devs but maybe a little to less time. That said I could reuse synergy 1.8 bit decided to just plug in a keyboard and mouse for when I need it until the lag is fixed

 Have a great day/night depending on where you love and happy new year to all!

Share this post


Link to post
Share on other sites

Same for me.
To be more accurate, the lag especially happens when changing from 1 screen to another (in my case it's a Windows/MacOS).
The delay is close to 1 second which makes Synergy 2 totally broken UX-wise.

Still waiting for my refund. In the meantime, i'm using good ol' Synergy 1 which still works great.

Share this post


Link to post
Share on other sites

Also, I really don't get why the handling of Synergy2 has to go through an external service. It's efficient as a anti-hack solution, I GET IT, but what good does it do if it turns your product to total crap? (question is rhetorical).

Share this post


Link to post
Share on other sites

I just upgraded to Synergy 2 and when using it on my 2 Mac's I get severe mouse and keyboard lag when sharing them on the other Mac. 
I also don't understand how I can configure the app anymore (probably a question for a new post). I used to have it set up so I'd have to hold a key before the mouse could switch to the other Mac but I see no were to change settings. 

Share this post


Link to post
Share on other sites
45 minutes ago, Preston said:

I see no were to change settings.

That's because there isn't any configuration, not until version 2.1 which should come out in a few weeks. The new Synergy is meant to allow non-tech users to set it up more easily by making them tinker with systemd config files, terminal commands and registry keys.

  • Like 1

Share this post


Link to post
Share on other sites

Hello , any news on this issue

i have win 10 and win 7 

While moving mouse everything is ok

While doings someting like typing or draging windows i have a sever mose lag.

 

Synergy 1 was ok .

Share this post


Link to post
Share on other sites

UPDATE: I switched from WIFI to ETHERNET

and everything is fine now)

Share this post


Link to post
Share on other sites

Hello,

I was already in ethernet, both comps connected on the same gigabit router.

What version do you use ? I switched back to synergy 1 because off that lag...

Share this post


Link to post
Share on other sites

I'm having the same problems with lag and delay as the mouse cursor transitions from one system to the next. I've gone back to v1 and it's significantly better. Keeping my fingers crossed for a fix soon!

Share this post


Link to post
Share on other sites

Hello,

Same issue here - I was showing off to my colleagues about finding the perfect solution for my Win10 / Ubuntu dual system setup, but the keystrokes sometimes slow down dramatically. Any suggestions? I'm running it as root in the Ubuntu box.

Thanks!

Share this post


Link to post
Share on other sites
3 hours ago, DaveSF said:

Hello,

Same issue here - I was showing off to my colleagues about finding the perfect solution for my Win10 / Ubuntu dual system setup, but the keystrokes sometimes slow down dramatically. Any suggestions? I'm running it as root in the Ubuntu box.

Thanks!

Yeah, go back to version 1.  It still works flawlessly.

Share this post


Link to post
Share on other sites

I had the same issue at launch of Synergy 2 and went back to version 1. 

Share this post


Link to post
Share on other sites

The mouse lag and stutter can be from several causes. Be sure to post your case with support. Report your experience to support. Send logs for each machine. Trouble tickets drive development. https://symless.com/contact/customer-support

Sometimes the cause is Synergy. The usual troubleshooting steps usually help. Stop/start Synergy service - Temporarily re-arrange screens displayed in the UI - Re-boot computers - Clean uninstall/reinstall.

In other cases the issue originates within the OS. Obviously something is chewing up the resources of a machine. In my own case it was an old Win 7 (32) that was begging for an HD de-frag. 

 

Report your experience to support. Send logs for each machine. Trouble tickets drive development.

Share this post


Link to post
Share on other sites

Often it’s other apps that cause this too; there’s a Qt bug that affects many apps, causing ping spikes on Mac.

 

Share this post


Link to post
Share on other sites

Yeap. I agree with most of guys here.

I bought Synergy 2 about two months ago to go latest version, but had to go back to Synergy 1.

The lagging in Synergy 2 makes it useless.

Like Nick, CEO of Symless, said, there could be multiple reasons for this.

However, if I just compare Synergy 1 and 2, Synergy 1 is way more stable than 2.

I just retried Synergy 2 with some hope, but I have to go back to Synergy 1.

Don't buy Synergy 2 yet unless you're super patient. just stick to Synergy 1.

 

 

 

Share this post


Link to post
Share on other sites

Yeap. I agree with most of guys here.

I bought Synergy 2 about two months ago to go latest version, but had to go back to Synergy 1.

The lagging in Synergy 2 makes it useless.

Like Nick, CEO of Symless, said, there could be multiple reasons for this.

However, if I just compare Synergy 1 and 2, Synergy 1 is way more stable than 2.

I just retried Synergy 2 with some hope, but I have to go back to Synergy 1.

Don't buy Synergy 2 yet unless you're super patient. just stick to Synergy 1.

BTW, Synergy 2 uses more CPU resource than Synergy 1 based on what I have seen.

 

Share this post


Link to post
Share on other sites

Yeah, I just upgraded to Synergy 2 Pro and can report the same. Mouse is really painful to use on a mac client. I'm using ethernet (was using wifi) and it's still pretty unusable :(

Share this post


Link to post
Share on other sites

(My setup is Windows 10 providing native mouse/keyboard to macOS High Sierra.)

Share this post


Link to post
Share on other sites

On Synergy 2.012 Beta.  All the same problems outlined in Dec 2017 STILL existing on my Windows 10 Pro / Mac as outlined by everyone else. Mac on wifi or ethernet does the same thing.

Share this post


Link to post
Share on other sites

Some users have installed Synergy 2 Beta without knowing that it's now a beta version. It's still at the early prototyping stage and contains many bugs. You may not be aware that Synergy 1 is actually the current stable version. So if this is the case, please could you switch to Synergy 1? Make sure you uninstall Synergy 2 Beta.

Share this post


Link to post
Share on other sites

I agree about the product being advertised in beta,
but there is a difference between "having some minor bugs here and there" and "not usable because of some critical malfunction". To me this product should be labeled as an alpha version.
If the Synergy2 beta was free, or part of a more gentle beta program (aka not making the user pay the full price for it), this point would be indeed moot but that's not the case.

I dont have a PR degree, but asking users to uninstall something THEY PAID FOR and go back to the older version wich they also paid for is just not the commercial statement you want to make :-|

Edited by Myst

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now