macdows

LoadLibrary failed with error 87: The parameter is incorrect.

8 posts in this topic

Using Windows 10 and Mac. With the Windows x64 version 2.0.3 I suddenly got this error when starting up the desktop application. Support could not help me and offered a refund. I suspect this started to happen after the latest windows update (Feature update to Windows 10, version 1709). Uninstalling and reinstalling does not help. Now I get the error on installation as well.

Edited by macdows

Share this post


Link to post
Share on other sites

I have the same setup and just started seeing the same issue. Did you figure out a solution/cause? I don't see any updates since I installed Synergy

Share this post


Link to post
Share on other sites

Another data point: Synergy is working fine on my Win 10, Creators version latest updates. 

If I were having the issues you mention, I would consider reinstalling Synergy. 

If you choose to reinstall, best practice is to do a clean install. After you uninstall the current version, clean all leftover files. Search the drive for any files "Synergyxxx." There are programs that do this for you; I use a free version of Revo Uninstaller. 

Again, best practice is to download a new instance of the current Synergy version. 

Please post your results for everyone's troubleshooting info. 

Share this post


Link to post
Share on other sites

After a little more experimentation, I found this error is related to my primary display. If I change my primary display, Synergy loads just fine. Once synergy is loaded, I can change my primary display back and it keeps working.

 

My setup is:

I have SpaceDesk setup on my desktop. That allows me to use my Mac as another screen. I use synergy to be able to use the mac's keyboard and mouse for windows. Basically this allows me to extend my entire windows desktop to the mac. The SpaceDesk screen was the one which had issues

Share this post


Link to post
Share on other sites
16 hours ago, Sid said:

After a little more experimentation, I found this error is related to my primary display. If I change my primary display, Synergy loads just fine. Once synergy is loaded, I can change my primary display back and it keeps working.

 

My setup is:

I have SpaceDesk setup on my desktop. That allows me to use my Mac as another screen. I use synergy to be able to use the mac's keyboard and mouse for windows. Basically this allows me to extend my entire windows desktop to the mac. The SpaceDesk screen was the one which had issues

You were right! Didn't think about it but I use EVGA UV+ to extend display to external monitors. When changing main display to the laptop monitor, it works. This workaround is ok, only backdraw is that I can not choose external screen as primary display in Windows. I can live with that for now, but this should be fixed.
 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now