b2k

Ubuntu 17.10 synergy-core stuck on 127.0.0.1:24801

7 posts in this topic

Running latest (2.0.3), tried uninstall & reinstall, restarting, etc.

Windows & mac versions seem to run okay, but the Ubuntu one will only work if I kill the "synergy-core" service and run the same command *without* the 127.0.0.1 for the address so the command ends with just ":24801" instead of "127.0.0.1:24801". Unfortunately there does not seem to be any way to easily override this with configuration.

Hopefully this helps someone else with the same issue, or maybe someone else knows a way to override.

Share this post


Link to post
Share on other sites

I'm having a simular issue, but from both the windows side and the linux side. They keep going into the loop of "route is to self" and closes..

now i finally got the logs to say they connected, but the Ubuntu one is is saying the secondary screen is not available. 

 

https://synergy-logs.symless.com/f9cedc5c4ccce0e623ab5e2e9a2a05e6/logs/19226-2017-12-18T11-36-24.log

 

really disappointed that it doesn't work at all. I've been using synergy for a long time, and this version 2 stuff is not even trying to work..

I don't want a refund i want it to work. and I can't get it to work..

Share this post


Link to post
Share on other sites
52 minutes ago, zaazz said:

What's the full command to launch it from the CL?

The command which synergy runs by default is (you can find this by running "ps ux | grep synergy-core")

/usr/bin/synergy-core --server -f --run-as-uid 1000 --debug DEBUG --name *YOUR HOST NAME* --enable-drag-drop --profile-dir /var/lib/synergy --log /var/log/synergy/synergy-core.log -c /var/lib/synergy/synergy.conf --address 127.0.0.1:24800

 

You just want to remove the localhost IP so the new command to run is

/usr/bin/synergy-core --server -f --run-as-uid 1000 --debug DEBUG --name *YOUR HOST NAME* --enable-drag-drop --profile-dir /var/lib/synergy --log /var/log/synergy/synergy-core.log -c /var/lib/synergy/synergy.conf --address :24800

Edited by b2k

Share this post


Link to post
Share on other sites
13 minutes ago, b2k said:

The command which synergy runs by default is (you can find this by running "ps ux | grep synergy-core")

/usr/bin/synergy-core --server -f --run-as-uid 1000 --debug DEBUG --name *YOUR HOST NAME* --enable-drag-drop --profile-dir /var/lib/synergy --log /var/log/synergy/synergy-core.log -c /var/lib/synergy/synergy.conf --address 127.0.0.1:24800

 

You just want to remove the localhost IP so the new command to run is

/usr/bin/synergy-core --server -f --run-as-uid 1000 --debug DEBUG --name *YOUR HOST NAME* --enable-drag-drop --profile-dir /var/lib/synergy --log /var/log/synergy/synergy-core.log -c /var/lib/synergy/synergy.conf --address :24800

This works despite logs telling me the connections are dead. Thank you.

Share this post


Link to post
Share on other sites

this solution only works one way. when i reconfigure and launch like this it only works if I then go to the "config" window and right click and "share from" the Ubuntu machine. 

trying to share from the Windows 10 side is a fail, Can't seem to find the equal setting over there. but you're on to something. this is the first time I got the mouse to cross the screen. look like the core app on windows 10 may have the same options to run, but I can't get it to connect just yet still trying. 

Share this post


Link to post
Share on other sites

ok, now I was able to break into it on the windows side too..

it broke the fancy UI that allows you to re-arrange the service.. and I have to have a command window up and running all the time... for now.. 

 

on the ubuntu this is running...
/usr/bin/synergy-core --client -f --run-as-uid 1000 --debug DEBUG --name <LINUXCOMPUTERNAME> --profile-dir /var/lib/synergy --log /var/log/synergy/synergy-core.log --server <WIN10COMPUTERNAME>

and on the windoze side...

"C:\Program Files\Synergy\synergy-core.exe" --server --address :24800 --name <WIN10COMPUTERNAME> -c "%userprofile%/AppData\Local\Symless\Synergy\synergy.conf" --profile-dir "C:\ProgramData\Symless\Synergy"

No advantage over the 1.8 version I had before.. at this point.. how does one provide feedback to Synergy to help them know how to fix this? 

The support people "don't have time for my $h..." oop well that's not fair they did in email responding to my criticism by requesting logs. 
 

Edited by M T
missing junk

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now