AndyLeeMeUk

macOS Bugs

3 posts in this topic

Dear All,

My systems are both running macOS 10.13.2 they are both on wired connections on the same network.  There are some very annoying repeatable bugs which plague the macOS version of this software:

  • Once both systems have gone into Sleep Mode Synergy 2.0.2 does not function properly if at all (In most cases it will not function) until both the systems are restarted, it gets stuck in a loop:
  • Server
    [ Router  ] [2017-12-09T11:23:38] debug: ClientProxy: Received client connection for Tengu.local from screen 23618
    [ Core    ] [2017-12-09T11:23:38] NOTE: accepted client connection
    [ Core    ] [2017-12-09T11:23:38] DEBUG: received client "Tengu.local" info shape=0,0 0x0 at 0,1209
    [ Core    ] [2017-12-09T11:23:38] ERROR: invalid message from client "Tengu.local": DINF
    [ Router  ] [2017-12-09T11:23:38] debug: Error reading from core server: End of file
    [ Router  ] [2017-12-09T11:23:38] debug: Terminating core server read loop
    [ Core    ] [2017-12-09T11:23:38] NOTE: new client disconnected
  • Client
    [ Core    ] [2017-12-09T11:23:06] NOTE: connecting to '127.0.0.1': 127.0.0.1:24801
    [ Router  ] [2017-12-09T11:23:06] debug: Saying Hello to core client
    [ Core    ] [2017-12-09T11:23:15] NOTE: server is dead
    [ Router  ] [2017-12-09T11:23:15] debug: Error reading from core client: End of file
    [ Router  ] [2017-12-09T11:23:15] debug: Terminating core client read loop
    [ Core    ] [2017-12-09T11:23:15] WARNING: failed to connect to server: server is not responding
    [ Core    ] [2017-12-09T11:23:15] DEBUG: retry in 1 seconds
  • Clipboard sharing does not work as intended, instead the mouse curser will leave one screen and will go off, make some tea and biscuits and at some point (usually 3-5 seconds later) after there is a notification in the top right of the screen that it is receiving clipboard from the other system... It will reappear.

Please let me disable this function, it is driving me mad!! >:(

Edited by AndyLeeMeUk

Share this post


Link to post
Share on other sites

I can confirm the behavior regarding MacOS and Sleep Mode.  

Is this a known bug?

 

- Charles

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now