AWidodo

Synergy Service Fails To Start During Installation Windows 7

12 posts in this topic

Old Version working fine then I uninstall, reboot the machine then install V2.0.2 start problem.

During installation on Windows 7 Home Premium, Synergy Version 2.0.2 (64-bit)

Popup Windows says:

Service "Synergy" (synergy) failed to start. Verify that you have sufficient privileges to start system services.

 Even user Account Control Settings to  bottom (never notify)

Share this post


Link to post
Share on other sites

Having the same issue on one of my machines. Also looking for a solution.

Share this post


Link to post
Share on other sites

support told me i need to update windows 7... im doing it now.. 

Share this post


Link to post
Share on other sites
On 2/11/2018 at 7:32 PM, timonthepeak said:

SOLVED WITHOUT WINDOWS UPGRADE

Download and run the Microsoft Visual C++ Redistributable for Visual Studio 2017.
https://support.microsoft.com/en-ph/help/2977003/the-latest-supported-visual-c-downloads

Run cmd as administrator.
msiexec /i Synergy_v2.0.5-blah_blah_blah.msi

I tried this today and it's still not working. I have a support ticket open too. Could the problem be that one of my computers is a corporate computer? I have access to install whatever software I want on this computer. Running Windows 7 Professional it says under "My Computer". 

When I try to open the GUI, Process Explorer shows the .exe load for a second and then it auto closes itself.

Share this post


Link to post
Share on other sites

So I just performed a full uninstall following these directions: https://symless.com/forums/topic/4519-synergy-2-how-to-uninstall-and-reinstall/

 

Then I installed synergy following the directions above regarding Microsoft Visual C++ Redistributable for Visual Studio 2017.

After installation, the gui half-loaded. I could see the window but its contents was solid white. The top bar said "Synergy (Not responding)"

I closed and tried to open it again, and now it won't even load the blank screen. It just keeps closing itself back out.

 

Will keep this updated as I learn more.

 

Share this post


Link to post
Share on other sites

Same issue here. Fresh install of Win 7 Ultimate (Win7 Service Pack 1 installed`).
Synergy v2.0.5 still doesn't complete the install. Stops at starting services. 
- Redistributable for Visual Studio 2017 fails to install too for some reason.

Older version of Synergy (Synergy 1.8) worked on Win7.

:(:(

Share this post


Link to post
Share on other sites

update .net and try c++ redist 2013 and 2015 also might give you some clue on dependency issues.

or you can use the dependancy walker if you want to try to figure that out.  I think SP1 for windows has the .net update to 2013 but no higher which may be related.

 

http://www.dependencywalker.com/

Share this post


Link to post
Share on other sites

We run into the same issue since we do fresh Windows 7 installs regularly. If you go into Windows Update, scan for updates, and install them (we only ever do the first batch, it's about 900MB worth) then Synergy should install no problem. I'm guessing Windows Update takes care of adding the services that a clean Windows 7 install doesn't have. Hope that works for you!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now