Sign in to follow this  
Mike Taatgen

Synergy 1.7.3 won't open on OS X El Capitan

4 posts in this topic

Do you mean the window won't open at all? This one would be so much easier if I knew someone else running the OS X preview. If you describe everything that happens after clicking on the Synergy Icon, that would be amazing. And by everything, I really do mean every little popup, animation, and sound. You are my eyes and ears!

Share this post


Link to post
Share on other sites
Me too and this is in my system.log: Jun 29 16:18:37 promote Synergy[2290]: WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.0 instead of 10.11.0. This is not a bug in Gestalt -- it is a documented limitation. Use NSProcessInfo's operatingSystemVersion property to get correct system version number. Call location: Jun 29 16:18:37 promote Synergy[2290]: 0 CarbonCore 0x00007fff93fd2d0b ___Gestalt_SystemVersion_block_invoke + 113 Jun 29 16:18:37 promote Synergy[2290]: 1 libdispatch.dylib 0x00007fff9a286765 _dispatch_client_callout + 8 Jun 29 16:18:37 promote Synergy[2290]: 2 libdispatch.dylib 0x00007fff9a28665d dispatch_once_f + 67 Jun 29 16:18:37 promote Synergy[2290]: 3 CarbonCore 0x00007fff93f5ebd7 _Gestalt_SystemVersion + 987 Jun 29 16:18:37 promote Synergy[2290]: 4 CarbonCore 0x00007fff93f5de6b Gestalt + 139 Jun 29 16:18:37 promote Synergy[2290]: 5 QtCore 0x0000000109ec0c76 _ZN9QInternal17activateCallbacksENS_8CallbackEPPv + 2598 Jun 29 16:18:37 promote Synergy[2290]: 6 ??? 0x00007fff68be2b1b 0x0 + 140734950681371 Jun 29 16:18:41 promote login[2291]: USER_PROCESS: 2291 ttys000 Jun 29 16:18:42 promote com.apple.xpc.launchd[1] (synergy.341152[2290]): Service exited with abnormal code: 1 Jun 29 16:18:42 promote spindump[584]: Saved spin report for Synergy version ??? (???) to /Library/Logs/DiagnosticReports/Synergy_2015-06-29-161842_hellozzjdeMacBook-Pro.spin Jun 29 16:18:47 promote kernel[0]: prlnet: wifi dhcp timeout, patching dhcp

Share this post


Link to post
Share on other sites
I concur this is also happening to me. An older version (pre installed) of synergy was working fine after I upgraded to EL Capitan. The main window asked me to upgrade so I did. Since I upgraded when I launch the application the icon appears on the dock and bounces for a few moments. The status bar icon does not appear and in the system.log i have the same message as above. My best guess is that the new version is not passing code signing due to changes in El Capitan, however pre verified applications continue to work without issue. [code]Jul 15 15:21:37 codys-mac-mini Synergy[15084]: WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.0 instead of 10.11.0. This is not a bug in Gestalt -- it is a documented limitation. Use NSProcessInfo's operatingSystemVersion property to get correct system version number. Call location: Jul 15 15:21:37 codys-mac-mini Synergy[15084]: 0 CarbonCore 0x00007fff86d6bccb ___Gestalt_SystemVersion_block_invoke + 113 Jul 15 15:21:37 codys-mac-mini Synergy[15084]: 1 libdispatch.dylib 0x00007fff84b6ac11 _dispatch_client_callout + 8 Jul 15 15:21:37 codys-mac-mini Synergy[15084]: 2 libdispatch.dylib 0x00007fff84b6ab09 dispatch_once_f + 67 Jul 15 15:21:37 codys-mac-mini Synergy[15084]: 3 CarbonCore 0x00007fff86cf7b97 _Gestalt_SystemVersion + 987 Jul 15 15:21:37 codys-mac-mini Synergy[15084]: 4 CarbonCore 0x00007fff86cf6e2b Gestalt + 139 Jul 15 15:21:37 codys-mac-mini Synergy[15084]: 5 QtCore 0x00000001098b7c76 _ZN9QInternal17activateCallbacksENS_8CallbackEPPv + 2598 Jul 15 15:21:37 codys-mac-mini Synergy[15084]: 6 ??? 0x00007fff68200b1b 0x0 + 140734940318491 Jul 15 15:21:37 codys-mac-mini tccd[302]: Unable to verify code signing identity of synergy: code failed to satisfy specified code requirement(s)[/code]

Share this post


Link to post
Share on other sites
Update! I decided to look though GitHub for any updates on this bug. It seems that there is a work around available that works. In the past you had to enable Synergy in the privacy section of mac preferences. It seems as though Synergy was listed there it was still failing. Once I removed Synergy and re added it everything is working without issue now. [attachment=0]Screen Shot 2015-07-15 at 3.47.55 PM.png[/attachment]

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this