Kevin Farley

Problem connecting to the auto-config service

36 posts in this topic

None of my machines have been able to stay connected this morning, between logging me out and requiring me to log back in again but giving me the message "Oops! There was a problem" but no further actions available, or telling me the Cloud Service was unreachable, or the often seen "There was a problem connecting to the auto-config service. Retry" which does nothing.  Where do we go for network status updates so we don't need to waste time posting here or contacting support?

Share this post


Link to post
Share on other sites

There was some brief downtime while we upgraded a server over Thanksgiving, which was resolved yesterday.

Share this post


Link to post
Share on other sites

Thanks Nick.  Now that it seems Synergy is so closely reliant on the cloud services, downtime on your server seems like downtime for all of us, is there any plan for a zero downtime maintenance path, or at the very least choosing a time to upgrade your servers that isn't during prime usage periods?  I'm in Eastern Standard Time and it seems this affected me all morning long.  I realize as a global service, my prime time is potentially others down time, but there's got to be a better way, I rely on this for much of my day to day and it caused a lot of pain yesterday.  Appreciate you and your teams efforts, as a full stack engineer myself, I totally get the difficulty in pleasing everyone!

Share this post


Link to post
Share on other sites

Don't worry, we're doing 4 things:

  • Adding redundancy to our cloud infrastructure (we'll shoot for 99.99% uptime; 1h a year)
  • Moving all non-essential things away from the cloud (auto-switching, config updates, etc)
  • Make it still completely usable if the cloud goes offline (apart from the initial setup for when in online mode)
  • Adding a full offline mode for people who can't use the internet (e.g. oil rigs, military bases, etc)
  • Like 1

Share this post


Link to post
Share on other sites

Have the auto-config service resumed? My machines are still unable to connect to the auto-config service.

Share this post


Link to post
Share on other sites

I am having the same problem with my "client" machine. I had to restart both services, but the client will not re-connect.

Share this post


Link to post
Share on other sites

I just upgrade to synergy 2 today, and "There was a problem connecting to the auto-config service. Retrying..." on both my windows and mac. So sad.

Share this post


Link to post
Share on other sites

I just downloaded synergy 2 and cannot connect to the auto-config service either.

Share this post


Link to post
Share on other sites
1 hour ago, LiQing said:

I guess, in China, the site 'https://pubsub1.cloud.symless.com/' has been blocked by A Firewall, you know.

I hope Synergy Team can resolve this problem for China users. If not, add a proxy feature??

 

Hi LiQing, where did you get the url "https://pubsub1.cloud.symless.com/'", I can only find "v1.api.cloud.symless.com" in capture tools. And by the way, even if add a proxy, still can't connect to auto-config service.

Share this post


Link to post
Share on other sites
4 minutes ago, GaryZheng said:

Hi LiQing, where did you get the url "https://pubsub1.cloud.symless.com/'", I can only find "v1.api.cloud.symless.com" in capture tools. And by the way, even if add a proxy, still can't connect to auto-config service.

You can find the url in log. Synergy maybe use global proxy, I can't find a way to set a global proxy on computer for Synergy. And I set the proxy in the router.

Share this post


Link to post
Share on other sites
2 hours ago, LiQing said:

You can find the url in log. Synergy maybe use global proxy, I can't find a way to set a global proxy on computer for Synergy. And I set the proxy in the router.

After some tests, I found synergy-service was not obey the system proxy settings, that’s why I can’t find it in capture tools. There is a software called profixer, you can config *.symless.com go through a proxy to walk around this instead of setting proxy in your router. But I think this is still a issue to us. Better way to solve this is adding proxy config right in the app or Synergy team can set more servers. 

Share this post


Link to post
Share on other sites
11 minutes ago, GaryZheng said:

After some tests, I found synergy-service was not obey the system proxy settings, that’s why I can’t find it in capture tools. There is a software called profixer, you can config *.symless.com go through a proxy to walk around this instead of setting proxy in your router. But I think this is still a issue to us. Better way to solve this is adding proxy config right in the app or Synergy team can set more servers. 

synergy still can not connect to pubsub1.cloud.symless.com:443 even though I setup a VPN. But pinged pubsub1.cloud.symless.com with OK responses.

Share this post


Link to post
Share on other sites

I've been using Synergy for longer than I can remember and have loved it. Version 2 has me concerned. I like a clean interface, but there is NOTHING. No help, no anything. I tried v2 beta 4 and had to uninstall because it would not connect between my Windows 10 and Linux desktops. That was about a month ago. This weekend I upgraded to v2 and still there is a failure to connect to the auto-config service.

Even worse, there doesn't seem to be any resolution to all these threads I'm seeing in the forum. I did a wireshark capture and it looks like a session is established between my host and the 45.55.221.2 server and then just when data is being transfered back and forth, the server ends the connection. I'm going back to v. 1.8 and not trying 2 again until I see some positive comments in these forums.

Share this post


Link to post
Share on other sites

I'm also having this issue. I just noticed that 2.0.2 was released as a stable build and decided to come back to it after not having any luck with it in beta. I was hoping for a seamless Symless experience, but all I got was "There was a problem connecting to the auto-config service". I have tried on both a Windows 10 and OSX machine with the same results. Back to Synergy 1 until this gets resolved.

Share this post


Link to post
Share on other sites

From the other topic that shares this name, it was recommended to do a complete uninstall of Synergy and reinstall. I followed the documented procedure. This allowed my Windows machine to get past this error, but my OSX machine did not. Since I do not have another machine for testing, I couldn't verify if the software was in a working state or not.

Share this post


Link to post
Share on other sites

Similar problems here. Synergy 2 "stable" releases... aren't. Can't reliably connect, interface is useless, reinstalling doesn't fix anything. Also reverting to Synergy 1. And I just paid $29 for a second license - more fool me.

Share this post


Link to post
Share on other sites
4 hours ago, Wei Jin said:

synergy still can not connect to pubsub1.cloud.symless.com:443 even though I setup a VPN. But pinged pubsub1.cloud.symless.com with OK responses.

Pinged(icmp) ok dosen't mean any thing. synergy-service connects under tcp protocol, whitch GFW can easy block TCP traffic on port 443.

 

4 hours ago, Wei Jin said:

synergy still can not connect to pubsub1.cloud.symless.com:443 even though I setup a VPN. But pinged pubsub1.cloud.symless.com with OK responses.

Are you sure you are under a "Globle mode"? In my case, after proxy synergy-service, this app runs great.

Share this post


Link to post
Share on other sites

I uninstalled the current version and installed 1.8, until this is resolved.

Share this post


Link to post
Share on other sites

Hi,

i just upgraded to version 2 and i'm not able to connect to the "cloud". can somone give me a hint how to solve this?

 

Platform:

arch linux - 4.13.12-1-ARCH

packet synergy2 2.0.2.stable~b1046+665fa610-1 (AUR)

systemctl

Nov 27 22:51:24 ikarus synergy-service[594]: [ Service ] [2017-11-27T22:51:24] debug: retrying websocket connection now
Nov 27 22:51:24 ikarus synergy-service[594]: [ Service ] [2017-11-27T22:51:24] debug: connecting websocket: pubsub1.cloud.symless.com:443
Nov 27 22:51:24 ikarus synergy-service[594]: [ Service ] [2017-11-27T22:51:24] error: websocket handshake error 3: WebSocket Upgrade handshake failed
Nov 27 22:51:24 ikarus synergy-service[594]: [ Service ] [2017-11-27T22:51:24] error: websocket handshake response 400: Bad Request
Nov 27 22:51:24 ikarus synergy-service[594]: [ Service ] [2017-11-27T22:51:24] debug: clearing last profile snapshot
Nov 27 22:51:24 ikarus synergy-service[594]: [ Service ] [2017-11-27T22:51:24] debug: retrying websocket connection in 10s

config tool starting

"[ Config  ] " "[2017-11-27T23:04:14] debug: install dir: /usr/bin" 
"[ Config  ] " "[2017-11-27T23:04:14] info: log filename: /var/log/synergy/synergy-combined.log" 
QObject::startTimer: Timers cannot have negative intervals
"[ Config  ] " "[2017-11-27T23:04:14] debug: connecting to background service" 
"[ Config  ] " "[2017-11-27T23:04:14] debug: connected to background service" 
"[ Config  ] " "[2017-11-27T23:04:14] debug: sending uid to service: 1000" 
"[ Config  ] " "[2017-11-27T23:04:14] debug: saying hello to background service" 
qrc:/ActivationPage.qml:65:21: QML Image: Binding loop detected for property "sourceSize.height"
qrc:/ActivationPage.qml:65:21: QML Image: Error decoding: qrc:/res/image/symless-signin-button.svg: Unsupported image format
"" "[ Service ] [2017-11-27T23:04:14] debug: setting core uid from rpc: 1000" 
"" "[ Service ] [2017-11-27T23:04:14] debug: saying hello to config ui" 
"[ Config  ] " "[2017-11-27T23:04:14] debug: service cloud connection error" 
"" "[ Service ] [2017-11-27T23:04:14] debug: retrying websocket connection now" 
"" "[ Service ] [2017-11-27T23:04:14] debug: connecting websocket: pubsub1.cloud.symless.com:443" 
"" "[ Service ] [2017-11-27T23:04:15] error: websocket handshake error 3: WebSocket Upgrade handshake failed" 
"" "[ Service ] [2017-11-27T23:04:15] error: websocket handshake response 400: Bad Request" 
"" "[ Service ] [2017-11-27T23:04:15] debug: clearing last profile snapshot" 
"[ Config  ] " "[2017-11-27T23:04:15] debug: service cloud connection error" 
"" "[ Service ] [2017-11-27T23:04:15] debug: retrying websocket connection in 20s" 
"[ Config  ] " "[2017-11-27T23:04:15] debug: current version is update to date" 
"[ Config  ] " "[2017-11-27T23:04:15] debug: current version is update to date" 
QThreadStorage: Thread 0x7fe0bc003220 exited after QThreadStorage 7 destroyed
ping pubsub1.cloud.symless.com
PING pubsub.cloud.symless.com (45.55.221.2) 56(84) bytes of data.
64 bytes from 45.55.221.2 (45.55.221.2): icmp_seq=1 ttl=55 time=87.1 ms

 

Share this post


Link to post
Share on other sites

I get the "problem connecting to the auto-config service" error on both my Windows PC and Mac. Nick, have you considered using a local config file? I don't understand what's the point of a cloud config service, especially when all the above users can't connect to it! Synergy just doesn't work. Sadly after my attempts to make one of the betas work, which failed, I was hoping for better with a "stable" release. Annoyingly I too now have to uninstall and reinstall an older version. Such a waste of time. :-(

Share this post


Link to post
Share on other sites
6 hours ago, bugfry said:

Hi,

i just upgraded to version 2 and i'm not able to connect to the "cloud". can somone give me a hint how to solve this?

 

Well, unlike every other internet application I use on Ubuntu, Synergy 2 doesn't seem capable of working through an internet proxy- at least not by using the system's proxy settings. (Perhaps there's a manual config file option you can tweak?) If you are behind a firewall, this is probably the problem. See this thread. I just uninstalled and went back to version 1.8.

14 minutes ago, LiQing said:

image.thumb.png.6f2b2b8e6686f3cdcf4bf6197c579b38.png

This is from Symless Team. Add an offline version in Synergy 2.1

In my case Synergy2 isn't explicitly being blocked by any firewall, the application is just not honoring my system's internet proxy settings. I am wondering whether they actually developed this tool without proxy support? Previous versions didn't need it, but now that you have to sign on to a cloud account...

Edited by UltimateOutsider

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now