aristizabal95

Synergy minimizes full screen programs on Windows

13 posts in this topic

I'm having this problem whenever I switch from one screen to another while running a fullscreen program on my windows. The program either gets minimized completely, or the computer brings the taskbar upfront. This happens whether my windows behaves as a client or a server. This is really frustrating since I lose focus of the program I'm running.

How to replicate

Open a browser on a windows with synergy 2

press F11 or make the browser full screen

Switch screens

Taskbar should show on top until the user returns to the windows computer

Share this post


Link to post
Share on other sites
10 hours ago, JLJTGR said:

This used to be avoided by a Synergy setting called "Don't take foreground window on Windows servers".

Without any settings interface in Synergy 2 we have no obvious way to configure this, but it is still a setting.  Synergy 2's configuration can be found at %LOCALAPPDATA%\Symless\Synergy\synergy.conf and the setting you want is "win32KeepForeground = true".

To keep the changes you will need to modify the file properties to Read-only or else Synergy2 will overwrite your changes when it next launches.  Speaking of, you need to restart the Synergy service in order for the setting to take effect at all.  (or reboot)

 

This fixed my problem! I'm hoping Synergy 2.1 adds all the configuration synergy1 had, as most of the problems I'm having are due to a lack of configuration. Thanks for posting the solution

Share this post


Link to post
Share on other sites
On 22/11/2017 at 7:17 PM, aristizabal95 said:

I'm having this problem whenever I switch from one screen to another while running a fullscreen program on my windows. The program either gets minimized completely, or the computer brings the taskbar upfront. This happens whether my windows behaves as a client or a server. This is really frustrating since I lose focus of the program I'm running.

How to replicate

Open a browser on a windows with synergy 2

press F11 or make the browser full screen

Switch screens

Taskbar should show on top until the user returns to the windows computer

seems to work ok for me windows 10 pro 

Share this post


Link to post
Share on other sites
Just now, MichaelDaCova said:

seems to work ok for me windows 10 pro 

to add works ok the pc that is the server, but not the client 

Share this post


Link to post
Share on other sites

You saved me from going back to version 1 thanks a lot!

Share this post


Link to post
Share on other sites

So I have tried to make this change permanent but i went into properties and clicked "read only" but every time i turn my computer on it still does not work, until i reset the service manually. Can someone please help with how to make this not happen? Thank you in advance 

Share this post


Link to post
Share on other sites

Unfortunately I reverted to v1 for other reasons, so I can't test any advice.  It worked for me back in November but maybe they have made additional changes.

Share this post


Link to post
Share on other sites

Thanks a lot for the fast reply, I guess i will have to keep messing with it. I am honestly blown away by this v2 after only a day. I can not see any reason on earth why they would take away ALL settings from this. I get they want it to be "auto config" but the only people using this program are people who have a basic understanding of computers. Can't see some Grandma with her triple monitor 2+ computer setup being grateful that they took all the "confusing settings" out of v2. haha i don't get it lol

Share this post


Link to post
Share on other sites

Now that I think about it... the v1 service starts before Windows login and then restarts when the user logs in.  Maybe v2 starts with the configuration not in a user's folder but somewhere else.  Try looking in the following location:

"C:\ProgramData\Symless\Synergy"

At worst case, you could use a Windows task to restart the service when your user logs in.

Share this post


Link to post
Share on other sites

Following the discussion, I could'nt find any settings on neither of this directories:

C:\ProgramData\Symless\Synergy -> Doesn't exist.

C:\ProgramData\Synergy

C:\ProgramData(x64)\Synergy

Seems like config can only be found on the directory @JLJTGR pointed first.

From my experience, ever since I did this change I've had no problems concerning full-screen apps minimizing on my windows client.

However, when I tried to do something similar on my Mac server, the app couldn't connect to the cloud config. I would just say that this change may work most of the times, but can also bring some unexpected behavior form the app.

I'm also kind of bummed by the fact that there is no way of configuring synergy, let's just hope syn2.1 will fix most of our UX problems.

Share this post


Link to post
Share on other sites
On 27/11/2017 at 6:11 AM, JLJTGR said:

To keep the changes you will need to modify the file properties to Read-only or else Synergy2 will overwrite your changes when it next launches

Nice tip!

Share this post


Link to post
Share on other sites
On 22/01/2018 at 9:43 PM, aristizabal95 said:

I'm also kind of bummed by the fact that there is no way of configuring synergy, let's just hope syn2.1 will fix most of our UX problems.

The settings screen is coming soon to 2.1, which is due in about 6 months.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now