Amy Fox

Stopping the service

13 posts in this topic

Seriously? With that many issues this software has (and I can tell for sure it's practically the same as version 1.8.x because it has exact the same issues) you don't even give us the option to restart the service from the UI?

That's ridiculous, as if you're not even aware of all the issues.

Restarting my Windows host now doesn't fix stuck-rmouse-button issue on my macbook-client, for example.

In version 1.8.x restarting Synergy via GUI on the Windows host always fixed that for me.

I want an option to restart Synergy via GUI, and it should not be optional, because this software is definitely not capable of proper self-config, as intended.

Edited by Martin Fürholz

Share this post


Link to post
Share on other sites

Now even restarting it as described above on both the Windows host and the Macbook client fixes that issue for me. Only way is to reboot the client. Which is horrible because I get this issue almost daily.

 

@Amy Fox thanks for posting the workaround.

Edited by Martin Fürholz

Share this post


Link to post
Share on other sites

I want to say I agree that it's unacceptable to have released this software as "v2.0" without basic features like "disable" present.

  • Like 1

Share this post


Link to post
Share on other sites
On 26/01/2018 at 9:27 PM, Craig Kovatch said:

unacceptable / basic features

We’re adding this feature in 2.1. The most requested features are implemented first. This is not the most requested feature right now, so it'll be done later.

Share this post


Link to post
Share on other sites

Yeah this is greatly pissing me off.

I use synergy with a laptop and a desktop.  Sometimes I take the laptop to the couch but Synergy won't let go.

And there's no "Disable" button.  This is auto-configure run amok.

Here's something for you OSX users:

edit your ~/.bash_profile and add these two lines:

alias synergy-stop="launchctl unload /Library/LaunchAgents/com.symless.synergy.synergy-service.plist"
alias synergy-start="launchctl load /Library/LaunchAgents/com.symless.synergy.synergy-service.plist"

open a new terminal and you'll have synergy-stop and synergy-start to control synergy.

If you want to get real fancy you could do the same with something like fastscripts.

  • Like 1

Share this post


Link to post
Share on other sites

We'll have a much simpler way to start and stop synergy coming very soon. Stay tuned. 

Share this post


Link to post
Share on other sites
On 2/14/2018 at 9:32 AM, osopolare said:

Here's something for you OSX users:

edit your ~/.bash_profile and add these two lines:

alias synergy-stop="launchctl unload /Library/LaunchAgents/com.symless.synergy.synergy-service.plist"
alias synergy-start="launchctl load /Library/LaunchAgents/com.symless.synergy.synergy-service.plist"

open a new terminal and you'll have synergy-stop and synergy-start to control synergy.

 

Super helpful, thanks for this!

Looking forward to 2.1.

Share this post


Link to post
Share on other sites
Posted (edited)

I just spent 10 minutes screwing with this on my Mac/Windows pair at work. It seems like the service on the Mac runs in stealth mode, and if you try to run the "Synergy" GUI it starts a second instance of the service and everything is unhappy? So I quit the GUI and ran the "launchctl unload"/"launchctl load" pair which calmed things down. Anyway, the pointer sharing is working, but I can't run the GUI on the Mac or it stops working. If I look at the GUI on the Windows system, it shows the Mac with the "green Cylon eye" seeking the device, even though I can move my pointer to the Mac screen.

I appreciate you're a small shop, but things seem pretty messed up right now.

This might be a complex problem to fully solve, I remember hassles like this with the previous revisions as well. At least a "disable/enable" button to control the service would be a little friendlier than having to Google a fix and run a cryptic command-line cycle each time things go wonky.

Edited by Nick Vargish
clarification on how I worked around the issue

Share this post


Link to post
Share on other sites

I see this feature added in the last release.

Thank you.

Share this post


Link to post
Share on other sites

When I move the mouse off my screen, it minimizes my fullscreen apps. That's unacceptable, so I tried to stop synergy. I can't figure out how to do it. There's nothing in the UI, and the processes in windows task manager bring each other back when killed.

 

I paid for your product, I don't want to use it, and I can't get rid of it. At this point I would pay you to get rid of your product.

Share this post


Link to post
Share on other sites
3 minutes ago, Joe Mathes said:

When I move the mouse off my screen, it minimizes my fullscreen apps. That's unacceptable, so I tried to stop synergy. I can't figure out how to do it. There's nothing in the UI, and the processes in windows task manager bring each other back when killed.

 

I paid for your product, I don't want to use it, and I can't get rid of it. At this point I would pay you to get rid of your product.

Hey Joe,

I'm pretty sure the new version of synergy supports stopping the service built into the program now. Right clicking on the app in the tray on windows gives you the option to stop the service. Sometimes if the synergy app isn't running you have to open it first then you can disable it in the tray. 

If you still have issues getting that to work I linked a file in google drive which are 2 .exe files (windows only) you just have to run that file and it will either stop/start the service :)

https://drive.google.com/open?id=1GoFBk49XlfRnkGsjFjwc0fBNkSmWBFix

Regards, Jay

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now