DeepakK

Unable to install Synergy 2.01 in Ubuntu 12.04

4 posts in this topic

I am trying to install Synergy 2.01 on Ubuntu (I have a older system and some important data, so migration is not possible right now).

I get the below error,

sudo dpkg -i /home/dkamurthy/symless/synergy_2.0.1.stable-b1034+59dd93a0_amd64.deb
(Reading database ... 238325 files and directories currently installed.)
Preparing to replace synergy 2.0.1.stable~b1034+59dd93a0 (using .../synergy_2.0.1.stable-b1034+59dd93a0_amd64.deb) ...
Unpacking replacement synergy ...
dpkg: dependency problems prevent configuration of synergy:
 synergy depends on libc6 (>= 2.17); however:
  Version of libc6 on system is 2.15-0ubuntu10.7.
 synergy depends on libqt5core5a (>= 5.5.0); however:
  Package libqt5core5a is not installed.
 synergy depends on libqt5gui5 (>= 5.0.2) | libqt5gui5-gles (>= 5.0.2); however:
  Package libqt5gui5 is not installed.
  Package libqt5gui5-gles is not installed.
 synergy depends on libqt5network5 (>= 5.0.2); however:
  Package libqt5network5 is not installed.
 synergy depends on libqt5qml5 (>= 5.1.0); however:
  Package libqt5qml5 is not installed.
 synergy depends on libqt5quick5 (>= 5.0.2) | libqt5quick5-gles (>= 5.0.2); however:
  Package libqt5quick5 is not installed.
  Package libqt5quick5-gles is not installed.
 synergy depends on libqt5widgets5 (>= 5.0.2); however:
  Package libqt5widgets5 is not installed.
 synergy depends on libstdc++6 (>= 5.2); however:
  Version of libstdc++6 on system is 4.6.3-1ubuntu5.
 synergy depends on init-system-helpers (>= 1.18~); however:
  Package init-system-helpers is not installed.
 synergy depends on qml-module-qtquick-controls (>= 5.5.0); however:
  Package qml-module-qtquick-controls is not installed.
 synergy depends on qml-module-qtquick-layouts (>= 5.5.0); however:
  Package qml-module-qtquick-layouts is not installed.
 synergy depends on qml-module-qtquick-dialogs (>= 5.5.0); however:
  Package qml-module-qtquick-dialogs is not installed.
 synergy depends on qml-module-qtquick2 (>= 5.5.0); however:
  Package qml-module-qtquick2 is not installed.
dpkg: error processing synergy (--install):
 dependency problems - leaving unconfigured
Processing triggers for mime-support ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Errors were encountered while processing:
 synergy
 

Could  anyone suggest any fixes?

Thanks.

Share this post


Link to post
Share on other sites

Help or I want my money back!!!!!!!!!!!!!!!!!:

 

[email protected]:~ # cd /home/afernandez/Downloads/
[email protected]:Downloads # dpkg -i synergy_2.0.3.stable_b1125+8a08e664_amd64.deb 
Selecting previously unselected package synergy.
(Reading database ... 221854 files and directories currently installed.)
Preparing to unpack synergy_2.0.3.stable_b1125+8a08e664_amd64.deb ...
Unpacking synergy (2.0.3.stable~b1125+8a08e664) ...
dpkg: dependency problems prevent configuration of synergy:
 synergy depends on libqt5core5a (>= 5.5.0); however:
  Version of libqt5core5a:amd64 on system is 5.3.2+dfsg-4+deb8u2.
 synergy depends on libqt5qml5 (>= 5.1.0); however:
  Package libqt5qml5 is not installed.
 synergy depends on libqt5quick5 (>= 5.0.2) | libqt5quick5-gles (>= 5.0.2); however:
  Package libqt5quick5 is not installed.
  Package libqt5quick5-gles is not installed.
 synergy depends on libstdc++6 (>= 5.2); however:
  Version of libstdc++6:amd64 on system is 4.9.2-10.
 synergy depends on qml-module-qtquick-controls (>= 5.5.0); however:
  Package qml-module-qtquick-controls is not installed.
 synergy depends on qml-module-qtquick-layouts (>= 5.5.0); however:
  Package qml-module-qtquick-layouts is not installed.
 synergy depends on qml-module-qtquick-dialogs (>= 5.5.0); however:
  Package qml-module-qtquick-dialogs is not installed.
 synergy depends on qml-module-qtquick2 (>= 5.5.0); however:
  Package qml-module-qtquick2 is not installed.

dpkg: error processing package synergy (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.58) ...
Errors were encountered while processing:
 synergy
[email protected]:Downloads # apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
  libavahi-compat-libdnssd1 libqt5qml5 libqt5quick5
Use 'apt-get autoremove' to remove it.
The following packages will be REMOVED:
  synergy
0 upgraded, 0 newly installed, 1 to remove and 149 not upgraded.
1 not fully installed or removed.
After this operation, 18.1 MB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 221866 files and directories currently installed.)
Removing synergy (2.0.3.stable~b1125+8a08e664) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.58) ...
[email protected]:Downloads #

Share this post


Link to post
Share on other sites

the same thing here

[email protected]:~/Downloads$ sudo dpkg -i synergy_2.0.3.stable_b1125+8a08e664_amd64.deb
Selecting previously unselected package synergy.
(Reading database ... 407817 files and directories currently installed.)
Preparing to unpack synergy_2.0.3.stable_b1125+8a08e664_amd64.deb ...
Unpacking synergy (2.0.3.stable~b1125+8a08e664) ...
dpkg: dependency problems prevent configuration of synergy:
 synergy depends on libqt5core5a (>= 5.5.0); however:
  Version of libqt5core5a:amd64 on system is 5.4.2+dfsg-2ubuntu9.
 synergy depends on qml-module-qtquick-controls (>= 5.5.0); however:
  Package qml-module-qtquick-controls is not installed.
 synergy depends on qml-module-qtquick-layouts (>= 5.5.0); however:
  Version of qml-module-qtquick-layouts:amd64 on system is 5.4.2-1ubuntu2.
 synergy depends on qml-module-qtquick-dialogs (>= 5.5.0); however:
  Version of qml-module-qtquick-dialogs:amd64 on system is 5.4.2-1ubuntu2.
 synergy depends on qml-module-qtquick2 (>= 5.5.0); however:
  Version of qml-module-qtquick2:amd64 on system is 5.4.2-1ubuntu6.

dpkg: error processing package synergy (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.13.3-6ubuntu1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu3) ...
Processing triggers for bamfdaemon (0.5.2~bzr0+15.10.20150627.1-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.58ubuntu1) ...
Errors were encountered while processing:
 synergy
[email protected]

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now