TheLordOfDarkness

Synergy 2 on debian 9

7 posts in this topic

I am unable to install synergy(newest version):

sudo dpkg -i ~/Downloads/synergy_2.0.1.stable-b1034+59dd93a0_amd64.deb
[sudo] password for mikhail:
Selecting previously unselected package synergy.
(Reading database ... 177323 files and directories currently installed.)
Preparing to unpack .../synergy_2.0.1.stable-b1034+59dd93a0_amd64.deb ...
Unpacking synergy (2.0.1.stable~b1034+59dd93a0) ...
dpkg: dependency problems prevent configuration of synergy:
 synergy depends on libssl1.0.0 (>= 1.0.0); however:
  Package libssl1.0.0 is not installed.

dpkg: error processing package synergy (--install):
 dependency problems - leaving unconfigured
Processing triggers for mime-support (3.60) ...
Errors were encountered while processing:
 synergy

 

Share this post


Link to post
Share on other sites

After you get that dpkg error above, run:

sudo apt-get -f install

That will fill in the dependencies and finish configuring the synergy deb.

Edited by Robert Holak

Share this post


Link to post
Share on other sites

I am having a similar problem on Kali

apt install ./synergy_2.0.1.stable-b1034+59dd93a0_amd64.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'synergy' instead of './synergy_2.0.1.stable-b1034+59dd93a0_amd64.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 synergy : Depends: libssl1.0.0 (>= 1.0.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

followed by the solution above

sudo apt-get install -f                                    
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I do seem to have a compatible package installed though: 

apt search  libssl1
Sorting... Done
Full Text Search... Done
libssl1.0-dev/kali-rolling 1.0.2m-3 amd64
  Secure Sockets Layer toolkit - development files

libssl1.0.2/kali-rolling,now 1.0.2m-3 amd64 [installed]
  Secure Sockets Layer toolkit - shared libraries

libssl1.1/kali-rolling,now 1.1.0g-2 amd64 [installed]
  Secure Sockets Layer toolkit - shared libraries

 

Share this post


Link to post
Share on other sites
On 21.11.2017 at 1:46 PM, yok said:

I am having a similar problem on Kali

apt install ./synergy_2.0.1.stable-b1034+59dd93a0_amd64.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'synergy' instead of './synergy_2.0.1.stable-b1034+59dd93a0_amd64.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 synergy : Depends: libssl1.0.0 (>= 1.0.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

followed by the solution above

sudo apt-get install -f                                    
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I do seem to have a compatible package installed though: 

apt search  libssl1
Sorting... Done
Full Text Search... Done
libssl1.0-dev/kali-rolling 1.0.2m-3 amd64
  Secure Sockets Layer toolkit - development files

libssl1.0.2/kali-rolling,now 1.0.2m-3 amd64 [installed]
  Secure Sockets Layer toolkit - shared libraries

libssl1.1/kali-rolling,now 1.1.0g-2 amd64 [installed]
  Secure Sockets Layer toolkit - shared libraries

 

Exact same issue here!

Share this post


Link to post
Share on other sites

I use also Synergy 2 on Debian 9 and I had to install the package from here: https://packages.debian.org/jessie/amd64/libssl1.0.0/download

After that, it was working.

Edited by Cirpe03
  • Thanks 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now