SenPi

Synergy 2.0.1 and Ubuntu 14.04 - libqt5core5a version >= 5.5.0

11 posts in this topic

So I wanted to install Synergy 2 on my Ubuntu 14.04 box today, and I can't seem to do that because 14.04 only installs libqt5core5a up to version 5.2.1. I couldn't find any sort of PPA for the newer version, and I tried building it from source, but I can't seem to figure out how to get synergy to look at the source one instead. Anybody have any way to get around this? Thanks!

  • Like 1
  • Sad 1

Share this post


Link to post
Share on other sites

Since I can't post in the linked ticket, I'll post here.
In the linked ticket there was a mention that this would be fixed in the stable release.

I tried installing synergy_2.0.4.stable_b1205+fcb59be4_amd64.deb on my Ubuntu 14.04 LTS and I get the same error.
Any progress on when this will be fixed?

Share this post


Link to post
Share on other sites

Just another data point> I realize I'm talking about a whole different beast, but Ver. 2.xx has run great on my Kubuntu 17.10, (and 17.04 before). Currently Version 2.04.

Share this post


Link to post
Share on other sites
13 hours ago, GranPaSmurf said:

Just another data point> I realize I'm talking about a whole different beast, but Ver. 2.xx has run great on my Kubuntu 17.10, (and 17.04 before). Currently Version 2.04.

Same here, on my Ubuntu 16.04 it installs without a problem as that one comes with libqt5core5a 5.5.1.
Searching around I can't seem to find a way to install libqt5core5a 5.5.1 on my 14.04. (apart from building from source)
I opened a ticket customer support ticket, let's see what they say.

  • Like 1

Share this post


Link to post
Share on other sites
On 1/16/2018 at 9:13 AM, TheFreak said:

Same here, on my Ubuntu 16.04 it installs without a problem as that one comes with libqt5core5a 5.5.1.
Searching around I can't seem to find a way to install libqt5core5a 5.5.1 on my 14.04. (apart from building from source)
I opened a ticket customer support ticket, let's see what they say.

I have the same issue as you had. Any progress or updates?

Share this post


Link to post
Share on other sites
26 minutes ago, lucky6qi said:

I have the same issue as you had. Any progress or updates?

Yes, I opened a customer support ticket:
Question:
Synergy 2.0.4 does not install on Ubuntu 14.04 LTS.
It has a dependency on libqt5core5a >= 5.5.0 but Trusty only gets up to 5.2.1.

Answer:
"We'll be adding support for this Linux distro in Synergy 2.1 which is due Q2 2018."

Share this post


Link to post
Share on other sites

First they said it would be in Stable, now they are saying it will be in 2.1. I'd really like to use this program I already paid for please 

Share this post


Link to post
Share on other sites

Until it is eventually fixed, I keep using version 1.8.8, which does work with Ubuntu 14.04.

Share this post


Link to post
Share on other sites

yeah I can still use the old one just fine, but I paid extra for version 2 even though I already owned 1, and I still can't use it. It's just frustrating

Share this post


Link to post
Share on other sites
On 26/01/2018 at 4:46 PM, SenPi said:

I'd really like to use this program I already paid for please 

For now, you can either wait or take a refund and use Synergy 1. Please contact us for a refund: https://symless.com/contact

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.