JohnCLeBlanc

Does Synergy prevent monitor from going to sleep?

46 posts in this topic

My monitor will stay on permanently in spite of my W10 power management set to turn it off after 20 minutes of inactivity. From searching the web, this appears to be due to a bad hardware driver or some software. in a command prompt, I ran "powercfg /requests and got:
DISPLAY:
[PROCESS] \Device\HarddiskVolume2\Program Files\Synergy\synergy-core.exe

SYSTEM:
[PROCESS] \Device\HarddiskVolume2\Program Files\Synergy\synergy-core.exe

Is it possible that Synergy v. 2.1 is preventing my monitor from going to sleep? Can I disable it without uninstalling it to test this hypothesis? E.g., can I disable services temporarily?

 

Share this post


Link to post
Share on other sites

Great tip thanks! Hopefully this persists beyond rebooting. One of my machines is a Mac; I'll test to see if it's affected since the above solution won't work for it.

 

Share this post


Link to post
Share on other sites

Yes, it writes to the registry and persists indefinitely. And Macs aren't affected from what I've seen.

Share this post


Link to post
Share on other sites

I'm going back and forth between Windows and Red Hat with Windows acting as the host.  Once my Windows monitor goes to sleep, Red Hat will not turn off and actually notifies me that a program will not let it go to sleep.  Do you know anything I can do for Red Hat to fix this?

Share this post


Link to post
Share on other sites
On 11/20/2017 at 5:49 AM, Theo said:

Had exactly the same problem on all clients, so I did

powercfg /REQUESTSOVERRIDE process synergy-core.exe display system

from elevated command prompt on every client machine and it took care of it.

Thanks Theo, sorted my similar issue out. :)

Share this post


Link to post
Share on other sites

my system stopped showing the lock screen after the screen saver when I updated to the 2.0, will the above procedure work as well?

Share this post


Link to post
Share on other sites

I had the same problem with Win 10 Pro 64-bit <> Win 10 Pro 64-bit running Synergy 2.0.2 and 2.0.3

Theo's solution seems to have worked for me. 

Thank you, I never would have found that solution on my own

Edited by Andy Hall

Share this post


Link to post
Share on other sites
On 11/23/2017 at 1:52 PM, Lucas001 said:

my system stopped showing the lock screen after the screen saver when I updated to the 2.0, will the above procedure work as well?

No, not in my experience.

Share this post


Link to post
Share on other sites

Would this change prevent Synergy from being able to wake a secondary system from sleep on mouse movement?  As it stands now I see this issue on and off, but I am concerned if I make the change then moving the mouse to the remote system might not wake it, thoughts?

Share this post


Link to post
Share on other sites
10 minutes ago, PortableTech said:

Would this change prevent Synergy from being able to wake a secondary system from sleep on mouse movement?  As it stands now I see this issue on and off, but I am concerned if I make the change then moving the mouse to the remote system might not wake it, thoughts?

Yes, it will prevent it.

Share this post


Link to post
Share on other sites

That could be an issue as I do not keep a keyboard and mouse attached to the second system, thus no other easy way to wake it up if the change is made.

Share this post


Link to post
Share on other sites
30 minutes ago, PortableTech said:

That could be an issue as I do not keep a keyboard and mouse attached to the second system, thus no other easy way to wake it up if the change is made.

Not an extremely elegant solution but you could run a script to wake it up over LAN.

Share this post


Link to post
Share on other sites

I should have been more clear when I said wake it up.  This is not a case where I need a WOL to get it to power up, rather that Power Management is shutting off the screen to save power.  As it works now, if it does go to sleep which can take hours despite being set at 10 mins, if I move the mouse towards that screen it will wake up the display.  That is what I was trying to describe.

Share this post


Link to post
Share on other sites

There is a downside of Theo's solution which I believe others have noticed.  It is not just the monitor that goes to sleep, so does the CPU.  Somehow you have to manually wake it up.  In my case, you can push the power button but not all systems support this.  My problem is that I have a Linux VM running on the Windows 10 client which performs some builds and backups during the night.   They don't run with this solution in place.

So I would appreciate some instructions on how to undo Theo's fix.  I will go back to manually turning off the monitor until this is fixed properly.   In the meantime, I will probably just set "Sleep" to "Never"

Share this post


Link to post
Share on other sites
1 hour ago, Andy Hall said:

So I would appreciate some instructions on how to undo Theo's fix.  I will go back to manually turning off the monitor until this is fixed properly.   In the meantime, I will probably just set "Sleep" to "Never"

To remove the override do just

Quote

powercfg /REQUESTSOVERRIDE process synergy-core.exe

(without specifying the types of override)

My systems never sleep, only their monitors, so I wasn't aware of the downsides.

Edited by Theo

Share this post


Link to post
Share on other sites

ugh.  this has been an issue going back for ages.

I used to not let my pc's sleep but in the interest of being a little more green and lowering our energy bills, i configured them all to do so.

2 of the 3 allow the monitors to sleep and the pc's to eventually sleep as well.  One (at current) wont turn off displays and thus never the pc.  As per usual ala powercfg synergy is the culprit.

What id like is to be able to wake subsequent pc's by moving the mouse to the edge.  Not wake the displays,j literally WoL aka send a magic packet when the mouse reaches the transition border.

At current ill settle for synergy not keeping pc's up for god knows why though. Also seems to need a service restart relatively frequently to keep it functioning when other pc's DO go to sleep and are re awoken (manually atm).

Def has its kinks still i guess.  

 

Share this post


Link to post
Share on other sites

I've fussed around with the powercfg workarounds, and I'm not convinced they're necessary.  I absolutely disagree with Andy Hall's appraisal, though, that the changes also cause the CPU to sleep. When I did use the powercfg workaround, the CPU did not sleep and the monitor still didn't. After a reboot, the monitor slept correctly, and the CPU still didn't. I didn't spend time investigating the issue, but I believe I had some other software running which prevented the monitor from sleeping.

Share this post


Link to post
Share on other sites

This works great to get the client PC to shut off the display, but for some reason, it doesn't honor the "On resume, display logon screen" checkbox.   It does when I'm not connected to Synergy.   I tried adding "awaymode" to the requestsoverride setting, it doesn't seem to help.

powercfg /REQUESTSOVERRIDE process synergy-core.exe display system awaymode

(This is becoming an issue at work as they're tightening down security practices.)

Share this post


Link to post
Share on other sites

I found "powercfg -requests" a helpful way to discover what might be causing the display to stay on or the system not to sleep.   Also, be sure you have the correct power and sleep options set in Windows 10 or in any virtual machines running therein.  I found there can be some surprising interactions. 

 

 

Share this post


Link to post
Share on other sites
On 11/20/2017 at 9:38 AM, Dash Minus said:

I'm going back and forth between Windows and Red Hat with Windows acting as the host.  Once my Windows monitor goes to sleep, Red Hat will not turn off and actually notifies me that a program will not let it go to sleep.  Do you know anything I can do for Red Hat to fix this?

Checking back in. Any Linux users having the same problem as me, and if so, any workarounds?

Share this post


Link to post
Share on other sites
21 hours ago, Mike Van Pelt said:

This works great to get the client PC to shut off the display, but for some reason, it doesn't honor the "On resume, display logon screen" checkbox.

The screensaver config was set to "no screensaver".  You have to configure an actual screensaver for the "On resume, display logon screen"  to work.

"On resume, display logon screen"  works fine now.

Share this post


Link to post
Share on other sites
On 3/16/2018 at 11:58 AM, Dash Minus said:

Checking back in. Any Linux users having the same problem as me, and if so, any workarounds?

That seems to depend on your window manager. Gnome always tells me that "an application was blocked from locking the screen" or something like that, whereas it works perfectly with Budgie.

Share this post


Link to post
Share on other sites

BTW, I just installed version 2.0.7.  On Windows 10,  It no longer seems to be making power management requests to keep the display and system awake.  On my pair of Windows 10 Pro 64-bit machines it works much better that 2.0.4.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now