Davey

How do I send Ctrl-Alt-Del to windows 7 from Linux

18 posts in this topic

My main node (and therefore keyboard & mouse host) is a linux PC.  I have 2 client nodes running Windows 7 and Windows 10.

I can easily unlock the Windows 10 by pressing space or dragging the logon screen with the mouse, but Windows 7 needs Ctrl-Alt-Del.
I used to use Ctrl-Alt-Break but this isn't working in 2.0.1.

Any ideas?

Share this post


Link to post
Share on other sites

I have this exact same issue where my keyboard and mouse are connected to a Linux PC and the client is a Windows 7 PC.  I am unable to press Ctrl+Alt+Del on the login screen or after logging in on version 2.0.1.

Share this post


Link to post
Share on other sites

As I recall you had to run a special command on Windows to allow a service to send the "Ctrl+Alt+Del"  command on Synergy 1.  It also helped with the escalation issues.  I set it once forever ago but can't find the instructions to try it again.  Not sure if its the same issue in Windows 10 because it wasn't around when I set it before.

Share this post


Link to post
Share on other sites

I found the thread in the synergy 1 forum.  There is a simlar setting in Windows 10.  Not sure if it'll fix your issue:

 

 

Share this post


Link to post
Share on other sites

This is also an issue I'm having with my machines.  I had them set up to use Ctrl+Alt+Pause/Break in Synergy 1 (worked great), but Synergy 2 doesn't seem to be registering it correctly.

Share this post


Link to post
Share on other sites
32 minutes ago, SchwannyT said:

I found the thread in the synergy 1 forum.  There is a simlar setting in Windows 10.  Not sure if it'll fix your issue:

 

 

I had the Windows 7 Policy already set from when I used Synergy 1 so I could use Ctrl+Alt+Del and it doesn't seem to work on Synergy 2.  I verified the values were correct from the link you posted.  Also the Ctrl+Alt+Pause/Break does not work either.

I think this is something the Synergy development team is going to have to fix since features of Synergy 1 were not re-implemented in Synergy 2.  Even after logging in, the Ctrl+Alt+Del  and Ctrl+Alt+Pause/Break key combinations don't work.

Share this post


Link to post
Share on other sites

Hello

where is the CTRL ALT Pause key configuration existing in Synergy 1 to be able to send CTRL ALT DEL on the "remote" windows machine?

is this feature is missing in the new version ?

I'll uninstall v2 and go back to v1 until this feature or the multiple computer unlock is available.

 

Edited by lmas

Share this post


Link to post
Share on other sites

May someone of the Synergy-team gives us an answer to this?

thx

Share this post


Link to post
Share on other sites

This is a pretty important feature for those who are in an enterprise environment. I cannot use without being able to unlock and lock my secondary PC. 

Share this post


Link to post
Share on other sites

+1

My main machine is a Mac and I cannot unlock my Windows 7.  I had the local GPO changed in version 1, but it's not working in version 2.0.4

  • Like 1

Share this post


Link to post
Share on other sites

Any update on this? I use a Mac as my main machine and need to unlock a windows 10 PC. I had followed the tutorial someone linked here with the first version of synergy. It does not appear to be working with Synergy 2, however. 

Share this post


Link to post
Share on other sites
8 hours ago, injaneer said:

Any update on this? I use a Mac as my main machine and need to unlock a windows 10 PC. I had followed the tutorial someone linked here with the first version of synergy. It does not appear to be working with Synergy 2, however. 

No change that I have heard of. Have had to abandon the application.

Share this post


Link to post
Share on other sites

Please could you try Ctrl+Alt+Insert?

Share this post


Link to post
Share on other sites
Posted (edited)
8 minutes ago, Nick Bolton said:

Please could you try Ctrl+Alt+Insert?

Hi Nick,

Didn't work from Linux host (Fedora 27) and Windows 7 Pro client  - both running 2.0.9 (didn't work on 2.0.8 either)

Thanks,
David

Edited by Davey
minor additional info

Share this post


Link to post
Share on other sites
5 minutes ago, Davey said:

Didn't work from Linux host (Fedora 27) and Windows 7 Pro client

Ah, that's annoying. Does it work the other way round... from Windows to Linux?

Share this post


Link to post
Share on other sites
15 minutes ago, Nick Bolton said:

Ah, that's annoying. Does it work the other way round... from Windows to Linux?

I'll test that later, I'm in the middle of long running tests on the Linux box and don't fancy finding out what a Ctrl-Alt-del would do to it O.o
On a side note, I did notice that doing a Win+L from the Windows keyboard on to the linux client did lock both screens which was nice.  Unfortunately that doesn't work in reverse.

Share this post


Link to post
Share on other sites
12 hours ago, Nick Bolton said:

Please could you try Ctrl+Alt+Insert?

Thanks for checking on this Nick. There is no insert key on the Mac keyboard. I've tried just about every combination of CTRL + Option + (another key) that I could think of. None of them seem to work. For now, I've got a second keyboard on my desk to unlock the windows machine. 

Share this post


Link to post
Share on other sites

I just tried to CTRL+ALT+DEL from my Windows 10 server to my Windows Server Essentials 2012 box...  No bueno.  The key combo affected the Win 10 box.   I was able to drag my mouse back to my desktop and hit cancel.    CTRL+ALT+DEL is gonna be important for Windows, Windows Server, and Ubuntu.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now